Page 59 of 59 FirstFirst ... 495556575859
Results 871 to 872 of 872

Click here to go to the first staff post in this thread.
Thread: Elite Dangerous 2.2.03 - Update incoming.

  1. #871
    @TrollhunterX

    You can download the launcher from the ED website - click on Downloads (top-right), suggest trying the smaller download (26MB) first.
    Or use this direct link: http://hosting.zaonce.net/elite/Client-Installer.exe

    The above will give you Launcher version 0.4.5912.0 which is (most likely) the minimum version you need (and the one I am using so I know it works).

    But as Micky suggested, I strongly encourage you to post something in the Support section as otherwise FD won't get feedback that their links/processes are broken (they really need to pay a bit more attention to this sort of thing as it must be very off-putting for new players and/or players who are not comfortable with PCs).

  2. #872
    Cheers. I hope I can get help there. Figuring out downloads/installation isn't my strong point...

    - - - Updated - - -

    Thanks for this, I'll try it for starters. I re-posted in the other place as well.

Page 59 of 59 FirstFirst ... 495556575859