Page 1 of 2 12 LastLast
Results 1 to 15 of 27

Thread: GTX 560 TI dont work with this game

  1. #1

    GTX 560 TI dont work with this game

    anyone having a epic FPS drops looking at a land able planet its is due to a bug with this card even with low settings i get 4fps

  2. #2
    I ran twin 560 Ti's in SLI when the game first came out, all the way up to about 4 months ago when I got a 980.

    Go buy a second one for $70 and SLI them for a quick fix.

  3. #3
    The 560ti is a pretty old card, but you should see better than 4fps! What settings/resolution are you running at, and have you got up to date drivers?

    I've got an old laptop with a gt540m (much less powerful than the 560ti) and on low settings at 1360x768 it will maintain a solid 30fps, not fantastic but playable.

  4. #4
    I'm running the game on a GTX 560. On lowest possible settings I'm still getting between 40 and 60 fps, even in combat. Are you sure you've got things set low enough?

  5. #5
    I played ED with a 560ti on high, it was fine for a year or so. When Horizons came along i noticed it started struggling, had to turn stuff down. I decided i needed an upgrade, bought a 970, life was Ultra good again.

  6. #6
    I played with a 560 Ti on High for about 2 years, up until about 2 weeks ago.

    I had an FPS drop coming in to landable planets, down to about 20-30 FPS.

    One CZ that was above a landable planet, in low orbit, saw some brief freezing, and FPS in the 15-25 range if I was looking at the planet.

    Those two caveats aside, the game was perfectly playable.
    Skipper, should I pick the yellow bananas or the red bananas, because the yellow bananas are green?
    Golf.India.Lima.

    Anaconda: FNCS-2706 'New Horizons'
    Fer-De-Lance: FNCS-2704 'Predator'
    Vulture : FNCS-2703 'Negative Ghost Rider'
    Asp Explorer - Han Shot First
    Cobra Mk. III- Eastbound & Down
    http://earthdefensefleet.net/

  7. #7
    GTX 560 TI doesn't work with this game. Sorry your title was bugging me.

  8. #8
    well problem is im a fall time carer for my sister after mum and dad died we lost every think and what i get as a carer i just cant buy a new card i only get £100 every two weeks ( now thats not a sob story just an explanation ) i really like this game but until i can get a new card i cant play it iv crashed my ship so many times iv run out of cash

  9. #9
    I really wouldn't buy a second 560 for SLI today. SLI is not exactly the most supported feature, and you're delaying the need to upgrade for a year or two, at some point new games will require features that the card simply does not support.

    I got a GTX 950 very cheap and it's doing very well.

  10. #10
    Originally Posted by sintara View Post (Source)
    anyone having a epic FPS drops looking at a land able planet its is due to a bug with this card even with low settings i get 4fps
    Went from a 560 to a 650, still had horrible fps (11) when landing on planets.
    Vanilla 64bit game was fine.
    Moved on to a new card, all is well.
    # apt-get purge engineers

    Look, I ain't in this for your revolution, and I'm not in it for you, Princess. I expect to be well paid. I'm in it for the money.

    Why does the computer keep saying "Friendship Giant Sausage"?

  11. #11
    Until a few months ago i played horizons with a 460 with pretty fair fps. Just had problem with textures because it had only 1GB of vram

  12. #12
    I run with an 1080 on triple monitors and planetary settings can really bog even this beast down when triple heading.

  13. #13
    i've got gtx660 2GB at work and i must turn off shadows and etc light effects to get ~35 FPS at planet's surfaces.
    And you are talking about 560ti 1Gb.
    Sorry for my bad English.

    MSI Z77A-G43, i5 3570k@4GHz, 16Gb, MSI GTX 970 GAMING.

  14. #14
    I guess I had a strong 560 ti then. I was fine on planet surfaces, frame rates between 45 and 60 fps. It was just the initial loading of the texture in low orbit, or flying in low orbit, that saw any real strain on the card.
    Skipper, should I pick the yellow bananas or the red bananas, because the yellow bananas are green?
    Golf.India.Lima.

    Anaconda: FNCS-2706 'New Horizons'
    Fer-De-Lance: FNCS-2704 'Predator'
    Vulture : FNCS-2703 'Negative Ghost Rider'
    Asp Explorer - Han Shot First
    Cobra Mk. III- Eastbound & Down
    http://earthdefensefleet.net/

  15. #15
    Drop the resolution to 720p, turn down supersampling to 1.0 (if it is any higher) or less & turn down shadows & terrain work. Make sure you have the latest drivers from Nvidia, older drivers can cause performance issues, not to mention graphical glitches.

    It would be a good idea to post your DxDiag report as there could be other issues with the system "GTX 560Ti don't work with this game" really isn't much information for support, or indeed anyone to help you out any more than they have already.

    - - - Updated - - -

    Originally Posted by GilliganTX View Post (Source)
    I guess I had a strong 560 ti then. I was fine on planet surfaces, frame rates between 45 and 60 fps. It was just the initial loading of the texture in low orbit, or flying in low orbit, that saw any real strain on the card.
    The card should be fine, but it depends on the rest of his system too, GPU isn't everything unfortunately.
    My System:
    AMD Athlon 860k, MSI A88X-G45 Gaming MoBo, 16GB DDR3, Asus Strix GTX 960 OC 2GB, Windows 10.

Page 1 of 2 12 LastLast