Results 1 to 15 of 15

Thread: EDLauncher Crash with work around.

  1. #1

    EDLauncher Crash with work around.

    Hi

    Windows 10 Pro, 15063.296.

    The launcher now crashes when ever I attempt to load it. Tried running as local admin. Assuming this is a recent Win10 update rather than Frontier update.

    Work around seems to be copying C:\windows\system32\d3d9.dll to the same location as EDLaunch.exe then its fine.

    DXDiag and app crash (rename to .wer)

    Report.wer.TXT DxDiag.txt

    Code:
    Faulting application name: EDLaunch.exe, version: 0.4.5912.0, time stamp: 0x581cb554Faulting module name: d3d9.dll, version: 6.2.15063.0, time stamp: 0x631de416
    Exception code: 0xc0000005
    Fault offset: 0x000000000000fd0c
    Faulting process ID: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report ID: %13
    Faulting package full name: %14
    Faulting package-relative application ID: %15

  2. #2
    Thank you very much for the fix.

  3. #3
    You are most likely running an outdated version of rivatuner or MSI Afterburner. Update that stuff.

  4. #4
    Originally Posted by wildw1ng View Post (Source)
    Thank you very much for the fix.
    Afterburner is at current version but there is a version 7.00 beta for Riva server. Installed that, removed the d3d9.dll from edlauncher.exe folder and weirdly it works now.

    Do you know the reason behind this?

  5. #5
    I am running Afterburner 4.3.0. Should i switch to a beta version?

  6. #6
    Originally Posted by wildw1ng View Post (Source)
    I am running Afterburner 4.3.0. Should i switch to a beta version?
    4.3.0 is the latest version of AB but if the Launcher is crashing you should update to 7.0.0 Beta for RTSS: http://www.guru3d.com/files-details/...-download.html

  7. #7
    There is, of course, the much easier workaround of starting MSI afterburner after the launcher has loaded up.

  8. #8
    After the recent Win update I get constant crashes with a comp reboot! Would this workaround help me, too?

  9. #9
    Ok, obviously not as I don't have this file in the directory mentioned. Is this Win 64bit?

  10. #10
    Originally Posted by space voyager View Post (Source)
    Ok, obviously not as I don't have this file in the directory mentioned. Is this Win 64bit?
    It's a different bug for you I'm afraid, you would be better off raising your own bug report with as much information as you can get, such as a DXDiag report.

    Computer reboots tend to indicate hardware issues however...

  11. #11
    It worked great until the recent Win update... Thanks, will try to work something out.

  12. #12
    just a suggestion try reinstalling the graphics driver (clean install option)if you just got the creator update also check power settings on pc and graphics card are set to high performance

  13. #13
    Originally Posted by kosch View Post (Source)
    Afterburner is at current version but there is a version 7.00 beta for Riva server. Installed that, removed the d3d9.dll from edlauncher.exe folder and weirdly it works now.

    Do you know the reason behind this?
    I was having this problem and copying the d3d9.dll to the edlauncher folder solved the problem.

    Is updating my MSI Afterburner from my current 4.3.0 to the 7.00 beta a wise move? Or should I just live as I am until it's no longer in beta?

    Note: I use it for a Rainmeter display on a second monitor!

  14. #14
    Originally Posted by NeilF View Post (Source)
    I was having this problem and copying the d3d9.dll to the edlauncher folder solved the problem.

    Is updating my MSI Afterburner from my current 4.3.0 to the 7.00 beta a wise move? Or should I just live as I am until it's no longer in beta?

    Note: I use it for a Rainmeter display on a second monitor!
    I had the same problem (games crashing with afterburner started) after the windows creator update.
    I have upgraded rivatuner statistic server to 7.0.0 (afterburner 4.3 contains RTSS 6.6.0) and everything is solved.

    Release notes for rivatuner stats servers 7.0.0 says (www.guru3d.com)
    Hook engine is now using alternate shorter x64 hook trampoline to provide compatibility with Windows 10 Creators Update Direct3D9 runtimes
    Someone had the same problem here.
    https://forums.frontier.co.uk/showth...locks-EDlaunch

  15. #15
    Originally Posted by MrVaad View Post (Source)
    I had the same problem (games crashing with afterburner started) after the windows creator update.
    I have upgraded rivatuner statistic server to 7.0.0 (afterburner 4.3 contains RTSS 6.6.0) and everything is solved.

    Release notes for rivatuner stats servers 7.0.0 says (www.guru3d.com)


    Someone had the same problem here.
    https://forums.frontier.co.uk/showth...locks-EDlaunch
    OK.. Updated to 7 beta and so far so good...

    Still on 4.3 Afterburner...

    Ta