Results 1 to 3 of 3

Click here to go to the first staff post in this thread.
Thread: Has anyone else trouble with the ED-Launcher?

  1. #1

    Has anyone else trouble with the ED-Launcher?


    recently i upgraded to Ryzen. And since i had an AMD CPU before, i just swapped boards and kept my Windows 8.1 Install. Recently though i had a spare SSD and wanted to try Windows 10. I have my Steam Library on a normal HDD, while both OS's are on SSDs.

    Pretty much every game just launches on Windows 10 without any problem - except Elite Dangerous. The Launcher crashes with no real Error message.

    Has anyone transfered their installed Elite Dangerous to another System and tried to launch it? Is there something i missed? Steam registered the Game in the AppData directory, asked for the Keys and after that - nothing. Can't launch Elite on Windows 10. It's running fine on Windows 8.1.

    Yes: i tried the d3d9.dll thing and i have the newest RRTS running, i do not have the Creators Update...any suggestions where i can look for logs?

  2. #2
    I would suggest trying the steam validate integrity of game cache
    if that fails use the launcher options log off machine function reboot then use the launcher options validate game files
    check you have this installed if it wont install it just means your dx library already has the required dlls in the library
    also ensure your win 10 netframe work is higher than 3.5 and your c++ redistiributables are updated windows 10 update should take care of that mind
    also try a clean install of the latest gfx driver for win 10 system in case its using a migrated or generic version

  3. This is the last staff post in this thread. #3
    Hey John Rhys,

    Problems with the launcher are commonly caused by the .Net framework as Strontium has suggested. So I would advise for you to try installing the latest versions of .Net 3.5 and 4.5 from Microsoft, which can be found here and here. Can you also make sure that the "Turn Windows features on or off" page has both entries under Microsoft .net Framework 3.5.1 unticked.

    If this doesn't work, please send us a ticket, which you can do by going here.