Page 1 of 12 1234511 ... LastLast
Results 1 to 15 of 170

Click here to go to the first staff post in this thread.
Thread: Removal of Win32 support for Elite Dangerous

  1. This is the last staff post in this thread. #1

    Removal of Win32 support for Elite Dangerous

    Greetings Commanders,

    As mentioned last year in this forum post by David Braben, the constant focus on pushing technological boundaries within Elite Dangerous has required us to reconsider our support for the Win32 version of the game client.

    The removal of the Win32 version will affect less than 0.01% of Elite Dangerous players and we’ll be reaching out to those few people directly to make sure they’re well aware of the changes. The change will come into effect at the release of 2.4 – those trying to access the 2.4 beta will be required to play on the Win64 version also.

    If you’re unsure this will affect you, you can find a guide online that will help, such as this one here: https://www.howtogeek.com/howto/2172...ndows-answers/

    As we mentioned above, the vast majority of players won’t notice a difference, and if we believe you’ll be affected we’ll get in touch with you directly. The change allows us to make the Win64 client the most stable and safe version of the game possible, and focus on the future of Elite Dangerous.

    Thanks.

    Ed

  2. #2
    About time! You did good in holding off for as long as possible, but it's quite clear that 32-bit architectures are now basically as dead as the Dodo as far as PC architecture is concerned - sure there are still folks out there using such PC's, but as you say, a fraction of a percentage.

  3. #3
    Onward and upward! Thanks for the update Ed. :)

  4. #4
    Thanks for that, Ed.

    Originally Posted by Edward Lewis View Post (Source)
    As we mentioned above, the vast majority of players won’t notice a difference, and if we believe you’ll be affected we’ll get in touch with you directly.
    .... and that too.

  5. #5
    Originally Posted by Edward Lewis View Post (Source)
    ...The removal of the Win32 version will affect less than 0.01% of Elite Dangerous players and we’ll be reaching out to those few people directly to make sure they’re well aware of the changes...
    Did someone say customer service?

  6. #6
    Good news, especially for Steam users who won't have to download double the data at every update.

  7. #7
    Does this affect us ZX Spectrum 48k users?

  8. #8
    This can't come too soon, looking forward to it.

  9. #9
    Originally Posted by Rob At Work View Post (Source)
    Does this affect us ZX Spectrum 48k users?
    I think we can honestly say that there will be absolutely zero effect on ZX Spectrum 48k users.

  10. #10
    Hooray for everything. Looking forward not back, up not down. Yeah !

    Flimley

  11. #11

  12. #12
    Your removing support for my heavily upgraded Altair 8800? I've only had the thing 43 years...

  13. #13

  14. #14
    Thank you Mr Ed! About time too. :)

  15. #15
    Just for clarity then, how will this pan out for 32bit people (and their computers)?
    I guess it's not the same sort of situation as for those that didn't buy Horizons and stay on a 1.x version of the game? So from 2.4 (or 1.8 for base?) they will not be able to play?

    Just to be clear, I think it's the right call, just wondered and can't remember what was said before.

Page 1 of 12 1234511 ... LastLast