Thanks for that. Turns out I had disabled the jumped script, so the system context wasn’t being updated. I probably did that when I reset all my json files, then went through and disabled the many scripts I don’t use. I never meant to switch off "Jumped", so I didn’t think to check until you mentioned it. However it happened, enabling the option solved my problem. Thanks again team!