Results 1 to 11 of 11

Thread: Failed to find GUID for device

  1. #1

    Failed to find GUID for device

    I know there are threads about this and other binding issues in the beta forums, that are now archived, and a bug report, but I have yet to see a solution to this.

    A few days ago I finally loaded into 3.0 and realised I had not backed up my bindings. I had to work off a set from about 18 months ago. After about 30 mins of messing around I had things back to normal and saved off a copy of the new binding file.

    However today I have logged back in and that set of setting was not loaded. In the BindingLoadingErrors.log it states, for my binding file:

    Failed to find GUID for device: 068EC010
    Failed to find GUID for device: 068EC010

    I use a Thrustmaster HOTAS and CH Peddles. I assume this GUID relates to one of those.

    The default Thrustmaster settings works, but not my own.

    Before I make a bug report, does anyone have a solution to this?

  2. #2
    Could you please post the binds file that has the problem?

    Those messages are referring to a CH device (USB vendor ID 068E), but apparently not the pedals which would be device 00F2 or C0F2 depending on if you're running them through CH Control Manager (C0 with, 00 without); I assume that since it's a "managed" device ID, it may be the code used for "combined" mode? If you just have the pedals, I would recommend uninstalling the Control Manager software entirely since it is IME completely unnecessary for the pedals, but can under some circumstances become unstable and cause bluescreen crashes.

    Assuming you're only using the pedals for yaw, the section in the binds file would look something like this without the CH software:

    		<Binding Device="068E00F2" Key="Joy_ZAxis" />
    		<Inverted Value="0" />
    		<Deadzone Value="0.02000000" />

  3. #3
    Hi Shadowdancer, first off thank you for your response.

    I am using CH pedals, and the CH Manager. Whilst the peddles are perfectly fine to use, they are very complex to set up and manage. When I first set them up I had to use some old threads on these forums to set up a virtual device. I followed the instruction successfully without really understanding what I was doing beyond a basic level (to get them to work as a rudder, and work in an analogue fashion I need to follow steps X, Y and Z and it should work), that was my level of understanding.

    I do have a lot of problems with this. Often when loading the game the pedals are not working. If I load the manager and simply click mapped mode they work. But in my Devices and printers I have this, which does not really look right and might be leading to my issues.

    That said today I logged in and my setting where back again. No idea how or why.

  4. #4
    I've never had problems using the pedals without any extra software, they just show up as a 3-axis input device. Binding them to an axis in game works no different than with the software. The only thing you really need the control manager software for is games that don't support input from multiple devices and need to combine multiple (CH) parts into a single virtual device, which isn't an issue for you since you only have the one.

    So really, try removing Control Manager and use the pedals "raw", it will be much more reliable.

  5. #5
    I'll give it a try later. But if I recall when I tried that they were not analogue. EG they were 100% on or off as opposed to being able to use them to turn fast or slow depending on pressure.

  6. #6
    Sounds like you were binding to left/right instead of the axis. You may also need to run Windows's built-in calibration in case it's way off.

  7. #7
    Unfortunately I am back to square one with this again.

    If I uninstall the pedals and the reinstall them without configuring them with the CH control manager they are recognised but only work in a basic way. I use them for yaw, so have to assign them directly to the left and right yaw. You can't assign the device to the axis (it yaws all the time). But then they are in a purely digital mode, EG on or off with no gradation.

    But as soon as I try to calibrate them with CH control panel (you can't calibrate them with Windows 10), they become unrecognised by ED and the whole binds file fails to load with the error "Failed to find GUID for device: 068E00F2"

    In fact since last reinstalling the pedals they will not work at all in ED, with the same error unfortunately.

    At this point I don't know why they worked before as a virtual device and don't now. I don't know if this is a conflict between the device and E-D, In incorrectly set up device, or a windows problem.

  8. #8
    I have them working again, correctly, for now. I deleted all my maps from CH control manager, reinstalled the pedals. I managed to find a very old post that I had bookmarked (and now saved the info off in a text file), which showed how to make a virtual device what will be recognised by E-D.

    This is what I had before. I can only assume something when wrong after the update to 3.0 and I had to make a new virtual device. So I am back up and running... for now.

    I have to say which the pedals themselves function very well, I can't recommend CH Pedals. They are far from plug and play.

  9. #9
    Originally Posted by Saool View Post (Source)
    as soon as I try to calibrate them with CH control panel (you can't calibrate them with Windows 10)
    I'm pretty sure you can, assuming you removed the control manager completely it should be somewhere in "Set up USB game controllers". I'll need to check later though if it's available for the pedals (edit: just checked, I can calibrate the pedals through Win10 onboard tools), but it definitely works for stick and throttle. That said, I've never needed to calibrate the pedals, they somehow were perfect from the beginning opposed to the other two parts, and they were very much plug&play for me.

  10. #10
    Nope. It just has a graphic saying please use Control Manager as you can't do it using windows.

    Loaded in again today. No maps. Device not recognised.

    Sick of this now.

  11. #11
    Disconnect the pedals, reboot, uninstall Control Manager, and reboot again. The pedals should show up in all-caps as "CH PRO PEDALS" and Windows will allow you to calibrate them as a bog-standard game controller.