Results 1 to 7 of 7

Thread: Emergent Gameplay or technical problem?

  1. #1

    Emergent Gameplay or technical problem?

    I would have posted this in the Dangerous Discussion as it's part story and part hardware but in a funny way what happened to me could almost have been a part of the game.

    I was nearing the completion of a massacre mission with only one or two targets left to kill in a High Combat Zone. I had taken a serious beating as my Imperial allies and I were constantly in the minority and was down to 28% hull, no heatsinks and only 1 SCB left.

    I suddenly seemed to have a problem: Although I had let go of the joystick (Saitek X52), my Clipper was twisting and spinning fast. By opposing the directions of the spin, tilt and yaw motions with the stick, I could stabilise her, but had to constantly keep fighting for control.

    I decided to go for the final kill before leaving the CZ. At first I attempted to target an Anaconda, but got swarmed, popped an SCB, heat through the roof so I ran!

    Restored to full shield health and normal temps I spotted an enemy Asp separated from it's allies, and with some help, we took her down. All the while flying in crazy unexpected erratic spins and constantly trying to correct my flight path.

    Supercruised to the station - around 500Ls - and it was really hard keeping her pointing in more or less the right direction.

    Arrived and requested docking permission... and now it got even more challenging!

    I got through the slot first time, just snagging the inside edge a little. A boost freed me, and I then somehow tumbled onto the right pad (25).

    But it took me around 4 minutes of fighting the Clipper on the pad to manage to dock. Most of my shields were gone even though I had 4 pips to Sys as I repeatedly slammed onto the pad, lurching, yawing and pitching violently.

    The relief when I finally clamped onto the landing pad with just one minute on the docking-clock left. I had already planned my exit.

    I was pumped, excited, delighted.

    I could have exited the game at any point. Restarted with the stick freshly plugged in as it's a problem that only manifests itself when I am in the middle of combat (i.e. more extreme use than regular flying around lazily ). But at some point I decided this was combat damage in action, and as I had no AFMU or repair limpets, my only hope was to go land somewhere.

    Anyway, emergent gameplay aside, can anyone suggest why this might be happening with the X52? i.e. works fine 90%, but when I fly combat, it sometimes throws a wobbly mid session. Sometimes it's this "out of control" craziness, other times the LEDs begin flashing manically, only to behave perfectly the next time it's plugged in.

    Cheers and o7

  2. #2
    Maybe the sensors going a bit of balance if you use the joystick more "violent" during combat? Then when you plug it out and in it resets itself and function correctly until next time you do action combat with vigorous joystick handling.

  3. #3
    Check the cable between the joystick and the throttle, it can work loose.

  4. #4
    Did you accidentally switch off flight assist?

  5. #5
    Open the control panel for the X52. The page with all the red bars and sliders that light up when you press the buttons or move the stick. Keep that open when you play. I had similar problem and that fixed it.

    There is a bug with the MadcatZ drivers or something and keeping the control panel open stops something cycling that affects the stick.

  6. #6
    Nice tip, Necronaught. Except I (probably mistakenly) "updated" my drivers to the Logitech ones, and now I can't find anywhere to get the stick's control panel up. Any clues?


  7. #7
    Originally Posted by Jakester13 View Post (Source)
    Nice tip, Necronaught. Except I (probably mistakenly) "updated" my drivers to the Logitech ones, and now I can't find anywhere to get the stick's control panel up. Any clues?

    Sorry I do not know. I still have the original drivers from 2015.