Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

Thread: Low FPS after 1803 and Nvidia update

  1. #16
    Originally Posted by CMDR_Cosmicspacehead View Post (Source)
    I haven't played ED for a while, but prior to 1803 I was getting consistently smooth gameplay in Crysis 2.

    Now after the update, when I launch the game, it runs like garbage, until I switch to windowed mode and back to full screen.

    That's with the latest nVidia drivers.

    And Crysis 1 no longer launches.
    I feel your pain...

    I don't know about those of you who tried the above solution but unfortunately I'm back to square one :/

    After a full evening of ED at 45-60FPS, I turned off the PC for the night. Upon switching the PC on, Windows prompted me that the system is SLI capable. SLI was working the night before, however after restarting the next morning, Windows somehow turned it off. I re-enabled SLI hoping that's the only issue. When I started ED in the evening I came across the exact same issues, only this time I decided not to let the low FPS keep me from my fun and it just kept getting worse and worse (12 fps) until I got the following System Error message:

    "The file has failed to load after multiple attempts as Direct3D cannot lock a buffer.

    Please check your machine meets the minimum specs for Elite: Dangerous. If the minimum specs are met then upgrading graphics drivers may rectify the problem."

    At present the only solution is uninstall drivers, run DDU in safe mode, reinstall drivers and NEVER EVER reboot/shutdown the PC

  2. #17
    The usual Microsoft stuff..


  3. #18
    Originally Posted by john willi View Post (Source)
    Hello cmdr, I had the same, at the bottom of this thread the issues were solved for me and another cmdr.

    Comment #13

    https://forums.frontier.co.uk/showth...-Driver-19fps!

    All the best.
    Thanks, this worked for me too

Page 2 of 2 FirstFirst 12