Results 1 to 3 of 3

Click here to go to the first staff post in this thread.
Thread: The game won't launch

  1. #1

    The game won't launch

    Frequency of the Bug/Issue
    All of the time

    Describe the Issue
    XBOX ONE: Everytime I go to launch the game at first it says "getting your game ready" then 30 seconds later it says "Something went wrong. Wait a minute or so, then try again. If it still doesn't work, select Help for more to try. (0x800705b4)" So then I wait five minutes, ten minutes and still nothing. Strangely it was working the day I got it but the next morning (today) it stopped working. Now when It was working I had one crash and when I went to save career it didn't want to load so I couldn't save. I ended up turning off my xbox then going to sleep and here we are.

    PS I'd like to add that I downloaded an update beforehand and I'm not sure if that was the cause or not

    Things I've tried:
    Restarting Xbox
    Reinstalling the game

    Reproduction Steps
    (Maybe) Reinstall the game. For me the Icon for the game doesn't even show
    1) Select Jurassic World Evolution from My Games & Apps
    2) Look for a popup that says getting your game ready
    3) Wait for Some thing went wrong

    Expected Result
    Something went wrong

    Actual Result
    Something went wrong

    Supporting Evidence URLs

  2. #2


    It was actually my Xbox causing the issue not the game. I tried loading up another game and it did the same thing. I hard rested my Xbox and now the game works.

  3. This is the last staff post in this thread. #3
    Hey Amaro,

    We glad to hear that this is no longer an issue.