Results 1 to 13 of 13

Click here to go to the first staff post in this thread.
Thread: Scrolling does not end ... sometimes yes

  1. #1

    Scrolling does not end ... sometimes yes

    Frequency of the Bug/Issue

    Describe the Issue
    When i scroll and move in game with WASD and middle mouse button the scrolling sometimes is locked and i can't move elsewhere. I try to scroll and press other keys but it will continue to automatic scroll in one direction until I leave the game. On restarting the game everything is fine but then after 10 sek - 1 minute it will scroll again automatically.

    Reproduction Steps
    Press WASD and use middle mouse button

    Expected Result
    Scroll in wanted direction

    Actual Result
    scroll in any direction like someone is pressing and holding D

    Supporting Evidence URLs

  2. #2
    Do you have a game-pad peripheral plugged in? I had something similar with a 360 controller plugged in, but not since unplugging it. Could be unrelated.

  3. Click here to go to the next staff post in this thread. #3
    Hey VValdmeister,

    Thanks for the report.

    I've not been able to reproduce this issue on my end.

    This does sound like you might have a controller connected like Bosenator suggested.

    It might be worth disconnecting and reconnecting the mouse and keyboard also to ensure there is no issues there.

    Does the side scrolling continue when the mouse and keyboard is disconnected?

    Any additional information would be helpful in tracking down what is happening here.

  4. #4

    Same issue

    Reproduction Steps
    Press WASD and use middle mouse button

    In fact I think this Bug occurs when you tab out of the game or use the steam overlay while pressing one of the navigation buttons (W A S D).

  5. #5

    same issue

    when I move, it doesnt end... I disconnected and reconnected the mouse and keyboard also to ensure there is no issues there and I dont have any controller. I tried to removed the game and installed it again but didn't work as well. I don't want to loose my game!

  6. #6

    Scrolling Issue

    Also have this issue - using WASD or using right-click

    I have also experienced this when using edge scroll a few times... but not as much as using WASD

  7. #7
    Having the same or very similar issue. Sometimes it just scrolls in one direction as if I was holding W (or ASD). It stops only when I press W manually - as if it needs the button to be released to stop despite it was not held down in the first place. Opening and closing the steam overlay also fixes it temporarly. On the Steam forums someone believed this to be related to a bug in the overlay implementation of the game.

  8. #8

    Also Having this issue

    I initially thought the game may have installed incorrectly, and after reinstalling the game worked fine for a while but then it started happening again. hitting WASD would make me infinitely go in that desired direction (e.g. hitting W would make me go forward until I either went to the main menu, or quit the game entirely).

  9. #9


    I've played for 20h with no issues. Then at some point I started on the extra island where it all began. And I think I also pressed TAB or SHIFT or some key combinations, but not sure if it's related. Then my keys started to get locked like WASD as well as mouse middle button or left button where I could release it and it still did the same thing as when I held it down. The only solution here was to press ESC and even restart the game as it kept on following me even after save game reload.

    But that's not all, some hours later after spending 1h in game without saving, my ESC button broke down. Every other key worked other than ESC button. I was only able to save the game by using an external program to initiate ESC pressing which triggered the options menu. The game is lacking the UI option opening or even autosave button and autoload buttons. So most people wouldn't know how to solve this issue and would have lost their progress. I don't have anything plugged into my PC and only using mouse and keyboard. Have never experienced an issue like that in any games I've played on steam and I have tried out like 100+ games. What kind of a stupid problem is this to have???

  10. #10

    Update on Issue

    4 hours in - After the WASD issue came up again, my whole game froze.

    Everything in the background continued to work - excluding the game.

    Could also not end the task - had to restart my PC.

    Somethings that might contribute + notes:
    1. I am using Steam Beta (the new chat is amazing)
    2. Shift tab quite a lot
    3. Stopped using WASD completely, issue still came up (only using right click to drag)
    4. Continuous playing for long

  11. #11


    Also this problem has been encountered by more people as we can also read about it in this previous thread: here.

  12. #12
    Your link does not function.

    Ok, i have plugged in a wacom tablet but the pen is in a penholder and i havn't used it for a while. Today I played 2 hours and nothing happend. I remember, the error occured after i have done some SHIFT+TAB. Maybe it's a steam overlay problem?

  13. This is the last staff post in this thread. #13
    I have fixed the broken link in Vadim Cool's comment above :)