Results 1 to 7 of 7

Click here to go to the first staff post in this thread.
Thread: Roll Axis not detected

  1. #1

    Roll Axis not detected

    I bought a slightly used (but still very good in condition) X52 Flight stick and throttle, maybe a year ago. After a break from Elite, I came back to it. In the middle of a dogfight, the game stopped letting me roll. I checked in the settings, the control hadn't been somehow unbound. The flight stick still was about to move in all directions, and I was still able to use pitch and yaw ingame. I tried leaving the galaxy and rejoining, but nothing changed. I even closed the game out and relaunched, but still, no success. Any ideas what caused this, or how to solve it?

  2. #2
    does the roll function of the stick work in other games or in a joystick test mode
    have you tried unplugging and using a different usb port too?

  3. Click here to go to the next staff post in this thread. #3
    Hi Fruitsalad,

    I would recommend testing the recommendation by STRONTIUM DOG as this will help to clarify where the issue may be!
    Secondly, if you would rather discuss this matter with ourselves at support please do send us in a ticket and we can dive a little deeper into this matter for you!
    (ticket via

  4. #4
    Originally Posted by STRONTIUM DOG View Post (Source)
    does the roll function of the stick work in other games or in a joystick test mode
    have you tried unplugging and using a different usb port too?
    I used this site to test my joystick:

    After rotating the joystick on the yaw axis, pitching up and down, and holding it in the roll left/right position, this is what I found:

    1. It doesnt seem to be detecting that I'm holding it in a still position on the roll axis, I saw that even when holding it still, the website thought I was flinging it back and forth slightly.
    2. It did detect that I rolled it all the way over, and held it still, on the right side. But, when I moved the joystick to the left and right again, it barely detected that the stick had moved, if at all.

    It can occasionally detect the stick moving, but most of the time, it doesn't even know I'm trying to roll (Keep in mind that the stick worked perfectly fine yesterday morning. The problem with the roll axis literally happened in the middle of a dogfight).

  5. #5
    try the windows calibration tool too is it the same kinda result there also?
    also check the stick does not have a ps4\pc mode switch that has been accidently switched

  6. This is the last staff post in this thread. #6
    Hmm, that is very strange. Do you think you could make a ticket for us if you're still having troubles?? We can get into the nitty gritty details there, and try and find a fix for you. You can do so here:

  7. #7
    from the evidence so far submitted I am speculating at this point that a sensor or wire maybe loose within the joysticks pid ( proportional integral derivative) as the softwere/hardwere test submitted so far indicates the characteristics of a faulty feed back loop fault hence the "thought I was flinging it back and forth slightly."or rocking (but that could just be a dead band issue) back and forth so suggested using one more test using the calibration softwere too to confirm my guesstimation on infomation given
    as to wether this problem is softwere or hardware related to which I think it could be the latter joystick hardware atm but that has still as of yet has to be confirmed by either another flight game or joystic calib/config software
    there are bundels of free flight sim demos etc out there to test a stick with