Results 1 to 5 of 5

Thread: Founders Permit missing?

  1. #1

    Founders Permit missing?

    Hi all, its been a long time.... I bought ED as a Premium Beta backer way back on 9th May 2014 for the princely sum of 100.00. I dropped in now and again to play it but never really had the chance for any decent time on it.... until this week! Yes it is over 4 years later.

    So I've finally amassed a couple of million credits in about 2 days, starting from 150,000 credits that I had amassed over 4 years since purchase. A friend of mine reminded me about Shinrarta Dezhra and that I would have a permit to go there due to being an original Premium Beta backer. So today (yes it is only 7am) I decided to head on over there to find that I don't have a permit and can't get in.

    Does anyone have any ideas what the problem might be? I am using the same email address and same commander name. Nothing has changed in that respect. Do I have to do something specific? Or is it a bug I need to report?

    Hope someone can help.

    Cheers,
    Gareth (Commander X6)

  2. #2
    Originally Posted by gcparris View Post (Source)
    Hi all, its been a long time.... I bought ED as a Premium Beta backer way back on 9th May 2014 for the princely sum of 100.00. I dropped in now and again to play it but never really had the chance for any decent time on it.... until this week! Yes it is over 4 years later.

    So I've finally amassed a couple of million credits in about 2 days, starting from 150,000 credits that I had amassed over 4 years since purchase. A friend of mine reminded me about Shinrarta Dezhra and that I would have a permit to go there due to being an original Premium Beta backer. So today (yes it is only 7am) I decided to head on over there to find that I don't have a permit and can't get in.

    Does anyone have any ideas what the problem might be? I am using the same email address and same commander name. Nothing has changed in that respect. Do I have to do something specific? Or is it a bug I need to report?

    Hope someone can help.

    Cheers,
    Gareth (Commander X6)
    Nope. Sounds like you should report it.
    I have not heard of things like this for ages, and when I did, most of the time, it wasnt a mistake. Normally, the CMDR had not actually purchased the correct level to get automatic access to Founders. It was confusing at the time, and the intervening years made that worse. Support will be able to tell you whats up, and pretty quickly too most of the time.

    PS. Welcome back !

  3. #3
    Yes report the problem, they are normally quite quick at sorting it out. Welcome back and enjoy the game.

    Fly safe Cmdr's
    o7

  4. #4
    Cheers all. I can see my original order on the Frontier support site and I've opened a ticket so hopefully all will be resolved soon. (note I'm now using my proper account after discovering I used a different email address 4 years ago! - maybe that has something to do with it).

  5. #5
    Originally Posted by x6tus View Post (Source)
    Cheers all. I can see my original order on the Frontier support site and I've opened a ticket so hopefully all will be resolved soon. (note I'm now using my proper account after discovering I used a different email address 4 years ago! - maybe that has something to do with it).
    ... That'll probably be it. Welcome back.