Results 1 to 11 of 11

Thread: Problem with Frontier: First Encounters

  1. #1

    Problem with Frontier: First Encounters

    So I tried Frontier: First Encounters and after a few trade runs, something very problematic suddenly made the game unplayable: my ship was drifting to the right! Set the speed to 0.0 and the ship accelerated to the right, no matter what I do. That is not what makes the game unplayable. The worst part of it is when leaving a starport: I crash on the right side of the mailslot and my ship explodes. That's what I mean by "Unplayable." Had no problem with that while I was low fuel. Did a deluxe repair, drive only AND equipment only and nothing seems to work!

  2. #2
    First of all, welcome to the forum Terraria MC!

    Do you have a joystick/gamepad plugged in?
    If you are playing the original then it may be taking some input from it and drifting or rolling depending on what your "other options" settings is for "Elite control method in space". You would need to disable the joystick in DosBox or disconnect it otherwise.
    If you are playing one of the reverse engineered versions that run natively in Windows without DosBox, then there will be an option in the .cfg file to turn the joystick off, although that's normally the default setting... so if you're wanting to use the joystick, it might be that it's spiking an input or needs some deadzones defining.

  3. #3
    I have to agree with Andy here - it sounds like the joystick input is knocking the ship off to the side. However, if there's no joystick plugged in, make sure that "sticky keys" isn't turned on (usually automatic by Windows when pressing one key repeatedly a bunch of times)

  4. #4
    I tried to unplug the joystick and nothing is different. Forgot to mention that it stopped doing that when I bought another ship or when I loaded another saved game that dated from before the incident. It would only happen when I loaded that saved game that dated from the time the incident happened. I didn't yaw or roll. The lateral thruster was pushing me around and even the autopilot/docking computer didn't care about that lateral thruster.

    Just in case you were wondering, I am using DOSBox 0.74

  5. #5
    ..check your equipment screen - perhaps the thruster was damaged, and so unable to fire? If this is the case, then this damage is manageable by rotating 180 and using the opposite, working thruster, with FA-on or off, and avoid relying on AP until you've made repairs (in principle, you can fly an entire mission, from launch to landing and completing any objectives en route, using just FA-off with only a single working thruster.. just a question of having the 'right stuff')..



    Alternatively, if you're playing the original FFE then perhaps it's the 'velocity fudge' feature/bug - this can suddenly slam you into terrain seemingly randomly, even though your ship's in perfect working order. In any event, with the time and effort involved in getting DOSbox up and running, you'd be much better off installing the latest version of FFED3DAJ, which allows you to disable this particular 'feature' in the .cfg, as well as enabling a host of really useful other ones.

    Do stick with it though! If you got this far, you must already have noticed this is an infinitely better game than ED.. the sense of achievement of every flight is a big part of that; the core experience that ED cheapens to total gaming bankruptcy, here, it's you vs the elements, playing the causal and deterministic against the random and procedural, it's the difference between rFactor 2 and Pole Position, realism instead of canned FX (especially with FD's velocity fudge disabled).

    Best advice is to use the latest FFED3D build, disable the velocity fudge in the config, map all your thrusters to a familiar key cluster (WASD, Lshift & Lctrl, Q & E for roll, or whatever), check your equipment status screen in the event of a thruster problem, maybe also a visual inspection from external view (if all thruster anims are enabled for your ship - some aren't), and learn to compensate and manage damage... flying FA-off for long distances is largely a matter of learning which speeds are manageable at which ranges for a given thruster power - generally you don't wanna be much more than 200 kms as a planet looms into visual range, and 30 kms before touching atmosphere - whatever the range to a target, divide that number by two then apply max thrust towards it until halfway there, then spin it round and continue applying max thrust in reverse for a smooth arrival. So long as you have a single working thruster anywhere on your ship, you can bring it home..

  6. #6
    OP may not be running on a Windows system Bounder, or might want the original retro feel of the game...
    ...and well, discussions about alternatives to the official games are off-topic in this sub-forum!


    @Terraria MC - I don't suppose that you could share the save game that has the issue somewhere?
    It'd be interesting to poke around and see what the problem might be if it's not a controller issue.

    (If you switch to the advanced edit view when replying, then there'll be an icon in the top row to attach a file - although you'd need to zip the save up first for it to be allowed. It's easier to post a link the file on dropbox/skydrive etc if you are already setup + familiar with those)

    If not then what ship has the issue and where are you docked at?

    If it's not a bug - then the other thing that I can think of (as you'd said that the ship was repaired) is that perhaps the station you're docked at has a serious rotation/drift or there's a high-gravity effect and the thrusters aren't strong enough to keep up... if you docked using a high stardreamer setting to "jump" to the station and then skipped through the docking sequence too then this wouldn't have been noticed, especially if the ship was damaged anyway.

    If you wanted to keep the original ship, then you might be able to escape by setting the autopilot to another station/target in the system prior to launching, then as soon as you do launch engage autopilot and accelerate time ASAP before it hits anything?

  7. #7
    I just got FFED3D and it looks amazing! All I need to do is map my joystick. Do I use AXIS_X- for example? I am using the AJ version of the game. One last thing: the thruster doesn't appear to be firing, so I think it's that velocity fudge thingamabob.

  8. #8
    Hi - could you ask any questions about that build over in the off-topic thread for it, and I'm sure there'll be a few familiar names there ready and able to help you out. (this sub-forum is only for the official Frontier releases)

    If you could post a link to the save game too, I'll be able to see if it's a broken thruster that's causing the problem.

    o7 Commander!

  9. #9
    Okay, here is the save file:

    https://drive.google.com/open?id=1ZK...HnGD5i_Y3kdQmj

    Here are the actions I recommend to try figuring out what is going on:

    Head to Argent and turn on autopilot
    Dock at Argent. Notice the ship is slightly moving to the right
    After docking, leave without refueling. Notice the ship goes in a straight line
    Return to Argent and refuel
    Lift off. I hit the mailslot. I don't know if it will happen to you, but it happened to me while touching nothing.
    After I bought a ship, it all stopped. It didn't stop after a repair. It just drove straight in the mailslot.

  10. #10
    Thanks for the save game Terraria MC, I can explain what the issue is now...

    At some point it looks like your ship had its right thruster destroyed and you've probably repaired it?

    For some reason, FFE holds two sets of thruster values for the player's ship. One set against the ship object itself (and on every AI ship object too) and then there's a copy in a general block of game data - this set is what the shipyard checks to look for damaged equipment. When accelerations are calculated for ships though, the game uses the thruster values stored against the objects.

    Somehow, these values have gotten out of sync. The copied set of thruster values are all at full strength so the shipyard doesn't show that any repairs are required. Against the ship itself though, the right thruster has 0 strength - so this is why the ship slides like it does!

    I couldn't reproduce hitting the docking bay on exit, but found that the autopilot didn't even get close to the station when trying to dock at x1 speed!
    (I couldn't test much as unfortunately also found that DOSBox manages to corrupt my video memory and crash Windows after about 5 minutes, possibly an nVidia driver/shadowplay incompatibility )

    I took a quick look at the assembly code that repairs the thrusters in FFE and it does look like it should be updating both sets of values, so I'm not too sure how this issue could have happened. I also edited a ship so that the right thruster values were both zero (destroyed) and then tried repairing it in DOSBox/FFE. It worked correctly... <shrug>
    I guess that it's unlikely you'd be using an early FFE executable from floppy-disc or original CD rather than the patched, remastered CD or shareware version?

    But there may well be something 'off' with the repair function though, as John Jordan does seem to have reworked the routine in JJFFE. Also the thruster values will self-correct in his build and the subsequent GLFFE/FFED3D builds - so if you wanted to continue playing with that ship in the DOS version, a work around would be to briefly fly/dock the ship in one of the remakes - you'll see the autopilot functioning correctly - then save the game and the ship should then be fixed.
    Otherwise to manually fix the ship in the DOS version of the game, you would need to find a station shipyard that stocks the engine, then sell and rebuy it for the ship - that would reset the thruster values.

    Hope that helps!

  11. #11
    Originally Posted by AndyJ View Post (Source)
    Hi - could you ask any questions about that build over in the off-topic thread for it, and I'm sure there'll be a few familiar names there ready and able to help you out. (this sub-forum is only for the official Frontier releases)

    If you could post a link to the save game too, I'll be able to see if it's a broken thruster that's causing the problem.

    o7 Commander!
    As a 'Mostly Harmless' noob like me I don't think Terraria will be able to post to the FFED3DAJ thread due to the new rep requirement for posting in the section, and neither will any other newcomers to the game. Can you think of any way around that? Perhaps get the thread moved. It will be a real shame if new FFE players aren't able to post bug reports or other contributions.

    I'm also going to drop this bug report here since you'll get notifications from this thread having posted in it.

    I noticed you'd done a couple of releases since the last time I played so I did a clean install of the version 1.13 beta 7 over beta3_Ittiz. The minor issue I encountered is that with usekeybinds=1 set it is not possible to modify the commander name in the main menu, or the save file name in the save screen. This was a blocker until I worked out that the bug was related to the usekeybinds setting and that I could work around it by just setting usekeybinds=0 to change the name and then set usekeybinds=1 again afterward. Now it doesn't bother me but I just wanted to let you know about it.