View Entry Info: HOTAS + pedals no longer detected by Game

Category:
PC/MAC Bug Reports
Results 1 to 8 of 8

Click here to go to the first staff post in this thread.
Thread: HOTAS + pedals no longer detected by Game

  1. #1

    HOTAS + pedals no longer detected by Game

    Date & Time of Occurrence
    3 OCT 2018 @1825

    Frequency
    1

    VR?
    None / N/A

    Location
    Launch

    Ship/SRV?
    N/A

    Ship Type
    n/a

    Commander Name
    CMDR Rieck

    Description
    I logged onto the game today and none of my controls worked. I checked the control setup and the controls were reset to default keyboard settings. I attempted to reset my control settings, but the game no longer detected my HOTAS + Pedal input. The only control it detects is the XBOX 360 controller if I plug it in.

    I double checked my devices on my system and confirmed that they are fully detected by the computer and all inputs operate without isssue. I logged into another game on steam and all my controls work there.

    I have a WORTHOG HOTAS and THRUSTMASTER PEDALS setup.

    Currently cannot play the game as it is now. Not willing to go back to keyboard/mouse.


    Steps to Reproduce
    n/a

    Additional files?

  2. Click here to go to the next staff post in this thread. #2
    Hey CMDR Rieck,

    Thanks for your report - I am going to move this over to the support section of our forum where they'll be able to troubleshoot why this has been reverted and guide you through how to get a bindings file set up so this doesn't happen again.

    Stay safe out there o7

  3. Click here to go to the next staff post in this thread. #3
    Hi there CMDR!

    This can happen when permissions are messed around with, and sometimes your file hierarchy can become corrupt, clearing your bindings.

    So, what we're going to try is to make sure that your keybinds stick! You can do this by:

    C:\Users\%username%\AppData\Local\

    1. Locate your bindings directory as above
    2. Backup/copy the whole Bindings folder.
    3. Start ED and make ONE change to any of the default configuration files. This will change the name at the top to "Custom".
    4. Apply the change and then make a copy of the Custom.binds file in the same directory. Rename the file however you wish, keeping the ".binds" extension. So, for example, Fred.binds
    5. Open the new file in a text editor and change the preset name to match the name of the file, minus the .binds extension:




    6. Delete any other files in the Bindings folder aside from your new custom file and StartPreset.start

    7. Go back to ED and open the Controls menu and find the new entry in the list. You shouldn't need to leave the game for it to re-read this directly. In the list you should see a new binds profile as you named it.

    If that doesn't work, please create a ticket, and we should be able to help you more from there! You can make a ticket here: https://support.frontier.co.uk/topic.php

  4. #4
    Interesting ...

    ... Even F D support are saying to rename custom.binds file. Does this mean that we are nearer seeing as "Save As" option in the Options\Controls menu I wonder?

  5. #5
    I tried what you recommended, but it didn't work. I confirmed that there is nothing wrong with the bindings. In the bindings folder I opened the bindings error logs and found the following message:

    There where errors when loading preset file: Custom.2.0.binds
    Missing devices: ThrustMasterWarthogJoystick, ThrustMasterWarthogThrottle, T-Rudder

    There where errors when loading preset file: Custom.3.0.binds
    Missing devices: ThrustMasterWarthogJoystick, ThrustMasterWarthogThrottle, T-Rudder


    Aside from the obvious grammatical error, I've been able to confirm that the game is simply not detecting the HOTAS + Pedals. Any other game detects the controls just fine.

  6. #6
    UPDATE.

    Upon further research, I discovered that if you access the game on STEAM via BIG Picture mode, your HOTAS system will no longer register. I have gotten around it by opening the game outside STEAM.

  7. #7
    Originally Posted by CMDR Rieck View Post (Source)
    Upon further research, I discovered that if you access the game on STEAM via BIG Picture mode, your HOTAS system will no longer register. I have gotten around it by opening the game outside STEAM.
    Oh yes that. You should be able to fix that by disabling generic controller configuration in Steam's controller settings, or alternatively—as you discovered—by not using Steam because why would you.

  8. This is the last staff post in this thread. #8
    I am glad to know that you have managed to resolve the issue yourself.

    However, please do not hesitate to get in touch with us again by opening a ticket, which you can do by clicking on the following link: https://support.frontier.co.uk/topic.php

    Fly safe cmdr!