Results 1 to 3 of 3

Thread: Sudden lag that makes game unplayable

  1. #1

    Sudden lag that makes game unplayable

    Hello everyone!

    So as the title sugest's, I am experiencing sudden lag on the game.
    I've been playing this game without any problems since day 1, and now all of a sudden, I clicked play and I experience so much lag that makes it unplayable..
    Now this is odd because I haven't played in a week, I even did the graphic's card update (NVIDEA update 417.22 lauched on december 3rd 2018) without playing it right away, but today I lauched the game and I experienced extreme lag..
    I thought it was because the saved game had a lot of stuff going on but, I tried to lauch old ones and I have eperienced lag in every single one of them..
    Almost forgot to say that this only happens when I lauch some saved game or new one, because on the main menu everything runs smoothly as it should.
    Sooo, may the cause be the update of the driver?? Or is this something that someone else is experiencing?
    Well either way I just want to find some solution and play the same way I used to.

    I dont know if this is usefull or not but ill leave it here:

    Nvidea GeForce GTX 1050
    Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
    8GB RAM
    1920x1080, 60Hz

    Hope you can help
    - Neoshifters

  2. #2
    Jurassic World Evolution Moderator Global Moderator Lora Craft69's Avatar
    Please make a post in the tech support forum here.

    I leave the thread open in case someone else experiences the same lag but it's best that you handle this with the support team.

    Thanks.

  3. #3
    Oh sure, didn't think about it.. Going to post it there, thanks for the help