• Good news Guest, we've updated our reporting system to make it easier for you to report issues to us!

    Head over to https://issues.frontierstore.net/ to report, vote, and give feedback on the issues that matter most to you!

3D-Gizmo Advanced move tool bug

Severity
Moderate

Frequency
All of the time (100% reproducible)

Area of Game Affected
Buildings

Description
Hello there,

Here I am again with another well known bug issue inside of the Planet Coaster community which we really would love to see fixed. Its been in the game for more than a year (probably since BETA or something) Im afraid. But until now we havn't see a fix for this issue. I can try to explain this really hard with typing, but I do think this video explains it enough incl. the footages..
https://youtu.be/DCgnWEaYHg0?t=13m50s

We really really really would love a fix for this issue :)

X DeLady


Steps to Reproduce
Explained in the video. Using several non grid pieces it sometimes makes it not possible to use the 3D gizmo how it should work
 
Yes. Thank you for posting this. Building can be so frustrating. I often feel like I am trying to stick two repelling magnets together when I'm trying to move objects around.
 

Vampiro

Volunteer Moderator
This has been an issue for quite some time. Actually it surprises me i couldn't find any previous bug reports on this as this has been a much discussed issue in the past.

Hopefully this is something that can be fixed.
 
Wasn't this because moving multiple selected objects in a building will move according to the world axis, and a single selected object is not?

Is the angle of the wall changed before placing in the video?

It can be really annoying indeed.
 
I don't think this is a bug. This is about understanding the 3d gizmo and multi-selection.

Use the 'reset rotation' button in the gizmo. Do this before rotating, multi-selecting and duplicating the multi-selection.

Edit - I'm getting different results in testing, so removed my earlier remark. I still think 'reset rotation' is handy for the times multi-select and duplicate causes the misalignment.
 
Last edited:
No.. I consider this a huge bug. I struggled with this a lot last night while building. If you place an item down in the maps axis it seems to work for a bit. Until you select more items.. Then it goes off at slight angles.. Or even worse angles sometimes. It's really not predictable at all unless you want to say knowing it's going to screw you over is predictable.
 
Either way, it's annoying when it moves at a slight angle. I'd rather have all objects move along the axis of the building then the random directions we sometimes get.

I'm already "advanced moving" single objects because multiple objects don't stick to the axis.
 
It's weird because sometimes.. If you pick up two items it goes off in a weird angle.. Choose 3 and it's back to normal.. Or a different angle altogether. And it doesn't even have to be different pieces or pieces that are turned different ways. You could make a completely straight line of say.. A fence... And it will go haywire when you try to move two or more.
 

Bo Marit

Lead Community Manager
Staff member
Thanks for the feedback everybody! We're currently looking into what's happening. If you want to email over any save files along with steps that you remember made it happen, you're welcome to.

Please continue to report issues like this so we can see what we can improve. Thank you again [heart]
 
Take some art shape tubes and copy them into a longer beam (problem gets worse when you slightly rotate the beam) and see the orientation of the 3D gizmo get all messed up. It seems to completely random how it will end up but it happens every single time. This obviously shouldn't happen since all of the art shapes that make up the beam have the exact same orientation.
 
Yep, this is happening to me as well now, had the issue before the latest patch that was supposed to fix it but the game is freezing up when advanced moving again, it seemed to be ok last week without any issues and then suddenly since Saturday 18th August its started happening again I have no idea why it could be suddenly doing it again since Saturday and being ok beforehand, seems very wierd to me.
Seems to be happening in an almost empty park with no guests, just a few random blueprints, haven't tried playing in another park yet but i suspect the game will freeze up at some random point whilst advanced moving again, just to note I am moving several pieces in one go rather than just single pieces, even so this still needs looking at and fixing as its getting very frustating now and making the game a little unplayable for me.
 

QA-Mark

Frontier QA Team
Staff member
Please can we ensure that we keep issues separate, for clarity.

We are currently investigating 2 reported issues relating to the advanced move tool:


  • Selecting multiple objects and using the advanced move tool changes the widget axis orientation
  • The game sometimes freezes when using the advanced move tool
When adding information, please ensure that it is posted in the correct thread, as it can get confusing!
 
Hi all, just to update you on this, been playing for almost a solid 2 hours today and no freezes, this is in offline mode in Steam so this seems to be a major cause of the freezing whilst advanced moving, the freeze seemed to happen to me whilst playing in online mode with Steam friends on.
If you are still experiencing this then it may be worth trying it out in offline mode, also reply to this post so the dev team can get more evidence from us and look at it and see what can be done :)
 

Joël

Volunteer Ambassador
Volunteer Moderator
Hi all, just to update you on this, been playing for almost a solid 2 hours today and no freezes, this is in offline mode in Steam so this seems to be a major cause of the freezing whilst advanced moving, the freeze seemed to happen to me whilst playing in online mode with Steam friends on.
If you are still experiencing this then it may be worth trying it out in offline mode, also reply to this post so the dev team can get more evidence from us and look at it and see what can be done :)
Hi Andypuk1980,

Thanks for your replies.

Please be advised that your post is in an incorrect thread. This thread is about the 3D-Gizmo issue, not about the game freezing / crashing issue.
Pay attention to what QA-Mark said above and post replies in the correct thread, in your case this one: https://forums.planetcoaster.com/showthread.php/32915-Planet-Coaster-crashes

You will also receive a PM in order to make sure that you take notice of this.

Let's hope that both issues get resolved soon.
 

QA-Matt

Frontier QA Team
Staff member
Hi Schief_Bief,

Have you toggled on 'Averaged Orientation in Advanced Move (Experimental)' in the game settings menu?

If so, then this is intended behaviour.
 
Top Bottom