ANNOUNCEMENT April Update - Coming 23 April 2019

Do they realize the game is virtually unplayable until they fix the power priority changes.

1. You can't do long range travel. Power changes will knock you out of supercruise to often and cause damage.(exploration including current trips, Small jump ranges, etc.)
2. You can't use ships with unpowered shields.
3. You can't do anything involving consistant instancing or loading.
4. There is a problem with jumping into systems turning in your hardpoints screwing up power and not turning them off.
5. I believe there is more but I can't remember.

Maybe this sounds insignificant to some but this is literally stopping anything but play close to a station and it's still lethal there. The game is broken until these things are fixed. It is literally in an unplayable state!

Anything power wise short of something that works not matter the power loadout is unusable. Anything involving loading of any instances is unplayable. That is most of the game. There are only a few things that are doable in the game atm.

Do they understand how bad this is. Are they even working on it right now?
  1. This only affects builds that go over 100% power with anything deployed.
  2. Related in part to 1 but even when not is only a problem for those pushing the boundaries for example if you scoop at below 66% and take a little longer the additional heat from an operating screen isn’t an issue.
  3. I don’t really understand this comment.
  4. I can see this being a problem but haven’t seen it myself but again a max power usage of 100% or less would avoid the issue.
  5. I am sure there is.
Don’t get me wrong the resetting power is a serious issue and will hit a lot of my fleet quite hard but it isn’t doing more than making me have to add a module check on drop from cruise currently and can be avoided by correct ship choice until it is fixed.
 
  1. This only affects builds that go over 100% power with anything deployed.
I disagree. It affects all builds that go over 100% power with all modules enabled regardless of the hardpoints state. E.g. all proper exploration builds.

it isn’t doing more than making me have to add a module check on drop from cruise currently and can be avoided by correct ship choice until it is fixed.
This is not working. You may check that priorities are OK before the drop and then got it changed immediately after the drop. So you find yourself in a dead ship which tried to power on all those AMFUs, for example.
Overpowering because of weapons deploying is just a particular case and an easiest one to control. The situation is much worse than that...
 
I disagree. It affects all builds that go over 100% power with all modules enabled regardless of the hardpoints state. E.g. all proper exploration builds.


This is not working. You may check that priorities are OK before the drop and then got it changed immediately after the drop. So you find yourself in a dead ship which tried to power on all those AMFUs, for example.
Overpowering because of weapons deploying is just a particular case and an easiest one to control. The situation is much worse than that...
If your build is over 100% with nothing deployed then it is beyond the help of the priority choices. Yes I know some long distance travel builds shut down everything so they can minimise mass and maximise jump distance I have never considered the ability to bypass as many stars as possible or travel as fast as possible to be part of exploration. I do have a Phantom that I am turning into an explorer and it does have currently some modules, AFMUs, turned off they have not powered themselves up since the update, they are turned off because the build is incomplete and I still have to work on the power plant.

By on drop I meant I drop and then check the modules not check them before.
 
Since the update I cant plot a jump to ANY system. I cant even select one of my bookmarks or change anything on the filter option of the galactic map.
 
Since the update I cant plot a jump to ANY system. I cant even select one of my bookmarks or change anything on the filter option of the galactic map.
Does it say anything when you try to plot a route? Any errors? Is the button greyed out? Can you jump to nearby systems via nav panel?
 
Does it say anything when you try to plot a route? Any errors? Is the button greyed out? Can you jump to nearby systems via nav panel?
Nope. Nothing. I'm out on dw2 and I can select a system from the nav panel but that's it. If I try to select the next WP via bookmark, which I can get to cause j was heading to it with no issues before the update, it goes right back to my current system
 
Maybe your FSD range isn't large enough, or you don't have enough fuel? Try logging in and out. Also try fiddling around with the plot settings - you might have some filters which are not applicable in the current location:
  • Economic/Fastest route setting.
  • Star types setting.
If it all seems right, try selecting economical route and see if you can jump from there. Hope this helps ;)
 
Yes I know some long distance travel builds shut down everything so they can minimise mass and maximise jump distance I have never considered the ability to bypass as many stars as possible or travel as fast as possible to be part of exploration.
Fair point. But on the other hand installation of the reactor big enough to power on all existing modules, even those you will use just from time to time (like AFMU) just a waste of credits, materials and ship mass. Underpowering and normally disabled modules is a rather standard for a decent exploration ship.
I do have a Phantom that I am turning into an explorer and it does have currently some modules, AFMUs, turned off they have not powered themselves up since the update, they are turned off because the build is incomplete and I still have to work on the power plant.
Well, I had that experience with self-enabling modules. And a lot of other people too - most complains are about self-enabling shields, but this is about any module in fact.
 
Uff, what the hell happened?
I thought the auto-center of the FSS was fixed with the last patch, now it is back again!! I'm out in the black and no intrest to continue the journey if i need to swing around so much for nothing. No hotfix for that so far? :(((

Rant off
 
In the original Elite back in the 1980’s (yes, I’m that old) you got different music every time you docked at a station. It’s sad that ED currently only has the Blue Danube, I miss the variety of docking music and hope they bring it back.
 
In the original Elite back in the 1980’s (yes, I’m that old) you got different music every time you docked at a station. It’s sad that ED currently only has the Blue Danube, I miss the variety of docking music and hope they bring it back.
I think time & age might be clouding your memory there, Blue Danube was the docking computer music in the versions of Elite that had DC music.

Frontier Elite 2 brought in much more classical music, but still played Blue Danube for docking.

I could be wrong though, I only played Elite on the Electron, Speccy & c64.
 
I too played Elite back in ‘84, and I only recall ever hearing only one piece of music - the Blue Danube. (Amstrad CPC 464)
 
Top Bottom