Are assassination missions bugged?

I took one and every time I drop into the mission related signal source it is totally empty. I’ve done it about four times already. Are they bugged?
 
I did a few of these a couple days ago and they worked for me. I do get the empty instance once in a while for other things though.
 
Done 50+ in the last couple of days - all worked fine 🤷‍♀️
Is there something I’m doing wrong then? Am I not actually supposed to enter the signal source? Also, the signal source faction is different from the target faction. It says mission target though. I tried to mode switch, just did it a sixth time in the signal source is empty.
 
I'm stacking system & faction* - all working fine for me.

If it's blue mission signal sources it should be fine - though if you have another type of mission in-play then it could be for that...

A lot of assassination targets will interdict you, which saves going all the way to the USS, though you can't rely on that.

* can't make a famine without breaking factions ;)
 
Top Bottom