Can't install the latest update on VR version at Oculus

Hi guys,

For two days I've been clicking on the Update button via the Oculus store to install the latest update that was released a few days ago.

It goes through the motions of counting down my download then 'optimising the updates' (whatever that means). Looks like its finished but when I click on the game to launch it wants me to update again...and again...and again...until I'm sick of it.

Am I doing something wrong?

Yes I've rebooted my computer...re-logged into Oculus store and turned off virus protection and none of these make any difference.

And yes, I've also posted on the Oculus forum, just thought I'd try here as well.

Anyone else experienced this?

ED in VR is AWESOME btw [smile]

Chris
 
I had the same issue. It just hung on 'installation'. I tried rebooting and reopening OH but the same problem persisted. I tried a 'repair' of the Oculus Home installation and that messed up. In the end I had to completely remove OH, delete a load of OH files manually, restart and fully reinstall OH and ED. Worked then though!
 
Last edited:
New patch today and I have the same problem again despite a fresh uninstall of ED and all of Oculus Home with the previous patch. What's the problem FDev?
 
Last edited:
It's not an FDev issue, it's an Oculus issue.
https://www.reddit.com/r/oculus/comments/8wa38q/what_on_earth_is_the_preparing_to_download_step/

Your guess is about right - we are scanning every file to see if we have to re-download it in case there were local modifications. Also, if the file was changed, we are scanning to find partial content we can reuse instead of re-downloading it. In _general_ this takes less time than downloading it would take. It's not our hash which is slow - it's the overhead of opening and closing and other fixed costs for every file and jumping in and out of managed c# code and optimized c++ code (which is what we use to do the actual scanning and hashing).

This process works great for games like EVE: Valkyrie and other games that have a single or a few massive files. It would be a terrible experience to redownload 20G when instead we can reuse 19.95G of it and only download the changed 50MB.

This doesn't work as well for games like Elite that instead have literal thousands (over 27k, actually) of tiny files. At that scale, per-file overhead dominates, and as you noticed our actual disk throughput goes nearly to zero. Compared to something like EVE where we can actually peg your SSD because we read and hash fast enough (I hit 300MB/s as reported by task manager in my synthetic test where I filled the main .pak file for EVE with random bytes and started an update, but only using 5% of CPU).

We made the decision that, for most cases, scanning the local game installation would take less time than downloading the whole thing over again from scratch. Also, internet connections can be metered and we want to minimize the impact we have on those. VR games aren't usually known for being 'small'.

I'm sorry that this does make for a worse experience for Elite. We are always looking for ways to make things better, balancing making tradeoffs (whether from more complicated / 'one-off' code, or negative effects in other scenarios) vs. the benefits we get from them.
 

Ian Phillips

Volunteer Moderator
Thats from 6 months ago -is it still valid?

This is what I'm seeing right now
Error

Can’t Reach Oculus Runtime Service

Your Oculus software may be updating. Please wait a minute and try again. If the issue continues, contact Oculus Support.
 
Last edited:
This thread describes a different issue from what I can tell. The issue discussed is the slow progress of the “Optimising download” step. Whilst this is annoying it is not the issue that I, and by the look of this thread, others have. This issue I have is that the game won’t update at all. From what I can see posts about this specific issue in the Oculus forums are referred to FDev...

Maybe these issues are related but the outcome appears different.

This issue has only occurred for me since 3.3.02. Previous updates were ok. The thread you linked to is much older than this.
 
I'm also having the same issue with my Oculus. " Please wait a minute and try again. If the issue continues, contact Oculus Support" I highly suggest Frontier work with Oculus to figure this out quickly. I'm not computer sabby and don't want to be manually adding or deleting files. From someone who has played this game for a few years straight. This is a huge turn away. Please fix it and fast.
 
Latest minor update failed in the same way again for me.

I uninstalled the game in Oculus Home and directly reinstalled it. This allowed the new version to be installed. I don’t think it downloaded the entire game again either.

Still broken though...
 
Could the stand alone installer from fdev work?
Im on Vive/Pimax but started with the stand alone version on an Oculus dk2 and its still working as it should.
 
Could the stand alone be used to download/install the most recent version and copy/replace the folder over the oculus install?
 
I have the same issue. It affects other games to. I've reinstalled windows from scratch, formatting the drive, reinstalling everything and the same problem.
I've raised a ticket with Oculus and whilst polite we are in week 2 now. So far I've had disable virus software and restart router. So if anyone has managed to get this working let me know.
 
I had this, drove me insane. Only way I could fix it was to reinstall Oculus. You can make a backup of any games so you dont have to download ED again.
 
happens to me every time.
fix each time for me has been to hit uninstall from oculus home..... then reinstall

it is not as bad as it sounds as despite it telling you it uninstalled, it seems it doesnt.......... because on then hitting reinstall it happily downloads the patch successfully and is good to go in a few mins. i am guessing all it does is uninstall the last patch rather than the whole game and then it works ok but this is total guess work from me.
 
Top Bottom