CV1 Black levels finally fixed for me! Weird solution.

EDIT: Since this post is being linked to from Reddit, I have not been able to reproduce what I happened to accomplish here by accident and since I wrote this, Oculus have made changes to image quality via updates.
-----------------------------------------


I've always had a grudge with one thing on the CV1 since day 1. I thought the image looked a little washed out and there was colorbanding in coronas and in the dark part of space in Elite, the edge between black and gas clouds wasn't smooth anymore like it was on DK2 with 0.6.0.0, it was unrealistic sharp. Something looked wrong and I tried a thousand things. I always suspected the HDMI Range for TV's to be the culprit but the Rift is supposed to bypass that and the controls are not available anyway. Read about others that their black levels fixed by running the Rift on the DVI port with an adapter, and others fixing it by reinstalling Graphics drivers. I tried it all. Fiddled with the registry. Even tried to find some hidden setting for Oculus Brightness. No luck, whatever I tried.

I have a HTC Vive now also and there space and gradients are smooth and black is really black so you all know I have something to compare too.

Anyway, my normal setup from my PC's GTX 1080 is DVI connected to an ASUS 1080p 144hz monitor and the CV1 in the HDMI. Like most single screen owners have it installed I suppose.

Today I took a long HDMI cable, put HDMI -> DVI converters at each end, disconnected my ASUS monitor from DVI and connected it to Displayport instead, and then I ran the long DVI->HDMI->DVI cable from my DVI port to my projector because I want friends to be able to watch what happens in VR on the big screen. Then I reset the HDMI range to the projector to FULL RANGE.

And now Rift black levels are fine. WHAT!?! This must be a bug, but if it's on Nvidia, Oculus or Frontier I can't tell.

I have to do further examination to find out exactly what I did that fixed it, but I won't touch it now for a while, I need to enjoy space in full color range.

If you are having bad blacks in Elite on CV1, try connecting a TV to DVI or something, change to full color range and compare.

The funniest thing with this is that the Rift still sits in the HDMI port like it always have been and that there are no settings Rift specific that I've changed. Somehow HDMI-range setting on other devices affect the Rift.
 
Last edited:
I had the same thing happen to me. about a week ago, I was building a pump mount for my pc case. i had unplugged everything and was working on my PC elsewhere and when I hooked everything back up, my rift displayed vibrant colors again.. wish i knew exactly what i did so i could reproduce it if need be. the washed out colors was my biggest complaint too.

EDIT: the change seems to be that i plugged my rift into the HDMI on the card and ran the TV HDMI through a DVI output on the card. I previously had it configured the other way around.
 
Last edited:
I just updated nv drivers and had the washed out colors again. i went into the nvcp and under 'change resolution' I set the output color format to YCbCr422. that single setting seems to bring back the rich black lvls and vibrant colors.
 
Last edited:
Agree something weird is going on in those colour space settings. The Rift driver seems to bypass some of the Windows colour space settings and it just ends up looking wierd. Not bad, but not as good as it should be. The Rift should be able to display as well as a decent monitor (as far as I know, without knowing the actual panel specs etc).

My monitor window looks fine with no undue black gradients, but in the Rift there's definitely less true black and obvious grading. (I'm ignoring the not-quite-black panel noise between pixels in the Rift. I presume the Vive suffers the same noisy black too?

Like you guys, I went into display setting, under resolution and changed to the Full Colour (it was set to the 16-250 range option). My card driver here at work doesn't seem to have any option.

Also worth checking the nVidia Digital Vibrance - it should be default at 50% - higher or lower might wash out or otherwise affect the display. Not sure if it applies to games etc though.

Blacks and dark greys (and whites etc) are the hardest colours to reproduce on any display, given you really only have 256 shades to play with for pure black to pure white.
 
I use a HDMI to Display Port adapter to counter this. Its a known bug in the NVidia driver. Nvidia had released a tool, to force full color range to the Rift, but they already took it off the net and say its fixed... Obviously it is not.
They say, you have to do a fresh driver install. It did not work for me, as i always do a fresh install with each update.

I came to that solution because user Y2K found it out by coincidence. The difference is immense, actually more than 16% extra color range or more than 2.5 mil values. As this bug is around since before i got my Rift, i have a whole new experience since last week...

If you experience the same problem of missing contrast and washed out colors, simply order a HDMI to Display Port adapter. Make sure, its a passive adapter, supporting 4k resolution, HDMI 1.2 and 3D audio. Such adapters are available for around 10 bucks.
 
Last edited:
If you experience the same problem of missing contrast and washed out colors, simply order a HDMI to Display Port adapter. Make sure, its a passive adapter, supporting 4k resolution, HDMI 1.2 and 3D audio. Such adapters are available for around 10 bucks.
Yes, I have been aware of all the things you mention, but I never tried with DisplayPort -> HDMI adapter. Some where saying a DVI -> HDMI adapter solved it and that was I had at hand at the time, but it didn't solve it for me, tried clean drivers, tried everything else. The people this worked for maybe had an adapter with it's own EDID (active adapter?). Due to how I solved it (see OP) by having a TV-rated device attached to DVI and changed that to full range, there seems to be some weird bug in that the full range setting for the DVI port affects the full range setting for the HDMI port. They seem connected in some way. Maybe because the Rift bypasses the layer where the driver can change the signal, the enumeration somewhere gets mixed up.

My theory right now is that the Rifts EDID doesn't tell the Graphics card what mode to use. Maybe EDID have to be ignored too to bypass the driver like the Rift does, and then you get the default mode for DVI and HDMI which unfortunately is Limited Range if the monitor doesn't say otherwise and due to the bypassing, the rift have no chance to tell the card what it wants.
 
So, let me get this straight. My Rift is now using the HDMI to display port adapter into the display port socket on the 1080. If I now change the resolution colour config for the main monitor (because there is no config option for the rift as it is "direct") to Full range or YCbCr422 this should help with the colours and colour banding ??
 
Last edited:
@stevesidea: Yes, basically changing the setting of some other display device affected the Rift for me.

I have not myself tried with having the Rift in a DisplayPort via adapter. Ordered one for later though for further testing.

What I am saying is that with the Rift in the HDMI socket on your card as Oculus intended, connecting a TV/proj to the DVI-port and setting that to full range solved black levels for me in the Rift which is weird to say the least. I am speculating on why this happens in the post above.

EDIT addition: This have bugged me since the day I got the Rift (quite some time ago) and NOTHING I did could change the bad black levels and yesterday it finally happened by chance when I added a projector to the card with full range setting.
 
Last edited:
I just updated nv drivers and had the washed out colors again. i went into the nvcp and under 'change resolution' I set the output color format to YCbCr422. that single setting seems to bring back the rich black lvls and vibrant colors.
Yes, and the funny thing here is that you changed color format for your TV and that changed the color format in the Rift, am I right?
 
Last edited:
I honestly find it horribly strange both headsets use HDMI at all and by what I see its not even hdmi 2.0, two 1200x1080 panels at @90 and we are getting pretty close to the edge of what hdmi can carry.

If setting 4:2:2 works it's odd. But kind of makes sense since its compresses the colour range from 12bit to eight and that frees a lot of bandwidth.and ycbcr is a compression on top of that.
And I would be very very suprised if these hmd's has 10bit panels. (TFT panels for most gaming monitors is 6bit btw)

But hdmi (and dp) handshakes between devices and sorts out a signal that often and most likely can void all settings if the cable or device doesn't register enough bandwidth.

Could be this scales down colour range (cause most people are quite blind to it) and it saves a lot of data.
And the use of a dp -hdmi adaptor maybe forces it to run full range or something and having a TV connected fools nvidia control paNelson so the colour settings to open up, but unless it doesn't sense a TV connected nvidia hides all these options cause I guess people are dumb. (I'm not talking the people here but the ones who call me over and pay me 40$ to change batteries in their mouse)

Anyhoo this whole thing is weird, but one thing is sure something isn't right here.
 
Did some quick napkin math, and my concerns for bandwidth should be entirely unwarranted.

I have also updated my gpu drivers too 372.54 and it seems the colour section of the change resolution is now present (it wasn't with the old drivers, this is probably what settings the mentioned the "tool" used to change)

I have also ordered a DP-hdmi adapter, what ever it does I would get to hook my rig back up to my HT again for some couch gaming :p
 
As far as i know, the reduced range uses 15 - 235 instead of 0 - 255 values for displaying the color, like the dynamic range used for TV sets. And it is based on a flawed device setting, which usually can be changed in the monitor setup, but as the Rift doesnt show up there... I guess, as long as you have a 1.2 HDMI port or adapter, there is nothing wrong with the bandwidth.
 
I have now tried all possible settings currently available.
And they do nothing.

It honestly doesn't and never did look as bad as poor colour space settings would but it does look like poor gamma and contrast/brightness calibration .
 
Yes, and the funny thing here is that you changed color format for your TV and that changed the color format in the Rift, am I right?
Yup.. I also tried playing with the digital vibrance in the desktop color settings but it changes nothing. I should note that the YCrBr422 settings are for color output and not a particular device.
 
Last edited:
Yup.. I also tried playing with the digital vibrance in the desktop color settings but it changes nothing. I should note that the YCrBr422 settings are for color output and not a particular device.
Yeah, but at the top you first need to select the display you want to change the settings for, right? The desktop color settings are just for videos if you are talking about the "Adjust video colour settings" under Video in the hierarchy. To be clear I am talking about Display -> Change resolution screen with three settings.
1. Select the display you would like to change.
2. Choose the resolution.
3. Apply the following settings. <-- here is setting for "Output dynamic range:" and your can select "Full" or "Limited"
 
Last edited:
Yeah, but at the top you first need to select the display you want to change the settings for, right? The desktop color settings are just for videos if you are talking about the "Adjust video colour settings" under Video in the hierarchy. To be clear I am talking about Display -> Change resolution screen with three settings.
1. Select the display you would like to change.
2. Choose the resolution.
3. Apply the following settings. <-- here is setting for "Output dynamic range:" and your can select "Full" or "Limited"
you're in the right spot but i have my range set to limited and the color output to YCbCr422. that was the only setting i had to change to get the deeper colors back after the driver update.
 
Last edited:
I honestly find it horribly strange both headsets use HDMI at all and by what I see its not even hdmi 2.0, two 1200x1080 panels at @90 and we are getting pretty close to the edge of what hdmi can carry.
There is the obvious question "Are there more HDMI-ready 3D cards that are VR-capable than DisplayPort ready cards?" when developing the Rift/Vive

I'm also wondering if there is a licence or royalty issue with using DisplayPort hardware all through the Rift/Vive, rather than HDMI. Perhaps the parts cost was too high, royalty on each chip too high, deal fell through for supply.

This might be true for nVidia too, although you'd think the hardware pipeline for HDMI output vs. DisplayPort output would be virtually identical save for any difference in the HDMI vs. DP specs. Dunno, just speculating on my part.

Granted, HDMI does the job, but with the lower resolution as it is, you'd think Oculus and Valve/HTC would try for the best image quality possible.

Should the difference between dynamic range (16-235) and Full range (0-255) also make a difference in the monitor window? Does DVI, or good ol' DB15 VGA connectors suffer the same/different issues?
 
Last edited:
This is a really great tip ! For the first time since the Oculus 1.3 runtime was released, I've got a decent looking galaxy background.

I also realised I was still connected to a DVI-HDMI adapter, which I remember was a workaround from an older issue. I've now connected directly to my graphics cards HDMI output, which might actually have cure the problem on it's own.

I still see some smearing around deep blacks though. Any body know how to prevent that ? It's almost as it blacks just need to be 1 step up from totally black, or something, to prevent this.
 
OP here: ...Aaaand now I've lost the full range again. Can't get it back. Will hunt for DP>HDMI adapter tomorrow but my hope of ever getting 0-255 color range instead of 16-239 in the Rift is fading. I am sad.
 
Top Bottom