Release EDDI 3.3 - Bring your cockpit to life

I am having an odd issue of EDDI not seeming to recognize that I own a Federal Corvette. It is not in the ship monitor, When I change the name, it seems to acknowledge it somewhat by stating the ID tag I've given it, but not the name and when I switch to and and from it it says something like "parking your federal underscore corvette and ..."

I've disassociated and re-associated my frontier account, disabled and enabled the shipyard plugin between runs of the game.

I use EDDI in plugin form with voice attack.

Anyone report anything similar? Seems to be the only ship that I own that this happens.

Thank you in advance
 
Tried again without success. Can someone please confirm if this file is corrupt or not. https://www.dropbox.com/s/ihpqq513sk8cf51/Darkcyde's Defaults 2.4.2 v4.0.rar?dl=0#

Also there is an error box at the top of the Dropbox window that says "there was an error downloading your file"

Not having problems with any other files I've downloaded but this one is corrupt. It will download a file but if I try to unpack it WinRAR tells me the file doesn't exist or it's invalid.
Hi Meridian,

That's my personality profile. I've just tried to download it from the link you provided in your post, and it works perfectly fine for me. The only thing I can think of, could be your version of RAR. Make sure you have the latest from the WinRAR web site (https://www.rarlab.com/download.htm) and try that.

I've just checked the RAR file and it does need version 5.0+ of RAR to extract.

-=] Darkcyde [=-
 
I noticed that the landing pad announcement doesn't happen for Asteroid stations. Is there any clue as to what the identifier is for these stations so that we can have them do the landing pad announcement as well?
It's "Asteroid Base" and the default 'Docking granted' script in 2.4.4 recognises it. If you're using a custom personality based on an older release of EDDI you may need to compare your version of the 'Docking granted' script with the new default and copy any changes across.
 
It's "Asteroid Base" and the default 'Docking granted' script in 2.4.4 recognises it. If you're using a custom personality based on an older release of EDDI you may need to compare your version of the 'Docking granted' script with the new default and copy any changes across.
I concur. If you're using my Docking Granted script, it was based on an older version of EDDI, when "Asteroid Base" was still the raw in-game variable. I'll see about fixing that in my version.

-=] Darkcyde [=-
 
It's "Asteroid Base" and the default 'Docking granted' script in 2.4.4 recognises it. If you're using a custom personality based on an older release of EDDI you may need to compare your version of the 'Docking granted' script with the new default and copy any changes across.
VerticalBlank,

I've just run some tests on an Asteroid Base for docking, and it would seem that there is some kind of problem. I'll open a ticket on GitHub.

-=] Darkcyde [=-
 
Hi Meridian,

That's my personality profile. I've just tried to download it from the link you provided in your post, and it works perfectly fine for me. The only thing I can think of, could be your version of RAR. Make sure you have the latest from the WinRAR web site (https://www.rarlab.com/download.htm) and try that.

I've just checked the RAR file and it does need version 5.0+ of RAR to extract.

-=] Darkcyde [=-
Confirmed, dloads ok and unpacks just fine with 7-Zip 16.04. No issues noted.

As far as errors with dloading it, your ISP may be trying to block the site or you are experiencing routing issues through your provider. Dropped packets would account for the file being corrupt when dloaded.
 
Hi VB & Team,

With the Galnet responder, I generally only get to play once a week at the moment. When I started EDDI just now, it automatically reads back all the Galnet articles from the moment I start EDDI up rather than when I log into the game/get into the cockpit. Right now its been talking for about 10mins and still going with the EDDI window locked (was just wanting to update to the latest version before I log into the game, but it will not allow till finished reading them all 15 articles out).

Would it be possible to delay the reading back of the Galnet articles till you get into the cockpit? and would it be possible to define how many articles it will read back? Perhaps either by date range (ie last 2 days) or a max number of articles to read (I could see this going for a long time if I haven't logged in for a few weeks :)) A few seconds delay between each article would be good too, as it tends to blend into one when it starts immediately after the next.

Many Thanks,
AD
 
Hi VB & Team,

With the Galnet responder, I generally only get to play once a week at the moment. When I started EDDI just now, it automatically reads back all the Galnet articles from the moment I start EDDI up rather than when I log into the game/get into the cockpit. Right now its been talking for about 10mins and still going with the EDDI window locked (was just wanting to update to the latest version before I log into the game, but it will not allow till finished reading them all 15 articles out).

Would it be possible to delay the reading back of the Galnet articles till you get into the cockpit? and would it be possible to define how many articles it will read back? Perhaps either by date range (ie last 2 days) or a max number of articles to read (I could see this going for a long time if I haven't logged in for a few weeks :)) A few seconds delay between each article would be good too, as it tends to blend into one when it starts immediately after the next.

Many Thanks,
AD
I find closing EDDI then reopening it works. It kills the TTS and all the Galnet articles are "marked as read".
 
Hi VB & Team,

With the Galnet responder, I generally only get to play once a week at the moment. When I started EDDI just now, it automatically reads back all the Galnet articles from the moment I start EDDI up rather than when I log into the game/get into the cockpit. Right now its been talking for about 10mins and still going with the EDDI window locked (was just wanting to update to the latest version before I log into the game, but it will not allow till finished reading them all 15 articles out).

Would it be possible to delay the reading back of the Galnet articles till you get into the cockpit? and would it be possible to define how many articles it will read back? Perhaps either by date range (ie last 2 days) or a max number of articles to read (I could see this going for a long time if I haven't logged in for a few weeks :)) A few seconds delay between each article would be good too, as it tends to blend into one when it starts immediately after the next.

Many Thanks,
AD
I have had this too, and it's a royal pain in the exhaust port.

I have been debating whether to move that the Galnet responder should ship in the 'off' position - this is another vote in favour.
 
Re the above:

VoiceAttack users can tell EDDI to "shut up" and it will immediately do so.

I have a ticket open for standalone (i.e. non-VoiceAttack) users to have a "Shut Up" hot key that does the same.
 
I find closing EDDI then reopening it works. It kills the TTS and all the Galnet articles are "marked as read".
Thanks. In this case the EDDI window was locked & couldn't close. I could kill it via Task Mgr I guess, but still wanted to hear the Galnet updates. Just not straight away :)
 
I have had this too, and it's a royal pain in the exhaust port.

I have been debating whether to move that the Galnet responder should ship in the 'off' position - this is another vote in favour.
Or if left on, to include an arbitrary delay before it triggers? Something like a 5min delay would generally give players time to load everything up, settle into the game then get greeted with the latest news. Anyways, just a thought :)
 
Another way to fix it is through Voice attack if you use it.
I've got my voice attack profile set up to automatically activate the quiet mode when the profile is loaded and then set a trigger to allow the speaking to happen once the commander continued event is triggered.
I've also added a verbal confirmation in the quiet and talky voice attack actions as to which mode is activated (which helps especially to know if the verbal commands have registered, especially if playing in VR)
 
Good morning and thanks for all your work on EDDI!

Quick question - I just purchased Voice Attack and a HCS Voicepack - are there any conflicts with EDDI and HCS?
 
Hey just wanted to say love this dang add on for elite. Im just wondering if any one else is also having there audio cut out while using this addon, and its not my pc i just bought a brand new digiatal storm epic pc, all drivers are up to date and it only happens when this app is open ran it last night for about 4 hrs with out this running and no problem, i start this up after and bam 5 min go by and my audio goes out. Was just wondering.
 
Hi VB & Team,
A few seconds delay between each article would be good too, as it tends to blend into one when it starts immediately after the next.
You can adjust the delay between readings by making a small change to your 'Galnet news published' script in EDDI.
1. In EDDI, open the Speech responder tab
2. If you have not already done so, make a copy of the default personality so that you can make an edit.
3. Find and click the 'Edit' button for 'Galnet news published'
4. If you're script matches the default, the 4th line from the end should read "{Pause(1000)}". "1000" is the time in milliseconds between each reading, so currently a one second delay. Adjust this to match your preference.

I've also been exploring some ideas for making the Galnet monitor only update while you're in-game... I'm not quite ready to make any promises yet though. ;-)
 
Last edited:
Hey just wanted to say love this dang add on for elite. Im just wondering if any one else is also having there audio cut out while using this addon, and its not my pc i just bought a brand new digiatal storm epic pc, all drivers are up to date and it only happens when this app is open ran it last night for about 4 hrs with out this running and no problem, i start this up after and bam 5 min go by and my audio goes out. Was just wondering.
This is the 1st I've heard of an issue like this. Anyone else having similar issues?
 
Hi Meridian,

That's my personality profile. I've just tried to download it from the link you provided in your post, and it works perfectly fine for me. The only thing I can think of, could be your version of RAR. Make sure you have the latest from the WinRAR web site (https://www.rarlab.com/download.htm) and try that.

I've just checked the RAR file and it does need version 5.0+ of RAR to extract.

-=] Darkcyde [=-
Just for the record, I tried unpacking this with Winrar 4.0 and it didn't work. Installed 7z and everything was fine. :)
 
Top Bottom