Release EDDI 3.3 - Bring your cockpit to life

Hi!
Have anyone noticed an issue with "Location" script in newest version of EDDI or it is just with me?
When I (re)load the game, "Location" script does't caling... Nothing happened...
I tried to implement into "Commander continued" script (it has no problem) with {F("Location")} but after 'cmdr contiuned' text, EDDI says: "You are in the system" and that's it!
If I press test button for this problematic script EDDI says: "You are docked at the orbital station Heyerdahl Hub in the Alpha Caeli system." but it is just an exaple sample, (I'm onway to Colonia to SagA* at this momment.) so in game this dont work... :( I think there are issues with calling variables or whatever...?
THX for replies.
Fly safe!
Repetition of the Location event was disabled by the original author of this application in response to user requests - users wanted to be able to re-log / flip mission boards without re-triggering that event. We're re-assessing whether this is still needed.

Variables for Location are set by EDDI when the event is generated and are not stored in memory after the fact. Invoking event driven scripts like F("Location") can be problematic - those scripts depend on variables that are only set when the events are allowed to trigger normally. It's possible to work around this if you customize scripts to store and retrieve values using the SetState() function but that is a burdensome approach and is not recommended.
 
I'm pleased to announce that EDDI 3.4 is now available from the update channel and GitHub.

Full release notes are here.

Highlights:

  • Core
    • Added localised names for the Advanced Docking Computer and Supercruise Assist modules.
  • GalNet monitor
    • Restored multi-lingual access.
    • No longer loses its place if a web request times out or fails.
  • Speech responder
    • Add event Discovery scan, triggered when you "honk" the discovery scanner
    • Add new function GetFaction() to obtain details about a faction.
    • Revised faction object to allow reporting faction data spanning multiple star systems
  • Voice Attack
    • Fixed a bug that would incorrectly disable invoked speech while disablespeechresponder was set.
 
Add event Discovery scan, triggered when you "honk" the discovery scanner
Um, I think you mean you added 'System Scan Complete' event? The Discovery scan event has always been there, it's the one I suggested a script for. :);)

System Scan Complete is new - "Triggered after having identified all bodies in the system", that I requested to be added. Thank you very much for this, by the way! 😁

Great job otherwise! Can't wait to add some new exploration functionality now! Thanks guys!
 
Um, I think you mean you added 'System Scan Complete' event? The Discovery scan event has always been there, it's the one I suggested a script for. :);)
I shall quote the default script for "Discovery scan":

Code:
{_ This event currently is being written to the journal about 15 seconds after a discovery "honk" is completed. _}
{_ Due to the extreme delay between the triggering action and the actual event, we are omitting any default script for the time being. _}
 
I shall quote the default script for "Discovery scan":

Code:
{_ This event currently is being written to the journal about 15 seconds after a discovery "honk" is completed. _}
{_ Due to the extreme delay between the triggering action and the actual event, we are omitting any default script for the time being. _}
:unsure: Yes, but as I mentioned in issue #1270 this no longer applies as the event is now written to the journal at the exact moment it occurs, there is no 15 second delay anymore. The change log states this event has been added, but it's been there for a long time, and it's the System Scan Complete that's been added. Or am I missing something?
 
:unsure: Yes, but as I mentioned in issue #1270 this no longer applies as the event is now written to the journal at the exact moment it occurs, there is no 15 second delay anymore. The change log states this event has been added, but it's been there for a long time, and it's the System Scan Complete that's been added. Or am I missing something?
In that case let me confer with my colleages.
 
i know this been asked a million times and a millions times i read on possible fixes but nothing can make my eddi 3.4.0 login with the frontier stupid API
sorry about the mini rant! 07
 
i know this been asked a million times and a millions times i read on possible fixes but nothing can make my eddi 3.4.0 login with the frontier stupid API
sorry about the mini rant! 07
Mine updated without a problem, API connection was retained.

I would suggest going to

%APPDATA%\EDDI

In that directory, delete CompanionAPI JSON file and try to re-enter.

HTH
 
Last edited:
I'm using EDDI with HCS voice packs and just the default EDDI VA profile.
The EDDI VA profile is linked to through the Elite: Singularity profile from HCS
I'm happy with that, but I have a question.

I want EDDI to be quiet by default.
I want to wake up EDDI by saying EDDI wake up
I also want all EDDI VA commands to only activate if I say "Eddi <command>"

I can of course add Eddi in front of all commands, but I want to avoid that. Makes updating the profile upon new release a pain.

Is there any simple way to achieve this.

(I have also put this question up on discord)
 
I'm using EDDI with HCS voice packs and just the default EDDI VA profile.
The EDDI VA profile is linked to through the Elite: Singularity profile from HCS
I'm happy with that, but I have a question.

I want EDDI to be quiet by default.
I want to wake up EDDI by saying EDDI wake up
I also want all EDDI VA commands to only activate if I say "Eddi <command>"

I can of course add Eddi in front of all commands, but I want to avoid that. Makes updating the profile upon new release a pain.

Is there any simple way to achieve this.

(I have also put this question up on discord)
I use the same setup. I don't know how to go about what your asking through a voice command, but the easy way would be to open EDDI through VA and just disable the Speech Responder.

I've also found the "open EDDI" seems to baffle VA, so I've edited that to respond to "Open Data" which responds as it should.

HTH

EDIT: There is also a command in the EDDI.vap "be quiet" that instruct EDDI not to speak unless spoken to.

I'm not sure how to revert that, but you might read through the EDDI vap to figure that out. Changing it to "Open Data" works every time.

More on changing "Open EDDI" to "Open Data"

Just edit Singularity after you've imported the EDDI.vap commands. Edit "[Configure; Initialize; Minimize; Maximize; Restore; Close; Open] EDDI" and go throughit line by line and replace "EDDI" with "Data"

Maybe it's me, but I've never been able to use "Open EDDI" and have it work consistently.
 
Last edited:
I use the same setup. I don't know how to go about what your asking through a voice command, but the easy way would be to open EDDI through VA and just disable the Speech Responder.

I've also found the "open EDDI" seems to baffle VA, so I've edited that to respond to "Open Data" which responds as it should.

HTH

EDIT: There is also a command in the EDDI.vap "be quiet" that instruct EDDI not to speak unless spoken to.

I'm not sure how to revert that, but you might read through the EDDI vap to figure that out. Changing it to "Open Data" works every time.

More on changing "Open EDDI" to "Open Data"

Just edit Singularity after you've imported the EDDI.vap commands. Edit "[Configure; Initialize; Minimize; Maximize; Restore; Close; Open] EDDI" and go throughit line by line and replace "EDDI" with "Data"

Maybe it's me, but I've never been able to use "Open EDDI" and have it work consistently.
Configure EDDI is exactly the same as Open EDDI. Of the two, I find Configure EDDI to be more easily recognized.
 
:unsure: Yes, but as I mentioned in issue #1270 this no longer applies as the event is now written to the journal at the exact moment it occurs, there is no 15 second delay anymore. The change log states this event has been added, but it's been there for a long time, and it's the System Scan Complete that's been added. Or am I missing something?
I believe Darkcyde is correct. Discovery scan is older, System scan complete is new.
 
Hi Guys,

Absolutely love EDDI, so thank you for all the work the developers/contributors have put into it.

Can anyone else confirm that the ((EDDI docked)) event does not trigger when departing from a station then immediately making a docking request and returning to the same station (without entering supercruise)?

I am using the latest version of EDDI: 3.4.0.
Take off and landing via the automated docking computer.

Event appears to trigger correctly when docking at a station for the first time, or after entering supercruise and then returning.
 
Configure EDDI is exactly the same as Open EDDI. Of the two, I find Configure EDDI to be more easily recognized.
My problem was getting VA to recognize "EDDI" correctly. I tried saying "Eddy" as a word and spelling "E D D I" but it never seemed to recognize it correctly until I just substituted "Data" for "EDDI"

Not sure what I'm doing wrong, but once I did the edit it responds 100% accurately.
 
My problem was getting VA to recognize "EDDI" correctly. I tried saying "Eddy" as a word and spelling "E D D I" but it never seemed to recognize it correctly until I just substituted "Data" for "EDDI"

Not sure what I'm doing wrong, but once I did the edit it responds 100% accurately.
I find VA can be quite problematic with some words and accents. For me, it never understands "A 2". It always thinks I'm saying "Eight", which is really annoying when I'm trying to ask for information on "Body A 2". o_O I've tried training the voice recognition a dozen times, but it has no effect.
 
A friend has said that to me as well, an Aussie with a deep voice. All you could really hope for, if you're unable to enunciate or use small pauses to get around it, is some workaround like using another phonetic based command to call the command you have trouble with. Watch the event log in Voice Attack and note the words it think you are using, and add them to a phonetic list of words you can substitute as command words to make them fire correctly.

For example, you can make a command for "Body 8 2;Body 82;" and translate that to A 2 and call the correct command. Certain words will have issues, so having another way to call something can help, too. VA can wait for a user input now, so a simple If statement could be used to have VA ask what you just said, and wait for you to quickly type an "A" or an "8". There are obviously many ways to try to create a workaround, but in the end, it's the current "wall" for voice recognition and control in the current year: foreign accents, regional accents & dialects, deep voices, and speech impediments are just not fun to try to work around.
 
Last edited:

Javert

Volunteer Moderator
All - I have an issue with EDDI where the voice announcements sound completely distorted all the time like there is interference on a telephone call. It was working fine until recently - I'm not too sure whether this coincided with the last upgrade to ED or not.

This happens no matter I'm using voiceattack or the EDDI app.

However, if I go into the EDDI app and use the "test" buttons for voice, then it works fine - it only seems when I'm running the game that it goes all distorted.
 
All - I have an issue with EDDI where the voice announcements sound completely distorted all the time like there is interference on a telephone call. It was working fine until recently - I'm not too sure whether this coincided with the last upgrade to ED or not.

This happens no matter I'm using voiceattack or the EDDI app.

However, if I go into the EDDI app and use the "test" buttons for voice, then it works fine - it only seems when I'm running the game that it goes all distorted.

Look at the "Text to Speech" tab, 2nd from bottom, and un-check "Distort the voice on ship damage" checkbox to see if that's the cause.
 

Javert

Volunteer Moderator
Look at the "Text to Speech" tab, 2nd from bottom, and un-check "Distort the voice on ship damage" checkbox to see if that's the cause.
Thanks - yes this seems to have worked. However my ship was not damaged in the first place.
 
Make sure your voice is fully compatible. If you're using the unlocked Microsoft Eva Mobile, for example, not only will pauses not work, but certain calls turn into loud static, probably because it doesn't support the latest API. I had some other voices that I downloaded which I liked but did the same thing because they were a bit older.
 
Top Bottom