Release EDDI 3.3 - Bring your cockpit to life

Single 55" curved 4k Samsung .. not braggin or anything .. okay .. maybe a little.

a file called EDDI.exe.config in the install directory? I do and I manually edited the Minimized parameter to True (maximized was at false, left it) and still opens to windowed mode in LL quadrant.

Also the Windows location cords there are 40,40,800,600 - no wheres near anywhere I've placed it.
@T'kael

I've done a complete uninstall, and re-install and still EDDI is not obeying the user.config specifications.
I'm am not doubting that this is NOT an issue with EDDI but something with my configuration. I've done what I could think of .. what else could/would cause EDDI to ignore user.config file?
 
ok, but when i try to choose italian, it doesn't work well. Eddi doesn't translate all parts
The UI and variables are 97% translated but we have not received any Italian translation for the scripts. Consequently, the scripts are in English except for the variable names which have been translated to Italian. Is that what you are observing - that there is a mixture of Italian and English in the scripts?
If this is what you are observing, we need an Italian translation of eddi.json.
 
@T'kael

I've done a complete uninstall, and re-install and still EDDI is not obeying the user.config specifications.
I'm am not doubting that this is NOT an issue with EDDI but something with my configuration. I've done what I could think of .. what else could/would cause EDDI to ignore user.config file?
Hi Tacyon, I believe that we've found and fixed a bug that was causing EDDI to ignore the config file. Have you retested this with EDDI version 3.5.1?
 
The UI and variables are 97% translated but we have not received any Italian translation for the scripts. Consequently, the scripts are in English except for the variable names which have been translated to Italian. Is that what you are observing - that there is a mixture of Italian and English in the scripts?
If this is what you are observing, we need an Italian translation of eddi.json.
thanks, this is exactly what i'm osserving. I'm waiting for translation.
 
The UI and variables are 97% translated but we have not received any Italian translation for the scripts. Consequently, the scripts are in English except for the variable names which have been translated to Italian. Is that what you are observing - that there is a mixture of Italian and English in the scripts?
If this is what you are observing, we need an Italian translation of eddi.json.
Shouldn't be a problem boss, just point me in the right direction and I'll accomplish!
😁

In other words: how can I do it?
 
Shouldn't be a problem boss, just point me in the right direction and I'll accomplish!
😁

In other words: how can I do it?
Please make a copy of the default personality and then translate it to Italian. Please follow the English translation as well as you can (understanding that grammar rules in Italian may require some changes). Once complete, pm the file to VerticalBlank for integration as the new Italian default personality.
 
Please make a copy of the default personality and then translate it to Italian. Please follow the English translation as well as you can (understanding that grammar rules in Italian may require some changes). Once complete, pm the file to VerticalBlank for integration as the new Italian default personality.
Yep. As you may recall, I have conversational Italian as a second language, so feel free to ping me on any grammatical issues such as gender agreement.
 
Hi Tacyon, I believe that we've found and fixed a bug that was causing EDDI to ignore the config file. Have you retested this with EDDI version 3.5.1?
Yes ... when its removal and re-installation didn't work, the next day you'd released v3.5.1 and I said HA! Downloaded that and tested again. But alas it was not meant to be.

I also (just now) checked the security on the user.config file and it all looks nominal. Ownership was Administrator but I changed it to my user which is also in the administrator's group and also has full rights/controls to everything. I did have a question about the path .. the \AppData\Local\Eddi\EDDI.exe_Url_r1ssbxzhw4kh3jnzubxq2mvoeb4m4ekm\1.0.0.0\
Is the section in orange supposed to be like that? Just felt odd given this was just a cfg file path.
 
Last edited:
Yes ... when its removal and re-installation didn't work, the next day you'd released v3.5.1 and I said HA! Downloaded that and tested again. But alas it was not meant to be.

I also (just now) checked the security on the user.config file and it all looks nominal. Ownership was Administrator but I changed it to my user which is also in the administrator's group and also has full rights/controls to everything. I did have a question about the path .. the \AppData\Local\Eddi\EDDI.exe_Url_r1ssbxzhw4kh3jnzubxq2mvoeb4m4ekm\1.0.0.0\
Is the section in orange supposed to be like that? Just felt odd given this was just a cfg file path.
It's the same on my PC
 
Hi quick question, I've updated EDDI to 3.5.1 but my Voiceattack (Steam) is still showing the v4EddiVoiceAttackResponder.dll as EDDI 3.5.0. under the VA plugins section.
VoiceAttack tells me to open EDDI standalone to update when I launch it.
Am I missing a file?
 
Last edited:
Hi quick question, I've updated EDDI to 3.5.1 but my Voiceattack (Steam) is still showing the v4EddiVoiceAttackResponder.dll as EDDI 3.5.0. under the VA plugins section.
VoiceAttack tells me to open EDDI standalone to update when I launch it.
Am I missing a file?
That would suggest that you have EDDI installed twice on your PC. Please verify that EDDI 3.5.1 is installed in the same VoiceAttack/Apps folder referenced by your Steam installation of VoiceAttack.
 
Yes ... when its removal and re-installation didn't work, the next day you'd released v3.5.1 and I said HA! Downloaded that and tested again. But alas it was not meant to be.

I also (just now) checked the security on the user.config file and it all looks nominal. Ownership was Administrator but I changed it to my user which is also in the administrator's group and also has full rights/controls to everything. I did have a question about the path .. the \AppData\Local\Eddi\EDDI.exe_Url_r1ssbxzhw4kh3jnzubxq2mvoeb4m4ekm\1.0.0.0\
Is the section in orange supposed to be like that? Just felt odd given this was just a cfg file path.
It's the same on my PC
Let's open a ticket on Github to investigate this further please.

As for the config path, it's not something that we directly control and I believe it is assigned by the system. I see a similar string in my own config path.
 
That would suggest that you have EDDI installed twice on your PC. Please verify that EDDI 3.5.1 is installed in the same VoiceAttack/Apps folder referenced by your Steam installation of VoiceAttack.
Yes this was exactly it, thanks.
What odd though is I used the update feature from within EDDI, running from my Steam install location, I can't remember if it prompted me to locate the current install location or just updated itself automatically however.
 
Yes this was exactly it, thanks.
What odd though is I used the update feature from within EDDI, running from my Steam install location, I can't remember if it prompted me to locate the current install location or just updated itself automatically however.
EDDI cannot update from within VoiceAttack. It had to have been running in standalone mode at the time.
 
A double installation of EDDI would certainly play havoc with both the installer logic and the custom URL protocol that EDDI installs in order to handle OAuth. This explains a lot.
I did have trouble getting frontier authentication working on my second account. I guess that explains it.

On my primary account:

C:\Users\Dad\AppData\Local\Eddi\EDDI.exe_Url_jtjtvmlplfce4fdwas0znyrhcb0gsrdn\1.0.0.0
 
A double installation of EDDI would certainly play havoc with both the installer logic and the custom URL protocol that EDDI installs in order to handle OAuth. This explains a lot.

I don't use Steam, and i always do the update from Standalone.

Additionally, some of the event triggers take a long time to get started, e.g. ship transfers get announced several minutes after they have already been in progress. I used to chalk it up to my old PC being a bit CPU crippled on an i7-950, but Iv'e upgraded to an AMD 3900X with 32 GB ram and an Aourus m.2 SSD right on the PCIe bus. It doesn't even have about 10% load on it.

Any thoughts appreciated -
 
Top Bottom