Release EDSM - Elite Dangerous Star Map

Hi @AnthorNet.

Not sure if you're aware, but EDSM.net is currently rebuilding its search index VERY SLOWLY (see: https://www.edsm.net/en/search/bodies).

It's indexing around 1% of it's search database approximately every 12 hours, and it says the search will not be fully functional until indexing is complete. It's at 27.04% today, so at this rate indexing won't be complete until 13-May.

Is this something that can be resolved? Or will we have to wait?
 
As the content per hot spot is not consistant and is able to be depleted that will only result in disapointment for many users of EDSM...
As far as I got from reading various discussions, the hotspots have respawn, i.e. the materials/minerals mining rates will raise up as the time passes.
It is also my understanding that their contents (minerals, materials) do not change, ever.
Regardless whether it is correct, I was not suggesting that the reported hotspots location information would be 100% reliable and persistent .
It is rather going to be like the locations with the trade commodities or equipment. It can change over time, as reported.
The main benefit of having this information is to allow to search for specific mineral and for the specific materials.
The most valuable minerals will give a quick cash to ones who need it.
Knowing where to look for the specific materials is invaluable engineering and synthesis.
Actually, by saying "hotspot" I mean: rings/asteroid belts, planets with planetary mining locations etc.
 

AnthorNet

Volunteer Moderator
Hi @AnthorNet.

Not sure if you're aware, but EDSM.net is currently rebuilding its search index VERY SLOWLY (see: https://www.edsm.net/en/search/bodies).

It's indexing around 1% of it's search database approximately every 12 hours, and it says the search will not be fully functional until indexing is complete. It's at 27.04% today, so at this rate indexing won't be complete until 13-May.

Is this something that can be resolved? Or will we have to wait?
First batch is really slow, but it should not be impactful after :) And much faster that what we had before ;)

As far as I got from reading various discussions, the hotspots have respawn, i.e. the materials/minerals mining rates will raise up as the time passes.
It is also my understanding that their contents (minerals, materials) do not change, ever.
Regardless whether it is correct, I was not suggesting that the reported hotspots location information would be 100% reliable and persistent .
It is rather going to be like the locations with the trade commodities or equipment. It can change over time, as reported.
The main benefit of having this information is to allow to search for specific mineral and for the specific materials.
The most valuable minerals will give a quick cash to ones who need it.
Knowing where to look for the specific materials is invaluable engineering and synthesis.
Actually, by saying "hotspot" I mean: rings/asteroid belts, planets with planetary mining locations etc.
not something we can use in the journal sadly as it is now. No unique index for asteroids, or information on bodies locations.
 
There seems to be an inconsistency in EDSM's data for Geras (system #4947). When I retrieve the system data using api-v1/system, it gives the primary star as
Code:
{"type":"White Dwarf (DC) Star","name":"Gliese 171.2 B","isScoopable":false}
However, when retrieving the body data using api-system-v1/bodies, it has
Code:
"bodyId":1,"name":"Geras",...,"type":"Star","subType":"K (Yellow-Orange giant) Star","offset":1,"parents":[{"Null":0}]
This is borne out in the game itself, which shows a type K star in the galaxy and system maps as the entry star.

Oh, and just to point out, the link to this thread on the web page footer ("Forum") is in an old style and is broken. I found it (obvs) but you might like to update the link.
 
There seems to be an inconsistency in EDSM's data for Geras (system #4947). When I retrieve the system data using api-v1/system, it gives the primary star as
Code:
{"type":"White Dwarf (DC) Star","name":"Gliese 171.2 B","isScoopable":false}
However, when retrieving the body data using api-system-v1/bodies, it has
Code:
"bodyId":1,"name":"Geras",...,"type":"Star","subType":"K (Yellow-Orange giant) Star","offset":1,"parents":[{"Null":0}]
This is borne out in the game itself, which shows a type K star in the galaxy and system maps as the entry star.

Oh, and just to point out, the link to this thread on the web page footer ("Forum") is in an old style and is broken. I found it (obvs) but you might like to update the link.
How interesting! I wonder if the primary star was switched in-game at some point? Browsing EDSM, I notice that the K star is at the top of the list, but it is the White Dwarf (Gliese 171.2 B) that is shown as zero light seconds from the system origin/jump-in point.
 
Tied of closing EDSM with your web browser... by mistake
fed up of your windows PC crashing your web browser thats running EDSM... when running complex web site...

Try a Web to app conversion site and have the EDSM run in a Stand alone process...
IF you can't do it your self here one Processed and made all ready (use at you own risk...) for MacOSX and Windows..

Linux users just use...epiphany web browser it generates one in that browser by its self... (no web site creation script needed.)
127171
 
Hi,

Another inconsistency to report: system Pleiades Sector IH-V c2-5 has 9 bodies, but if you look at the Celestial Bodies tab, you'll see that there are 13 shown excluding the belts (discovered because the API returns a body count of 9 but an array 13 entries long). There are duplicated (and incorrectly named) entries "Pleiades Sector IH-V c2-5 1A", "1B", "1C" and "1C A".
 

AnthorNet

Volunteer Moderator
Hi,

Another inconsistency to report: system Pleiades Sector IH-V c2-5 has 9 bodies, but if you look at the Celestial Bodies tab, you'll see that there are 13 shown excluding the belts (discovered because the API returns a body count of 9 but an array 13 entries long). There are duplicated (and incorrectly named) entries "Pleiades Sector IH-V c2-5 1A", "1B", "1C" and "1C A".
Fixed, looks like our old EDDB import!
 
I think I found more duplicate bodies in the database:
  • Njikan 4B vs Njikan 4 b
  • BD+05 5244 1C vs BD+05 5244 1 c
  • Outordy TS-R c18-0 A 1 vs Outordy TS-R c18-0 A 1 (the former has TWO white-spaces between A and 1 but in the database it is NOT ringed as is the latter)
 
Last edited:
Is there something going on with the FD servers? For the last two days it does not pull the journal files for consoles. Instead it just flashes a brief message that the FD auth service is out.

B79D7D36-9B02-406A-A3E4-D7E987BAF319.jpeg
 
Is there something going on with the FD servers? For the last two days it does not pull the journal files for consoles. Instead it just flashes a brief message that the FD auth service is out.

View attachment 127536
Delete your Token in the Security page of settings...
Fdev can invalidate that token at any time...
so unlink and relink with the Steam logo or console logo on the EDSM site... and then it will normaly run again...
Screenshot_20190412_095916.png
 
Delete your Token in the Security page of settings...
Fdev can invalidate that token at any time...
so unlink and relink with the Steam logo or console logo on the EDSM site... and then it will normaly run again...
I tried that a couple times, including just now. Still same error message. I am on Xbox. I did monitor the network traffic and EDSM returns two json files. The journal file is empty, while the profile file contains the correct info.
 
Same issue. Tried to connect my son's ps4 account (Lamacolada) to edsm and it tells me that the frontier Auth server is not available.
I checked my own account, which was working yesterday, same problem.
Disconnecting and connecting again, didn't solve anything.
 
Same issue. Tried to connect my son's ps4 account (Lamacolada) to edsm and it tells me that the frontier Auth server is not available.
I checked my own account, which was working yesterday, same problem.
Disconnecting and connecting again, didn't solve anything.
Seems to be up and running again. All is good! 😎
 
So, I have a problem, I accidentally unlinked my frontier account from the EDSM Star map and I cannot work out how to link them back together. I have tried registering again, but EDSM says that my email and cmdr name are not available! Help!
 
Tested the Web site with the New Chrome based Edge browser build which is how PC web apps will run on windows and so far it seams fine...
logo-dev.35e98db9.png
So theres no requirement to recode the site for Porting to stand alone app powered by Edge in windows store once the build goes public so far they have not broken the chromium build there using...
PWA version can then be a public option then...
 
Last edited:
So, I have a problem, I accidentally unlinked my frontier account from the EDSM Star map and I cannot work out how to link them back together. I have tried registering again, but EDSM says that my email and cmdr name are not available! Help!
Log in to EDSM through the normal log in page, not the Frontier Auth on the right. When you are logged into EDSM go to the dashboard. It should then ask you to link your accounts. Select the platform you are using and follow the steps.
 
What ever f-dev were doing on the 12 of April broken the player journals for this...
11th and 13th were fine they imported but the 12th is not retro actively available... For my account...
 
Top Bottom