Elite Dangerous and BSODs in the browser

I need help to resolve one strange thing with my PC. BSODs and AMD video driver crashes after successful game session in ED. I played ED some time ago (April or May). All was fine. I used old driver version from the Windows Update. Something around 17.7.x version. I played many games since it and all was fine too. Until last Friday. I installed new driver version (19.9.2) for AC: Odyssey in October, because that game has low fps with my old version. I played that game during November. No any problems.

But then (last Friday) I started ED. Game session was successful. No problems. But after it I started my browser and opened Discord web. Then... My system gone to huge laaag. Some black screens, loses of signal etc. Then I rebooted it. But issue still there. I'll miss some unimportant details. Bad period was around hour or lesser. I tried to restore my system. After all I upgraded driver to the last beta (19.11.3). Run some short game sessions without any issues.

Next day I played in AC without any issues too. And next day too. But at the evening I decided to test ED again. Flyed some, made one jump, exited game. All ok. Started browser, some pages (Discord too)... And then after some minutes system gone to the same issues again. Some signal loses, one BSOD, reboot.

Signal loses are equal to "Display driver stopped responding..." records in the system log.

BSODs records was with "0x00000116" code.

Also there was some records RADAR_PRE_LEAK_64 related elitedangerous64.exe. But I can't link it to any special moment.

I decided to make clean driver (19.11.3) installation now. Will test AC next some days. And then ED if all will ok with AC.

It may be hardware issue and randomly linked to Elite Dangerous. I need more investigation.

My PC: Intel Core i5 7600, 16Gb, Asus Radeon RX 480 4Gb, ASRock B150M-Pro4, SSD+HDD, Windows 10 x64 1903.

Thanks for any advice.
 
Last edited:

A 116 BSOD is a TRD error. The GPU stopped responding for longer than the driver's time out period and the driver attempted to reset it, crashing when it could not.

Sometimes this is simply an issue with load/scheduling that can be resolved by increasing the timeout for the driver to recover, but it can also be indicative of a hardware defect or buggy software.

The symptoms you describe have me wondering if you may have a power supply issue (ED is really quite demanding, even relative to many newer/better looking games), an unstable CPU (the PCI-E controller is part of the CPU), or motherboard (motherboard still connects the slot to the CPU). Could also be the video card itself.

I'd double check load temperatures on the CPU and GPU while gaming and run some basic stress tests to rule out there being a power issue or any overt flakiness elsewhere.
 
OP: As Morbad stated, the root cause can be basically anything, but as you have already found out, it is somewhat related to the driver. Try to proof that the problem is only occurring in the later drivers. Try some more games as well and follow the exact same procedure after you close the game.
 
Thanks friends! Is there any way to analyze my crash dumps? May be some service or specialist who may look further?

P.S. My PSU is Aerocool VP 550
 
As B1rdy mentions, going back to a much older driver could help rule out an issue with recent drivers. The RX 480 is old enough that it's had mature drivers for years, so this should not be hard.
 
Top Bottom