Elite Dangerous can't connect to frontier servers potential fix

Hi,
Please try this official fix first: https://support.frontier.co.uk/kb/faq.php?id=344
If that didn't worked I've found a potential fix for the connectivity problems in the game. Some of you may have a problem to acces the passenger lounge, the bill-board or anything really.
The problem is your provider for not giving you a real IPv4 adress but a DS-Lite tunnel or something simmilar. The fix is to use IPv6 and I will show you how.

1. Go to the game folder in ...\SteamLibrary\steamapps\common\Elite Dangerous or ...\EDLaunch , depends on where you have installed it
2. Search in \Products\elite-dangerous-64 for the "AppConfigLocal.xml".
3. Make a safety copy of the file
4. Edit it and exchange the code with this, then save the file:

<?xml version="1.0" encoding="UTF-8" ?>
<AppConfig>
<Network VerboseLogging="1" ReportReceivedLetters="1" ReportSentLetters="1" DatestampLog="1" LogFile="netLog" upnpenabled="1" Port="5100" IPv6="1" IPv4="0" IPv6Port="5100" />
<Journal Address="0.0.0.0" Port="0" />
</AppConfig>

5. Go to the management site of your router like fritz.box, 192.168.178.1, ...
6. Open the port 5100 with the UDP protocoll and direct it to your PC and if not already done give your PC a static IP address (if not sure how google it for your router)
7. Launch the game and go into the network settings
8. Change "port overwrite at IPv6" to "5100" and "port forwarding" to "on" with the assigned port also being "5100"
9. Save and restart the game

I hope my fix worked for you and please forgive me if any settings aren't named exactly like this I play the german version ;D
 
Top Bottom