Release Elite: Dangerous Market Connector (EDMC)

Had the same issue too, but instead of starting TCE to get the login request, I did start EDMC alone.

So I did:
1. Deauthorizing EDMC first (https://auth.frontierstore.net/).
2. Start EDMC alone to get to the login page to authorize EDMC.
3. Login and approve the authorization once.
4. EDMC should thereafter confirm the success.

Hope it helps!
This is not working for me. Following these instructions EXCATLY, after Step 3 I receive the message: "Redirecting to edmc://auth?code ......etc" and EDMC says "Error: Invalid Credentials".

This has been happening for about 2 weeks. I know the credentials are correct and Inara is authorised and so is EDMC on Frontier Authorisation even though EDMC says invalid credentials after deauthorisation and re-authorisation as above.

Rob
 
This is not working for me. Following these instructions EXCATLY, after Step 3 I receive the message: "Redirecting to edmc://auth?code ......etc" and EDMC says "Error: Invalid Credentials".

This has been happening for about 2 weeks. I know the credentials are correct and Inara is authorised and so is EDMC on Frontier Authorisation even though EDMC says invalid credentials after deauthorisation and re-authorisation as above.

Rob
OK, I have just got EDMC working again :). I changed my default browser to Chrome and went through the whole process of deauthorisation and re-authorisation as Eventure directed above and this time it worked! I did try this yesterday but it did not work then. Strange! My default browser is Palemoon (a Firefox derivative) and it has always worked in the past for EDMC until about 2 weeks ago.

So maybe try Chrome for those who still cannot get EDMC authorised correctly.

Rob
 
OK, I have just got EDMC working again :). I changed my default browser to Chrome
Welcome to a decent browser! Chrome is the only one that runs Twitch, Discord, and all the Elite 3rd Party Tools for me. Opera, Firefox etc all fail to properly run one thing or another.
 
Had the same issue too, but instead of starting TCE to get the login request, I did start EDMC alone.

So I did:
1. Deauthorizing EDMC first (https://auth.frontierstore.net/).
2. Start EDMC alone to get to the login page to authorize EDMC.
3. Login and approve the authorization once.
4. EDMC should thereafter confirm the success.

Hope it helps!


^^^ this worked for me

After weeks of EDMC not working, the above sorted it out

Many thanks
 
Had the same issue too, but instead of starting TCE to get the login request, I did start EDMC alone.

So I did:
1. Deauthorizing EDMC first (https://auth.frontierstore.net/).
2. Start EDMC alone to get to the login page to authorize EDMC.
3. Login and approve the authorization once.
4. EDMC should thereafter confirm the success.

Hope it helps!
No works for me :( . Neighter poutting steam instead of frontiers in the address bar. Removed ED market, rebooted, registry cleened, reinstalled the lastest 3.3.8, put all information : first time, invalid credential, second time : an error occurred .. So sad

Chrome as default brower. Tested too with firefox and opera
 
Last edited:
Hotdarn! Using Chrome worked. Something is wonky in passing login creds between Firefox and EDMC. Oh well, I'll just keep Chrome installed and turn it on when needed.

j,
 
Forgive me if this has already been answered somewhere, but this is my first time playing with EDMC/any third party program with Elite.

When I “update” it with my data for the first time, does it collect all my past exploration data, or just the data for my current system/station? For now I’d prefer to keep my past discoveries to myself.
 

Otis B.

Volunteer Moderator
When I “update” it with my data for the first time, does it collect all my past exploration data, or just the data for my current system/station? For now I’d prefer to keep my past discoveries to myself.
The app only sends data that it collects while it is running.
You can also use the "Delay sending until docked" option to keep discoveries secret until you return to civilsation.
 
EDIT: Seems to be a problem with a specific station, as another in-system station responded without issue.

Updated info:

The station is Hippoc Bioceuticals Research Station, in 51 Arietis.

https://eddb.io/station/67654

Every time I dock, EDMC responds with frontier server is lagging, but only this station, in this system. TCE claims I'm not docked when this is happening, so maybe the station has moved or something to where it isn't recognized by EDMC??
 
Last edited:
Ignore Solved.


Hi,

Does anyone know if there should be a WAV folder in EDMC?

I just had a warning from Malwarebytes regarding that folder with several wav files in it apparently containing wav's for EDMC.

They downloaded yesterday and put the folder in the Program Files(86) directory

Thanks,
 
Last edited:
@Arnak, WAV is a sound format, I would think they are sound effects, etc for the app. I haven't looked at them specifically but run your antivirus on the target folder and u should be fine.
 
Thank you for this brilliant tool, its indispensable. I can't imagine running E: D without it. I'd like to make a small observation, if possible: the latest version (3.40) changes the font in the transparent theme (which is the most practical) but the font size is larger and the window takes up more screen space. Would it be possible to shrink the font size or give us the option of choosing a size?

Thanks again for your enthusiasm.
 
Hi there, i just wanna say thank you for this tool. I started playing ED few days ago and find it pretty hard to keep track with all it's economy information. So, tools like EDMC, and websites presenting a evaluation of the cumulative data, are huge benefit for ED-players like me. Otherwise i would be totally lost, by trying to find good deals in the universe. So i'm eagerly willing to contribute by using this tool at any time i'm playing ED.

Thanks, and keep up the good work please! :)
 
Hello,
I do have little problem with EDMC. I do run ED from linux under wine (using lutris). It is perfectly playable. Everything wokrs. But if I try to run EDMC it crashes under wine. (probably some dependencies missing. But can't figure out which ones.
If I run EDMC natively undel linux it does not see ED. So not asks for any authorization and that leads to "unauthorized access" errors.
Is there a way to do it under linux solely ?
 
Top Bottom