Elite Dangerous: Odyssey Update 3

sallymorganmoore

Community Manager : Elite Dangerous
Frontier
@sallymorganmoore

Hello again!

Could you let me/us know if this issue it being looked at as well as the issue in the um... issue?

Thanks!


Yep, totally grabbed it :)
 

Ozric

Volunteer Moderator
Thanks once again to the team for a huge list of fixes. Remember to stay hydrated, take breaks, and look after yourselves.

  • Fixed POIs spawning all over the galaxy.
This is very nice indeed, thank you.

  • An issue has been fixed whereby dying in SRV caused players to enter the ship rebuy flow when they relog.
This is also a good fix as I lost a couple of week's worth of genetic sampling data and Codex vouchers when my SRV was destroyed.
 
SWEET!

The Horse is back

HighResScreenShot_2021-06-10_15-12-03.jpg
 

sallymorganmoore

Community Manager : Elite Dangerous
Frontier
@sallymorganmoore
You said there's a CM specifically on the forum every day, like you today.
Does that mean, your service here isn't a one-time thing, but tomorrow it's Zac or Bruce or so who's all over our questions and complaints?
And if yes, which thread to post, since this is a patch notes thread after all.

That's right! It'll be one of the guys tomorrow. I'll be back next Thursday (lol! Like a TV show).
So today is a bit "special" because it's patch day, so I would naturally be very focused here - it turned out to be veryyyy busy so I've stayed here for now. The guys will look broader places and you'll notice them just generally chipping in on things drawing their attention :) Hope this helps!
 

sallymorganmoore

Community Manager : Elite Dangerous
Frontier
Myyy goodness, Auroral you are so very welcome, this is a really lovely thing to read - and look, you all fuel us too! We are listening and we will continue to improve as hard as we can. With all of this wonderful feedback, thoughts and cooperation we are going to truly get Odyssey to the best it can possibly be.
Sending my best! Thank you again for the game feedback too!
And I absolutely believe it. Nothing shows it more than going from no on the ground, meaningful communication to how things are right now. I know it's probably not easy, especially going from one thing to a different direction on communication like this so quickly, but it's already doing wonders, at least for me. Thanks again. I'll quiet down now! I just never expected things to change like this. Makes me excited for the future. 😭


Be well!
 
I have about 700 hours on record with Horizons (double Elite status, close to tripple Elite) and I am just very sad that Odyssey so far (incl. today's update) is unplayable for me.
Reasons:
  • I can not play fullscreen, any time I go fullscreen mode the game crashes (10 sec in release version and all updates till today, today it crashed after 10 minutes, I actually did manage to shoot down one NPC ship in a random encounter but soon after that it crashed). Each time I send a crash report but I have given up hope that it changes anything.
  • I want to run the game in 4k which I did for the entire time of Horizons and it was smooth and looked fantastic. I had all settings to high or ultra and it was wonderful
  • Now I can't run even the "mid" preset with low shadows and no anti-aliasing, I get (if the program does not crash) a maximum of 26 FPS (in space and on foot) and it is laggy as hell, absolutely zero fun to play.
  • I ran it a bit in windowed mode with a smaller size window and it was "ok", FPS around 30-40, but I don't enjoy one bit of that small window on my large screen.
  • The colouring is way off. Too dark, gamma settings don't help at all.

My specs:
  • I7 6700K overclocked watercooled
  • 2 x GTX1080 founders edition (12 GB VRAM each) in SLI configuration (overclocked, watercooled)
  • 32 GB RAM
  • Samsung NVMe SSD 950
  • Win 10, latest NVIDIA drivers

This is a (for the time from 2016 where I treated myself to this crazy overpowered setup) very nice gaming platform still today. It exceeds the minimum and even recommended specs by a lot and it is capable of running modern titles very nicely. I play "Assetto Corsa Competizione" a lot (in 4K, decent details, no problems at all), "Shadow of War" in full detail max view range, max gfx config (comparison as an FPS game) and Arma3 with about 6 GB of mods installed (comparison for a complex 3D game with tons of mods).
All of those titles and many more (BF 1, Doom Eternal just to name other FPS games) I can play with 100% stability and enjoyment in 4K. So I consider my system not at fault for those crashes and problems I experience with Elite at this point in time. I think the game engine is very poorly optimized at this stage.

The reason I am writing this posting is just to let you know I love the game and I want to believe in it. I want to enjoy it again. But for now I will not be playing anymore.

Sad greetings from Germany
 
@sallymorganmoore thanks for being so active on this thread. Really great seeing all the responses and note taking. Do we have any word yet on when on foot team missions will make their way in? We're anxiously waiting to really do things as a squad.
 
So with todays update i had hoped it might help my issue sadly it did not. The on foot tutorial fps was 60 fps and card temperature normal on lowest graphics settings supersampling to 0.85, until i enter the building with the fire in and my gpu temperature QUICKLY shoots into overheating territory (90+ degrees) and fps TANKS. Still too afraid to continue the tutorial to learn how the game works without fearing damaging my gpu. (with the madness that is gpu prices buying a new one is out of the question)

GTX 980ti 6gb I7 6700 16gb ram
If you didn't manually deactivate the safeguards for your card, I am pretty sure you can't damage it.
When reaching a certain threshold the card will lower performance to not overheat to the breaking point.
 
That's right! It'll be one of the guys tomorrow. I'll be back next Thursday (lol! Like a TV show).
So today is a bit "special" because it's patch day, so I would naturally be very focused here - it turned out to be veryyyy busy so I've stayed here for now. The guys will look broader places and you'll notice them just generally chipping in on things drawing their attention :) Hope this helps!
Thanks for clarification. :)

nudge at thread
 
Super cool. I love you guys. We are a lot of commanders that really enjoy Odyssey. Hi to all the community Manager that do a so wonderful job. Thank you to be more transparent with us. Be safe. o7
yes, thank you to sell us a no finish game with a lot of bugs but with a operational cash shop... sheep. Do you work for frontier or are you only an .....?
 
This is absolutely bangin.. Sally you've sure earned your chips today!! Great news going forward I would say!

And to whoever posted this..
Dunno whether anyone else has found this, I searched for an existing ticket but couldn't find one, but I'm having trouble with plotting a route in the GalMap. Specifically, I have two binds for 'select system', one on my HOTAS and one on my gamepad, but hovering over a system and trying to hold either bind to plot a route does nothing. If I hold the left mouse button it works fine.
I can say I think we have both found a problem there. There really seems to be a blockage when we use a controller + HOTAS.. although my issue is almost the same but only one of them will plot the course. So if I'm using the HOTAS I have to pick up the Controller to quick-plot the route and when I am on foot using the Controller the only way the jetback will register a HOLD input is with the HOTAS.. weird!!
Here is my issue.. https://issues.frontierstore.net/issue-detail/38152 I'll go and contribute to yours now too as I think it's relevant and possibly related.
 
Great list of bug fixes.

Sadly however for me - When in my SRV on planets - the screen judders / stutters quite badly. At the same time the frame rate usually drops by 20FPS (when uncapped)
On the whole I'm about 10FPS down on planet surfaces since last update.

I deliberately left myself on the same planet, so that I could compare Frame rates.
I've tried capping my Framerate, and also setting VSYNC, but no joy.

Will log something on the Performance / set thread, and see if it helps them get to the bottom of this.
 
Top Bottom