Elite on the Oculus Quest - Amazing!

So I finally sorted out Elite on the Quest, and I've got to say it looks beautiful. There are a few guides online but I had a couple of issues with them - namely it recommended to use Windows Powershell to access the command prompt, and the USB debug prompt wouldn't appear in the rift itself. But using windows command prompt iin admin mode worked for me to install as needed.

I'm thinking of creating a video tutorial on how to set-up along with the necessary files in a zip.

Would their be any interest here for a tutorial?

Requirements (for ideal performance):
  1. PC wired to the router
  2. Router with 5Ghz output frequency
  3. PC within 4 meters of the play area (note: you do not need to be sat at the PC if you use wireless controllers, as long as you're within close range of both PC and router for wireless signals to function
Pros:
  1. Wireless, no wires dangling from your head (for upto 2+ hours anyway). You can continue playing while it's charging if necessary.
    OLED 1600x1440 resolution per eye (inky blacks, deep colours)
    Manual IPD adjustment for maximum compatibility (2 seperate screens in the headset)
  2. You can also take your VR headset anywhere and use it with the Quest, obviously, which you can't with other wired headsets
  3. No sensor setup
  4. Built in sound (which is surprisingly decent, although everyone can hear it). Else I'd recomment a pair of Koss Porta Pro which are around £35 new, they sound amazing and are very light on the head. I got a free pair of MSI Immersive GH60, which retail around £70, the Koss Porta Pro blow those out of the water, fuller sound and louder)
  5. The home screen is super easy to use now, I used to find the original rift home very confusing, for me they've refined it and it's much better now
Cons:
  1. They are somewhat heavier than the CV1 I had previously, but I got use to the weight quickly
  2. The initial set-up does require some time and you need to follow instructions closely, but other than that it's simple to run
  3. Reduced to 72fps, compared to 90fps (CV1) and 80fps (Rift 2), but to be honest I haven't noticed and it's not been an issue at all for me. That said people who are mre sensitive to this might notice it
  4. You are receiving an encoded video stream to the headset, so there is occasional artifacting. It heavily relies on a stable router that can output around 30Mbs. You can adjust this in settings so I might do some testing so see how longer bit rates look, potentially fine for something like Elite, but do bear this in mind. If you have an older router, or your router as far away from your gaming location, this is likely not a good option for you. Do a speed test from your phone to your router on the 5Ghz band, see if you get a constant 30Mbps or thereabouts, of it's lower then you probably need to change something in your set-up (note this is the speed from the router to the device, not your broadband speed, so try a file transfer for example, you want to hit around 4Mb/s transfer speed for it to be suitiable, CONSISTANTLY).
The two main benefits I've found are, I no longer try to 'ignore' the screen door effect. It's there but it's not distracting, and I really mean that. I just don't percieve it anymore unless I consciously look for it, which is a MASSIVE improvement over the Rift CV1, for me at least. Also the improved resolution makes text readable without any issues at all, I haven't bothered looking at supersampling just yet, as the game runs so well in it's default settings on VR medium I haven't had time to tweak the settings.

My specs for reference (so a relatively high end system, not sure what would be the minimum spec for good performance, but I would assume a quad core + GTX 1060 or RX580 or higher with 8Gb RAM as a bear minimum):

Ryzen 3700X (octacore @ 4.2Ghz approx)
GTX 1080 8Gb
16Gb DDR4 3200 CAS 16
AData 1Tb NVME SSD
 
Last edited:
I don't have a quest but that is interesting.

What kind of loading do you see on the 3700x? I'm interested as It's likely what I'll upgrade to later in the year.
 
CPU usage was typically around 10-14% in an asteroid filed, spiked to 30% when I first loaded near a planet, but then setted to 10-14% again.

That's with 1440p res with 1.25 supersampling, ultra settings. Typically getting around 100-130fps.
 
I'd really appreciate it if you could produce some kind of tutorial on how to get ED running on the Quest. :)
 
I'm also interested in the configuration information. However, I would like to know - is there enough battery capacity for a long game? How long will the energy be enough for a long game? I would also like to know how exactly to test speed between router and a helmet?
cptwhite - what router do You have? What router would you recommend? Will router Keenetic Giga (KN-1010) be suitable for using with Oculus Quest?
 
Last edited:
I'm using a Virgin Media 3.0 Hub for reference, you need to go into the settings and change the SSID names for 2.4 and 5.0 bands, in their wisdom Virgin named them the same so it can select optimal network when you connect, but by default it goes to 2.4Ghz for me. So I renamed them and ensured my Quest connects on the 5Ghz band.
 
Here is the set-up video, the files can be downloaded here:


Note: You enable DEVELOPER MODE on your phone (not USB debugging like i say in the video). I couldn't remember and couldn't check as I was recording with the phone!

Note2: Obviously you need to have Steam VR installed, go to Library > Tools > Scroll down and install from the menu. Do this before following the video below.

Note: I also opened UDP port 9944 as ALVR recommends, but I'm can't be sure if this was absolutely necessary, try without doing it beforehand.
Source: https://www.youtube.com/watch?v=7mkADyTLH6c
 
Last edited:
While the above videos cover the basics, there are a few errors, mostly because it was 9pm, I was tired and the video positioning is terrible. I will endevour to fix the issues using SteamVR with the Oculus Quest controllers and upload a (slightly) better presented video at some point in the future, but for now this does cover the exact process in real time, if you can't see what I'm doing on screen in some portions of the video, just listen to my instructions I have tried to be very clear in my explaination.
 
Thanks for all the effort you've put in to helping us. I've had to order a usb cable to connect the quest so can't really do much until that arrives. I'll let you know how things go once I get past that stage. Again, thanks for all your hard work.
 
@cptwhite Followed your instructions and was successful in getting the game to run. My first time seeing ED in VR...wow, everything is so big! Really becomes immersive. Thanks again for the videos. I've had a lot of trouble with controllers too. Once you're in the game and manage to get rid of them then it's ok. Did you find a work around for getting them to work for future reference?
 
There are still minor issues compatibility issues with the controllers in some games. But in general yes I did get them to work. It seems an Oculus Quest software update was causing the issue (looking on github) and someone had released a patched version of the ALVR.apk and Desktop app.

I'll link them here when I'm back home but it means Steam VR home works and shows the correct virtual controllers (Oculus Rift type, which switched to quest type when you load a game if I remember correctly). I think a lot of these issues would be resolved if you go for one the pay-for equivalents of ALVR - I believe there are apps called Virtual Desktop and also RiftCat, probably others too, which cost ~ £15

But to update the apk on the headset, you need to:

1) Connect with USB cable
2) Got to command prompt, and navigate to the ADB folder
3) Type adb uninstall com.polygraphene.alvr [This uninstalls the original app]
4) Restart the headset to finalise the uninstall (app will disappear from Unknown Sources folder)
5) Go through the original proceedure with the new app I'll link tonight, and I'll provide a link to the working ALVR desktop app as well, just to ensure you're using both of the same versions I was.

Magically the hand controllers start working in Steam VR :)
 
Last edited:
I'd also point out I missed a fairly major point in my tutorial (as I was re-treading the steps for the video that I had already done), in that when you turn on "Developer mode" from your phone settings, you have to sign up as a developer on the Oculus site before it will enable this. It's just a case of putting in a few details, making up a developer name (so any apps you develop would be accredited to this developer name) and then hit apply. It's a bit of a faff but only takes 2 minites and is completely free. Once done it will enable Developer Mode to be turn on in the phone app settings.
 
Note: I also tried No Man's Sky this weekend, that game is great fun and gives an impression of what Elite with legs would be like in VR...and it was multiplayer too.

The only thing that annoyed me was the graphical fidelity, it's like a post processing effect (even visible on desktop, it's hard to make the game look "sharp", which in VR is even more annoying as it just leads to the game world looking lower resolution, compared to the fidelity you're presented with in Elite it was a bit of a let down, but the immersion of being on a planet made up for this.
 
Here's the updated files, remember to uninstall the original apk on the headset first, following my 5 point guide above


The updated APK file to install is already in the ADB folder (ALVR.apk) so you can just repeat the video guide above to install the new one.
 
Top Bottom