Elite on the Rift S

Just raising my hand to say I'm having the same problem as well. All of my other titles (including DCS World) work just fine, but Elite constantly resets my head position.

Considering going back to my CV1 :(
 
My rift S isn't showing as a screen option in Elite. What am I doing wrong?
You don't set it as a screen option; you need to launch the VR version of the game and it will use your HMD, the screen option is for the view repeat window to be displayed on.

You instal the game in Oculus home, and launch from there.
 
You don't set it as a screen option; you need to launch the VR version of the game and it will use your HMD, the screen option is for the view repeat window to be displayed on.

You instal the game in Oculus home, and launch from there.
There's VR version of the game? Where?
 
I can't even get my Rift S to appear as a display option in ED
What am I doing wrong?
There's VR version of the game? Where?
You've installed the Oculus software, right? So launch Oculus home and put the headset on. (or do this in the desktop) Go to the game store and download the game from there. You have to instal this VR version. The install you used before you got the Rift will not play on the rift.
You'll have a code you can get from your frontier account to prove that you already own the game. You don't have to re-buy it. You'll enter that code in the oculus app.
When you launch the game from oculus home it will launch in VR. It will use your headset. The display options page in-game where you select windowed or borderless options are for the repeated view on your monitor, not the headset. Set that window pretty small to take some load off your GPU.
 
Here is a blog post where they go over the details.
They are doing steam VR but the process is basically the same. Skip to the "if you already own the game" section.


They tell you that you "need to" uninstall the previous version of the game. You don't really, the new instal will use your same preferences folder for settings, but you can also right-click and launch the game in normal (Not VR) mode from Oculus library if you want to play that later. You can uninstall your old version to save space if you want. but don't need to.
 
You have to instal this VR version. The install you used before you got the Rift will not play on the rift.
I’m afraid you are mistaken; you can just select the “HMD” option in the display options menu, restarting the game will flash it up in VR. The Oculus software needs to be running in the background.

I’m still using the same install from 2014, using VR for the last 18 months.
 
I’m afraid you are mistaken; you can just select the “HMD” option in the display options menu, restarting the game will flash it up in VR. The Oculus software needs to be running in the background.

I’m still using the same install from 2014, using VR for the last 18 months.
Oh, even easier than I thought. Maybe I’ll give that a try as I don’t need it double installed.
 
Hope I have done the right thing - just ordered one, should be here by Thursday!
I picked up mine yesterday, like you I’ve gone from a Rift CV1. I’ve had a few hours in the S now and I’m glad I made the purchase.

Clarity is much increased, I’d say like going from HMD quality 1.0 to 1.5 with a great reduction in the screen door effect. I can’t see any difference in the fps reduction from 90hz to 80hz, and performance is about the same with the same settings in ED.

The sound is worse, like you’ve suddenly elevated a thousand feet and your ears haven’t popped :) Just cupping my ears made it much better, so I might investigate the low-tech solution instead of plugging my headphones into the HMD.

I’ve had no issues with tracking or head repositioning so far, played SkyrimVR, PavlovVR, Robo Recall and Elite Dangerous. The only issue I’m having is that the ring on the Touch controllers is now above the hand, and I occasionally clunk it on the other controller or headset when doing my Legolas bit in Skyrim :)
 
I picked up mine yesterday, like you I’ve gone from a Rift CV1. I’ve had a few hours in the S now and I’m glad I made the purchase.

Clarity is much increased, I’d say like going from HMD quality 1.0 to 1.5 with a great reduction in the screen door effect. I can’t see any difference in the fps reduction from 90hz to 80hz, and performance is about the same with the same settings in ED.

The sound is worse, like you’ve suddenly elevated a thousand feet and your ears haven’t popped :) Just cupping my ears made it much better, so I might investigate the low-tech solution instead of plugging my headphones into the HMD.

I’ve had no issues with tracking or head repositioning so far, played SkyrimVR, PavlovVR, Robo Recall and Elite Dangerous. The only issue I’m having is that the ring on the Touch controllers is now above the hand, and I occasionally clunk it on the other controller or headset when doing my Legolas bit in Skyrim :)
Thank you, that helps reassure me, I’m looking forward to it
 
I've read that oculus announced an update that promises to improve the audio from it's built-in speakers. Increasing efficiency of the amplifier and low end response. I think they were too conservative with the power the dedicated to the amp in the first version.

Also, regarding the head tracking, I think mine is a lot worse when my CPU is hitting 100% usage. I'm going to experiment with setting the OC server process higher priority (though I doubt that will help) My poor i5-6400 is just outmatched. I actually think it is extra stressed because of how much I'm making it do ASW. I'm pretty happy with out ASW looks in this game so, I let my settings push into that quite a lot. But that means the Oculus software is being asked to create the intermediate frames, and that means higher CPU usage. I was tracking this last night an in RES combat I was getting 100% cpu usage and only 50-60% GPU.
So I think I need to get out of constant ASW so my GPU can do more of the lifting, as a percentage of the hole.

...And then get my hands on an i7-6700k when I see a good price...
 
Oh, I was also just reading that there is a resolution tweak in the Oculus software. In the graphics settings for Oculus it's called "graphics preference"
What it's actually doing is setting the default 1.0x sampling resolution.
  • Prioritize Quality: 1648×1776
  • Prioritize Performance: 1504×1616
    I haven't messed around with this to see how it impacts ED, but I expect knocking that starting res down will give us another option for controlling out performance. There's also and Anti-Aliasing setting in there and I can't find anywhere to see for sure if that is going to be overlaid on top of other games. I'm thinking of turning it off to check if performance increases any. Shouldn't be much as simple AA is essentially free on modern GPUs.
 
Well, I just fussed around with this a bit and I can see a slight difference when I switch the internal resolution on the Oculus, (when focussing on a mid field object and watch the jaggies move around) but it makes absolutely no difference to my rendering headroom as measured by the Oculus debug tray.
My CPU is still the choke point in this system. After some messing I find that many of the detail settings I could probably turn up as my GPU has free time, but the CPU sitting at 100% is causing all kinds of stuttering after I spend more than 30 min or so in a RES. It's hard to tell.
I guess the only thing I haven't tried yet is processor affinity. Having just 4 cores and no HT I guess I could set them 2 each (ED game exe and OC server) and see if that helps. Maybe it would restrict what ED could use so OCvr never runs out of headroom.

EDIT: I know I'm already flooding this thread with posts. Don't bother messing with CPU Affinity. Just like thread priority it's best left along. You'll only get more hitching and possible crashing by restricting any of these processes.
I even played around with forcing ASW on or off (rather than auto), but this didn't help. Forcing it off, did reduce and stabilize CPU load, but at the cost of unpleasant jitter that I didn't prefer. So that's staying in Auto mode.

I did eventually land on a solution to balance the loading and I think this could help anybody who's in my case, where the CPU is hitting 100% load but GPU is far from it.

So here's my recommendations:

Measure your systems performance my loading up the game and sitting in a station (return to surface) so you have a baseline for what's goin on. I think the performance tab of task manager is fine; we aren't writing a scientific paper here, after all.
I found that my system is very CPU bound and wasn't fully utilizing my GPU. So when I saw performance hiccups I went and turned down some settings, but that wasn't making any difference because my GPU has no trouble at all with the shaders. I couldn't figure out why my performance seemed to get worse as I kept turning things down. The problem is my CPU often can't keep up with all it's being asked to do. So at that point I can set much of the detail to be whatever I want. I turned a bunch of things up like FX and environment quality, stuff that really adds to the game. And this all took my GPU utilization from 40%-50% up to around 70-80% (no need to take away all its headroom) and my CPU utilization seemed to drop from almost steady 95%-100% to more like 80%-85%.
It seems to be important to balance. Using the GPU more seems to make the CPU less loaded and heavy.
Understanding how the draw call process works differently in a VR system, this might make sense since the CPU and GPU don't overlap. So my GPU was doing it's thing very fast, then calling back to the CPU and waiting. The CPU being the slower part, it can hardly cope and really just maxed out. By asking the GPU to do more we use up more of it's time and it takes longer to finish the draw and call back to the CPU. So the load lowers slightly and stabilizes.

I didn't take these settings out into combat yet, but I wanted to work that out. I hate sitting down to a play session and spending the whole time tweaking. I want to fly!
 
Last edited:
After more use, I’ve got a further gripe about the S - my nose is slightly too large for the HMD. I have it fully extended forward and have the soft rubber nose-piece removed, and the ridge is still just rubbing the bridge of my nose. Annoying, but not painful.

I’m going to pop a piece of foam on the offending bit, and if that fails, out comes the Dremel!
 
Top Bottom