Failed to synchronize time with server

I'm try to launch the game via Steam but when i press Play i,m getting an error message "Failed to synchronize time with server" (i have like 200h in game and i didn't have any other problems until now). Also i tryed to download the Laucher from FDev but i get the same error. Also sync time in windows 10, restarting router, or reinstalling the game does not work!! Anythin else on laptop and any other game work fine. Does anyone know how to fix this?

EDIT: I remember now that 2 days ago I start the game and worked fine, then later that day an update from windows 10 came for .NET Framework and after that the game didn't worked (may be related?). Anyway I tried to reinstall the .NET and even reseting windows 10...
 

Attachments

Last edited:
Ok is your time settings in American or British English? Is "7/12/2019" the 12th of July or the 7th of December? Check that your time is ok, that your regional settings are ok and that your timezone is ok.

When the PC clock is off you can't establish https connections (security is time sensitive), so you'd probably get errors doing web banking, or visiting simple https sites. If you verify that all is ok with your pc, then there is the simple possibility that a Frontier server has problems, in which case others will start noticing, too. Best of luck, I'll start the game in a few minutes, too.

Edit: everything is ok on this end, using Steam, too.
 
Last edited:
The time-zone, the hour indicating, the date, everything is ok. I also check other forums and sites and there were a lot of ppl with this problem even recently (in April or so), but I didn't find a solution that works...
 
I have the same issue, I just ran windows update and it had some .Net patches, so I wonder if it broke it.
I have tried a re-install of the launcher and PC reboot - no good!
 
It may be worth checking your windows proxy settings. Open internet explorer (even if you use chrome, because chrome uses IE's settings), click the gear on the top right, Internet Options, Connections, and LAN Settings. Uncheck everything, especially the "Automatically detect settings" tick. Sometimes a malformed wpad.dat file from routers can cause problems.
You're not using any sort of VPN service are you? (grasping at straws, now) or some weird antivirus that tunnels traffic to check it....
Did you contact FD support?
Edit: Also, did you try connecting to your router's web page and checking the date/time there?
 
It may be worth checking your windows proxy settings. Open internet explorer (even if you use chrome, because chrome uses IE's settings), click the gear on the top right, Internet Options, Connections, and LAN Settings. Uncheck everything, especially the "Automatically detect settings" tick. Sometimes a malformed wpad.dat file from routers can cause problems.
You're not using any sort of VPN service are you? (grasping at straws, now) or some weird antivirus that tunnels traffic to check it....
Did you contact FD support?
Edit: Also, did you try connecting to your router's web page and checking the date/time there?
i'm not useing any proxy or VPN settings, and only "Automatically detect settings" is check, my antivirus is Windows Defender. I send a ticket to FDev, i'm waiting for a response now.
In my router web-page i can't find any date/time setting (i searched the web how to but there it isn't)
 
i'm not useing any proxy or VPN settings, and only "Automatically detect settings" is check, my antivirus is Windows Defender. I send a ticket to FDev, i'm waiting for a response now.
In my router web-page i can't find any date/time setting (i searched the web how to but there it isn't)
Ok, did you uncheck the "automatically detect settings?" and try again?
 
Top Bottom