Notice Fleet Carrier Update - Known Issues

Tim Smith

Lead Community Manager
Frontier
Greetings Commanders,

Thank you to everyone who has reported the issues they’ve found since the update went live. We’re reading all the feedback and the development team is working hard on resolving them as we speak.

This thread is intended to share which issues we are aware of and any information relating to them. We'll keep this thread up to date with news and information, so please do keep checking back for the latest updates.

Current known issues:
  • Commanders being kicked from the game and unable to rejoin, or taking a longer than expected time to rejoin.
  • Commanders experiencing crashes related to connection errors.
  • Various sites missing from the in game world, such as Dav’s Hope.
  • Commanders being unable to purchase a Fleet Carrier.
  • Some Commanders did not have to wait any time for their fast track quota.
    • Fast tracking Powerplay quotas is currently not available while we investigate a further fix.

Thank you for your help in reporting these issues and your patience as we investigate!

For any other issues we're going to be reading the feedback here, but please also submit them to our issue tracker: https://issues.frontierstore.net/

Tim

Update:

Morning Commanders,

Just an update to say that the development team are already investigating, the community team are reading all your feedback and we’ll be sharing more updates throughout the day when we have them.


o7 Commanders
 
Last edited:
Hey I lost my anaconda and 152M Credits My CMDR name is rascalix and it has placed me with one of my old ships the federal dropship please fix this I have many days of game time please fix if someone doesn’t fix this I might just quit Elite I just can’t get all that back again
 
I have a query.. if I have "Fleet Carrier Markers" turned on in Galmap.. should I not see where all current FC"s are located? I have that turned on and see nada on the map.
 
Also, I'm not sure if I'm the only one to notice but the carrier dry docks that are supposed to be in the fleet carrier vendor /admin systems are gone also.

edit to add, I play on xbox
 
Squadron bookmarks on Xbox seem to have been wiped. 300 something people, dozens of squadron bookmarks, none currently available.

(Much preferred the blue normal bookmarks to the orange as well)

Also Tim when you have a second I sent you discord link to "The Coalition" a collections of independent pilots with thousands of total members across over a dozen squadrons all on one discord. I'll forward this link to their channels for now.
 
i noticed that as well, so i tried to reshare an old book mark with my squad and they all popped into existence. Not sure if that is a work around or not. Though it doesn't look to be persistent.
 
Top Bottom