Flight Controllers Don't Acknowledge Landing Permission (again)

This minor but frustrating bug has again resurfaced in Elite. If you have a docking computer aboard your ship and you request landing permission, you get the permission but the Flight Controller doesn't say a thing. He only acknowledges your permission and points you to a landing pad when you engage the docking computer. If you land manually you don't get the "Permission granted. Proceed to landing pad XX" line. It's a minor issue but noticeable and takes away from the enjoyment (even if just slightly so). I haven't tested this with ships with no docking computers but in my experience the Flight Controller speaks all the lines fine when a ship doesn't have that. I guess the introduction of the new Advanced DC made the bug apparent again. (The bug occurs with both types of DCs.)

Please, if you experience and notice the same then confirm the bug here: https://issues.frontierstore.net/issue-detail/1689
 
Apropos voiced lines; the complete lack of dialogue from fighter crew is a bigger problem. Once, my trusty and longstanding subordinate used to communicate with words and phrases, now she just chirps digitally... Either she was an android all along and her vocal processors have malfunctioned, or there is a bug in Elite.

But yes, I noticed the station control thing a few days ago. I remember there being no vocal confirmation until the DC was engaged, which triggered the dialogue.

One time I was on the deck in a station and I heard the confirmation for a landing request - I don't think I had a DC on that ship, though, so it might not just be associated with that. I'm running evacuations at a station in my shiny (literally, it's chrome) new Corvette, so no DC's to test.

edit - ran some supplies to the evac ship, and fitted a DC (resupplying at a surface base) to the T9 to test it. And yeah, if you request docking and then power up the DC, you get the station control confirmation as normal, and can then use the automated landing.
 
Last edited:
I just ran a test myself and turned off my Advanced Docking Computer before requesting to land and I immediately received an acknowledgment to land and where. I then turned my ADC on and did an auto land.
This appears to be related to the former landing light issue whereby with a docking computer active you couldn't use the lights in a station. It seems docking computers mess with the programming.
 
It is definitely related to the auto docking computer. I asked for permission to land with no response . I then turned auto docking off and immediately received an approval to land.
 
If you think about it, when you have a dc powered up, the tower shouldn't need to tell you where to land, as the dc does it all once permission granted (and you are at zero throttle). Maybe working as intended?
 
Bug then. I think it would be much better if they knew you had a powered up dc and they just said something along the lines of "permission granted, sit back and enjoy the ride" or "permission granted, turn that thing off and don't scrape the walls on your way in. Pad 9 Mr Magoo" ;)
 
If you think about it, when you have a dc powered up, the tower shouldn't need to tell you where to land, as the dc does it all once permission granted (and you are at zero throttle). Maybe working as intended?
But this wasn't the behaviour previously, like the landing light issue it was introduced with an update. Previously, and correctly, you would get a response immediately after asking for permission to land. It is up to you to decide whether to use your DC not traffic control.
Eg. What if your DC failed you would need to know where to dock.
It's only a small thing I know but I prefer realism, it's what I like about the game even though it is futuristic.
 
Top Bottom