FPS Improvements for Beta, Release, or Post Release

While running the game I have experienced multiple issues with the FPS.

1: When having the game run in the background or playing for a while the game will slowly lower the FPS.
2: If you have used the coasters such as Barghest, Torque, or Tiamat you would notice that you will drop frames if you have a lot of them in the park while looking at all of them. (May just be an issue with my computer)
3: Maybe an option in the graphic settings, "Polygons [Low]
| [Medium]
| [High]
"
 
i dont know if it is possible, but it would be nice to make like 3 custom graphic sets, and when you start a coaster game it goes to highest custom set, when you have problems with framerates you can switch to medium and later on when your park gets more and more stuffed you can set it to low.
The game then remembers your setting with the savegame you have, making it auto switch to the right setting upon loading saving you lag.
 
i have tried it whit pennington park
if i set pc on high or low does not matter
fps will be always 10-20fps
but mayby the settings menu is stil not finished and not yet every function is changed in the game when you change the settings

only fps improvements it can get is atleast less utilization on the cpu
in pennington park it is 90% or higher and gpu load is less than 20%
the only thing what can use more utillization on the cpu is loading screen
i saw i uses 1core to load the park. it may use all 4 mayby that makes loading time even faster than now.

biggest question is stil what for fps improvements we can have
i hope we seen that soon enough
 
I've been getting major frame drop even in an almost empty park, all i have is 1/4 of a torque coaster layout and a few trenches made with the terrain tool.. starts at about 100fps+ and drops to around 35-40 after 30 minutes or so. The game also gets really laggy. I have an i7 4790k a gtx 980 16gb ram asus rog motherboard its not my computer it runs other games fine!
 
Last edited:
i think this happen's to everyone, i am using a 6800k and my cpu usage is about 35% across all 12 threads and my gpu is at 80% with about 4,000 people, but as you said it doesn't matter if my park is empty, my framerates start out high and tank to 20-30 fps after 20 min, all my other games are just fine.
 
Cant decide if i'm gonna spend 650€ for a new mobo, cpu and ram because i dont know if the game will run better on that :(
 
Cant decide if i'm gonna spend 650€ for a new mobo, cpu and ram because i dont know if the game will run better on that :(
Just get a good CPU, and 16GB ram. If you have anything under a GTX 950 SP+ 2GB then get one of those, it should help along with the other stuff. I don't really know anything else about computers lol
 
While running the game I have experienced multiple issues with the FPS.

1: When having the game run in the background or playing for a while the game will slowly lower the FPS.
2: If you have used the coasters such as Barghest, Torque, or Tiamat you would notice that you will drop frames if you have a lot of them in the park while looking at all of them. (May just be an issue with my computer)
3: Maybe an option in the graphic settings, "Polygons [Low]
| [Medium]
| [High]
"
There is certainly a bug with the coasters. I've noticed it as well. Interesting you have it only apply to certain types. I'll have to test
 
Cant decide if i'm gonna spend 650€ for a new mobo, cpu and ram because i dont know if the game will run better on that :(
i bought a 256 gb samsung sm961 m.2, with read speeds at 3200mbps and write speed at 2200mbps, this did not make much difference either, dont waste your money if your pc meets the recommended requirements, i am not blowing anymore money on hardware.i will wait until game release and see how well the sim runs.
 
Top