FSS still broken

Will was asking for videos, might be worth a crosspost (though I'm sure he'll see this :) )

Hello Darthtool,

We've been investigating the issue you raised earlier today with the team and require a little bit more information to understand the exact issue you're having. Is it possible for you (and any other Commanders experiencing this issue) to provide us some video footage of what you're experiencing?

Ultimately, this will help us understand when and where this is occurring. If you've previously made a Issue Tracker report about this, please also upload the footage there.
 
Honestly all I see in the video is your mouse sensitivity spiking with a corresponding frame rate drop. Probably cause of your recording software, what are you using to record Fraps? OBS?

Have you updated to the latest graphics drivers?
 
Honestly all I see in the video is your mouse sensitivity spiking with a corresponding frame rate drop. Probably cause of your recording software, what are you using to record Fraps? OBS?

Have you updated to the latest graphics drivers?
It's a new issue, and it isn't caused by my recording or graphics drivers.

You're seeing it behave the way it does because the thing gets "more resistant" (for lack of a better description) the closer you try to force it to the center. It's a sensation kind of like trying to force two magnets together where you've got both magnets' poles of the same polarity facing each other. If you've ever tried to do that, I think its a pretty good descriptor of how it feels like the mouse behaves in this issue.
 
Last edited:
Yeah I see it now, not even 5minutes after I said that the FSS started freaking out on me too. It Only happens when you zoom in on a group of objects (Double Circle?) what ever it is that you call it. Made my own video to show conclusively.

Should be up in another minute or two; (if you dont see it press f5 to refresh)
Source: https://youtu.be/Kr5TZpA9P88

As for how to fix this, I havnt programmed or had to do high level math in some time. From what I can tell its looks as if the there are axis issues X,Y,Z and the camera seems to be spinning at times on the Z axis (that is from the players perspective) at the same time the X and possibly the Y axis are free roaming. What should be happening is the objects on the plane should be static as should the X and Y axis the only thing that should move is the Z axis with a simple rotation. Coordinate planes are always a little funky to work with when you add the third dimension. If you watch my video you can clearly see that you can make the X axis rotate im not sure about the Y axis my eyes dont receive it but I could be wrong.

Or I have the Plane Designations mixed up in which case the camera is spinning on the Y axis, X is free roaming, and as soon as you extend the field of the Z axis everything goes wonky. The only thing the player should have control over is where 0,0,0 is, that is unless of course the FSS considers us to be on the plane as well and 0 is the base star on the plot?
XYZ.jpg
 
Last edited:
From what I can tell its looks as if the there are axis issues X,Y,Z and the camera seems to be spinning at times on the Z axis (that is from the players perspective) at the same time the X and possibly the Y axis are free roaming.
Ever since the FSS was introduced you've been able to rotate around the Z axis by spinning the mouse in circles, so that's not new (not saying that I like it, though). However, for it to continue spinning once you stop moving the mouse in circles, well I've never seen that before..
 
Can't confirm this yet (but will do a few full system scans soon. Maybe then I can).
Since everyone and his grandma is playing on VR these days... do you? And could it be a VR exclusively thing?
I'm using joystick and gameboard (no typo: not a gamepad) and no mouse, in case it matters.
 
Top Bottom