Game Suddenly Started Crashing... Why?

Hello all!

Unfortunately, I've just run into a serious crashing problem. I recently purchased the game and have spent the past few days "tagging" all of my items so while I'm building parks, my items are easy to find. Everything has been working fine for the past several days, until today. It crashed. And now it keeps crashing.

Whenever I click one of the item menus such as "Blueprints, Toolkit Items, Scenery" etc... it crashes. I have tried loading 4 different saves (my own, plus all 3 autosaves) as well as loading a brand new sandbox park... no matter what, as soon as I click an item menu, it crashes. I was almost done tagging and very much looking forward to starting my own parks. Now I can't play at all. Does anybody know what's wrong?

Any help would be greatly appreciated, and thank you in advance!
 
Yeah, I already have a ticket open. So far it hasn't been able to resolve anything. Was just hoping to try another avenue, as nobody I've talked too seems to understand why this is occurring with my game, nor how to go about fixing it. :(
 
As this is a real issue, that makes the game unplayable, I'd suggest mailing them directly at community@frontier.co.uk.

And if possible, send the save game with it.

I wouldn't know what the issue is, I guess tagging every single item pushes to much load on the game?
I suppose your computer is at or above minimum requirements?
 
Yeah, my PC is sufficient according to their recommendations. Since then, I have tried everything I can possibly think of. I have made sure my Windows is up to date, my GPU drivers are current. I have uninstalled every single Steam Workshop item, I have uninstalled and reinstalled the game in several different ways (trying new directories, a different hard-drive, etc) and no matter what I do, the game runs perfectly smoothly until I click one of the blue item menu tabs... then it locks up for a few seconds and crashes. Really wish I could figure this out.
 

Paul_Crowther

Community Manager
Frontier
Post has been removed for promoting rule breaking activity. We have not released any changes or updates to Planet Coaster for several months so your description would indicate an issue with the Steam Workshop. You may wish to try uninstalling and reinstalling your Steam client. If you continue to experience issues after this please report them on our Issue Tracker so our developers can investigate further. If you have not yet received a response from our support team you may wish to submit a new ticket here who will aim to get back to you as soon as possible.
 
I have reinstalled the Steam client, as well as the game, several times. I've also clearly had a ticket open awaiting a response this entire time. Your solution is to just keep spamming support tickets and hope that someday they'll care enough to respond? Your support team is the first place I went to ask for help. They just happen to also be offering the least amount of assistance. Which is ironic, since they're the people I paid for the game. And I wasn't "promoting" anything. In fact, I specifically stated I had zero interest in actually playing it. I was simply testing another game file, since the company that makes the game doesn't seem very interested in helping me. Funny how that's the most progress I've been able to make. I'll go ahead and just request a refund if this is how it's going to be.
 
Last edited:
Top Bottom