Help! Some of my textures are backwards!

After a lot of wrestling I finally managed to upload an item into TMT, but when I placed it in the game, some of the textures are facing the wrong way so that the front is invisible and you can see the back, and the opposite if you are looking from the back. What did I do wrong and how do I fix this?
 
That sounds like your normals are reversed. What program are you using?

If Blender, go into Edit mode, select everything, and go to the Shading/UVs tab in the left hand menu. (Press T if you can't see the left menu). Under Normals, click "Recalculate" - that usually fixes it unless it's a very unusual shape!
 
That sounds like your normals are reversed. What program are you using?

If Blender, go into Edit mode, select everything, and go to the Shading/UVs tab in the left hand menu. (Press T if you can't see the left menu). Under Normals, click "Recalculate" - that usually fixes it unless it's a very unusual shape!
Well that kind of worked. The textures that were reversed are now normal, but the textures that were normal before are now reversed. This is really frusterating.
 
Hm, okay, so it's not a shape Blender can figure out on its own. You may have to fix the normals manually. Try this:

  1. In the right hand menu (press N if you don't see it), under "Shading", turn on Backface Culling. (This will make it so the textures are only shown on the front side, which is what Planet Coaster does - so you should now see the same faces messing up as are messed up in game)
  2. Go into Edit Mode and use Face Select mode to select any faces that aren't working right.
  3. In the left hand menu, in the Shading/UVs tab, click "Flip Direction".
When all of them look right in Blender, they should also work correctly in PlanCo.

I hope that helps!
 
Top Bottom