Release Issues with Voice Attack while managing ED's panels

Is anyone else having problems to manage panels in Elite Dangerous with Voice Attack after ED 3.3?

Before ED 3.3 my panel commands (to open left, right, comm, center panel (any of their tabs)) worked flawlessly. Now sometimes they work, sometimes they simply don't. However, there is no pattern.

At first I thought "ok, the VA profile is broken". But then I opened the notepad and tested all the panel commands. I did this several times, more than 15min... ALL commands worked as intended (the key press showed as expected on the notepad).

Then, back to the game... sometimes they work, sometimes they don't.

Any hints?

(by the way, I am the responsible for the Vector Sigma profile (https://sites.google.com/view/vector-sigma))

FIXED

I really forgot to come back here telling I found what was causing all that trouble to me: typing error.

The command to issue a key press was "press key, hold for 0.008seconds then release". It was too short a time. All the other commands I have use "0.08s". So, of course the other commands were OK, just the ones for the panels were misbehaving *LOL*
 
Last edited:
I had heaps of issues with the HCS plugin and Voice Attack, panels was apart of it and been slow responding to commands, that and the mic always been muted, had to keep saying "Wakeup" before each command, it nearly crashed me a few times.

Voice attack itself, keeps closing down, and HSC and Voice attack kept suggesting it must be other third party apps.. ( one of the most used ones) So I deleted / uninstalled that widely used app and the issue of VA closing down and the muted mic still kept happening. Finally I gave up on HSC and VA in Discord in trying to find the problem, as there was no real help forth coming, from either VA or HSC.
So posted in Voice Attack on steam asking if anyone else had the same issues I was having, to see if I could find the problem, only to have that Steam post "disappear". (got another thread going today)

So I decide to remove/uninstall the HSC plugin as that was the only plugin left ( which is a problem using VR now as I cant play without Voice assistance ) and all my binds in ED Options where wiped !.
it was a real mess, still sorting it out, even put in a tick to Frontier ( no help there either) So I went back to HSC Discord, an HSC said "impossible its not HSC Plugin" that could wipe your binds...whatever.
Fact is I deleted HSC Plugin and my binds go south, not making this nightmare up !.

So then I'm left with, no binds and no HSC Voice pack, and no other plugins just plain Voice attack, and still VA keeps shutting down, but at least the mic was no longer muted.... progress hahahaah !

Its clear this problem is seen as 'my fault' or the "PC fault" Yet Ive ran every scan on the system have a paid anti virus and this PC is a 2018 PC gaming build, has the latest of everything, its used for gaming nothing else, built for VR

Ive ran Windows 10 file checker 3 times now, had the Tech from the shop where we pick each part and who built my PC, come to my house ( paid for the service) to check nothing is wrong with my PC !
( bench marks where above avg )

YET STILL VOICE ATTACK KEEPS SHUTTING DOWN.

So in answer to your question is there anyone else having issues .. yes me .. the Question is are there any more players with issues ?
'
This is the error code for Voice Attack shutting down

Faulting application name: VoiceAttack.exe, version: 1.7.3.0, time stamp: 0x5bf1e60a
Faulting module name: ntdll.dll, version: 10.0.17134.556, time stamp: 0x319e0a75
Exception code: 0xc0000374
Fault offset: 0x000d8529
Faulting process id: 0x25c0
Faulting application start time: 0x01d4afbeb5f2c680
Faulting application path: C:\Program Files (x86)\VoiceAttack\VoiceAttack.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: e1feb26f-2ca9-4df1-aac1-b55e24453cdb
Faulting package full name:
Faulting package-relative application ID:
 
Last edited:
I have given up trying to make voice attack work. I don’t have a background in computing and that means I need their help to the extent that they ignore me now. 3.3 broke it completely. “ I can’t make it work, tell me how?” I asked...”it’s only you” was the response. Sad really, was good for a while though but.
 
Working fine for me.

I'd suggest Uninstall/re-install latest versions available for both VA and HCS Voice packs. Be sure that you delete all remnant subdirectories during uninstall and kill any and all old .vap files.

Managing and figuring out where the vap files are and how to be sure the latest one is loading can get pretty confusing - especially if you run EDDI concurrently.

The whole structure could really benefit from some simplification.

Worst part is that you can no longer edit the latest HCS vap file directly - it's been locked down in an effort to facilitate future upgrades. Sort of a good idea, maybe. Time will tell.

HTH
 
I have given up trying to make voice attack work. I don’t have a background in computing and that means I need their help to the extent that they ignore me now. 3.3 broke it completely. “ I can’t make it work, tell me how?” I asked...”it’s only you” was the response. Sad really, was good for a while though but.
The level dismissive arrogance sadly is something Ive come across too, in my post in Discord the reply had a photo attached, of a large frog, with the comment " is this a toad"

PS ”it’s only you” was told to me also ..:)
 
Last edited:
Yes..delete vap files, reinstate c data log whatnot doodahs...ummm...no idea me, so put a warning on it or help me out. It’s not recommended for those who have no interest in how a pc works. Annoyingly I have followed the instructions to the letter and it still doesn’t work! The videos pointed to on YouTube are irrelevant as they are outdated. I WANT this to work, being a vr player, I really do.
 
Yes, following themdirecting me to their outdated youtube videos (irrelevant material) they sent me to 'discord'. I have had no experience with this. No idea whats going on on that...then the emailresponse much like yours! It really is a shame. 'Its only you!' well that's ok then!
 
There's no doubt that VA/HCS is pretty much a self-help endeavour.

My experience is similar in that the forum responses are rather abrupt and seldom on point and largely insufficient to solve a users problem.

There is a lot of information available that can usually sort things out, but that's not much help for any user that doesn't want to spend days figuring out all the details needed to make things work. VA, HCS, and EDDI are pretty complex products for the common user. The fact that adequate support from HCS is lacking is rather sad.

In contrast, the guys working on EDDI do a great job.

That said, having both working together is a really good game experience - but it does take a lot of work to get right.
 
Last edited:
There's no doubt that VA/HCS is pretty much a self-help endeavour.

My experience is similar in that the forum responses are rather abrupt and seldom on point and largely insufficient to solve a users problem.

There is a lot of information available that can usually sort things out, but that's not much help for any user that doesn't want to spend days figuring out all the details needed to make things work. VA, HCS, and EDDI are pretty complex products for the common user. The fact that adequate support from HCS is lacking is rather sad.

In contrast, the guys working on EDDI do a great job.

That said, having both working together is a really good game experience - but it does take a lot of work to get right.
First up, I’m not having any issues with VA+HCS+Windows 10+ED etc....but that doesn’t help you.

Why I am responding is the due to the negative comments about the HCS discord and forums.
I’ve not needed any help recently, but did use both the forum and the discord a fair bit about a year back.
I found them to be extremely responsive and helpful, so I’m a bit disappointed to hear they may have gone downhill recently.

It’s great that you’ve posted details about your error sutex, I might have a bit of a dig around and if I find anything useful, will revert here.

Kenjiro, I think GJ51 advice is sound, uninstall HCS and VA and make sure all remnants are gone.
Then reinstall latest (supported) version of VA then make sure you are downloading the absolute latest version of one of your HCS voicepacks and re-install as per their instructions (ie plugin first), then test as is (ie do not customise anything if you are in the habit of doing so) and see how you go.

Clicker
 
Yes, following themdirecting me to their outdated youtube videos (irrelevant material) they sent me to 'discord'. I have had no experience with this. No idea whats going on on that...then the emailresponse much like yours! It really is a shame. 'Its only you!' well that's ok then!


Read this thread I started on Steam, first part gives some advice , the latter is a bit 'loose' , update not surprised by been ban, as no help was forthcoming just insult the users and blame the machine, not been allow to deal with VA dramas in any VA official forums now, clears the way for santiy !
https://steamcommunity.com/app/583010/discussions/0/1742231705662869746/?tscn=1547922447



 
Last edited:
Well, I never used HSC voice packs (couldn't afford them). I first tried Anubis (great work from Zenuel) but since the project was dead (he said he wouldn't be updating it) I started my own project: Vector Sigma.

Like I said, before Elite Dangerous version 3.3 Sigma's panel management worked just fine. Now it works... it doesn't... it works again...

I am still trying to figure out what I have to do in order to have my VA profile working 100% again. I will try and make some more testing this week, adding LOADS of "output" to the log window and see if I find what is wrong.
 
I have given up trying to make voice attack work. I don’t have a background in computing and that means I need their help to the extent that they ignore me now. 3.3 broke it completely. “ I can’t make it work, tell me how?” I asked...”it’s only you” was the response. Sad really, was good for a while though but.
Uninstall (including all voicepacks and profiles), then install the latest version of VA - should be good to go - I have no issues with it at all.


I......... the Question is are there any more players with issues ?
'
This is the error code for Voice Attack shutting down
....
Faulting module name: ntdll.dll, version: 10.0.17134.556, time stamp: 0x319e0a75
Exception code: 0xc0000374
......
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
.......

The answer from me is no I have no issues with VA and any of my HCS voicepacks.

1. Have you considered that ntdll.dll might be an issue in your machine - there are over a million google hits on issues with it.

2. Did you completely uninstall the HCS voicepacks and delete all profiles before updating VA? (Old versions have issues in either direction.)

3. I have found the HCS forum to be very helpful, sorry to hear you have not found this.
 
Last edited:
Well, I never used HSC voice packs (couldn't afford them). I first tried Anubis (great work from Zenuel) but since the project was dead (he said he wouldn't be updating it) I started my own project: Vector Sigma.

Like I said, before Elite Dangerous version 3.3 Sigma's panel management worked just fine. Now it works... it doesn't... it works again...

I am still trying to figure out what I have to do in order to have my VA profile working 100% again. I will try and make some more testing this week, adding LOADS of "output" to the log window and see if I find what is wrong.


Going though all the debug files discovered a "corrupted heap" given I had uninstalled VA re-installed VA numerous times to try and fix my issues, to no avail

I went with a more complete solution, just for Voice Attack.

I used this Revo Uninstaller 2.0.6 Free to uninstall VA and used the advance mode to removed all the registry keys associated with VA.

Next step
used Everything Search Engine to delete every folder belonging to VA, rebooted and then re-installed VA, ( you need to re-enter your license key)
Seems the VA uninstaller leaves stuff behind, which if corrupted, 'seems to be' reapplied. In any event doing all that has fixed my issues (I hope) for VA worked for hours without crashing and without a muted mic, and with my favorite plugin the G19 app for Elite dangerous running, the fault was with VA was never my PC but with VA itself !


If anyone is interested in the Dumpfiles and Error logs associated with the drama I had with Voice Attack PM me.

Voice Attack was not interested in looking at these files, even after I asked repeatably asked for these logs to be taken and viewed to assist with a Fix and to help stop others from having problems in the future.
 
Last edited:
I am still waiting, pointlessly, for the voice attack reply...thanks sutex for this. When I get the chance i will give it a go, thanks again!
 
Last edited:
Try my profile: https://www.dropbox.com/s/e38zrzm5tec8td2/Acecool-Elite Dangerous-Profile-Feb2019.vap?dl=0

It works for me... The one thing I have to do though, and mind you I am on a 10 year old machine.... is set VoiceAttack.exe priority to above normal, or realtime... This makes the delay next to 0 when speaking and it handling the command. Otherwise it can take up to 10 seconds which is annoying.
I have a ton of features, including deploy rover, request docking, power management, targeting, and a few others...

I tested them a few months ago and they still worked... You will need the binds dll https://www.dropbox.com/s/s7kvj7gio1a0iyj/Custom.2.0.binds.zip?dl=0

Basically, when you load my profile, say Load System which executes everything needed, resets the data and assigns all of the bind mapping ( If you edit your binds in Elite Dangerous, simply say Load System again and the script will have the latest binds ). You never need to change teh binds in the script.

If you want, you can change any of the voice commands, and you can add hotkeys too... If you want to change power management, take a look at how it is done. The first section resets it ( power reset code should be the same for everything if I recall correctly ) --- Strike that... Just remembered I did a major overhaul on this... I try to prevent repetition in all of my code as a general rule / coding standard... So, there are presets to reset the power to 2 2 2, then you simply adjust from there...

Self destruct hasn't been created yet. I can't recall whether this was because I haven't found a way to navigate the menus as there is no hotkey, or is there? The way I navigate menus is, because your position in the menu is always remembered, by finding a way to zero the menu to the same point every time and then I make changes from there. With deploying the rover, you can go up or down without it cycling through, so that's what I do. For most of the other stuff it is just hotkey execution. Silent running automatically shuts off your exterior lights / beacons if they are turned on which is a simple yet nice feature to have...



Anyways... I really hope my profile can help you... It works on my 10 year old machine ( And I just won an x299 mbd and processor on eBay for $580 or about less than half price of both parts so.... now I just need memory and a heatsink and I'm good to go...

I will be looking into EDDI next to add even more features to the system such as auto deploy landing legs when near landing pad after requesting docking, auto retract when taking off ( easiest to do because they have a tutorial for it anyways ), and see what else I can come up with to make the game more realistic ( honestly, by the time we have warp drive, and all of the technology which is possible to achieve, space-ships will be so heavily automated that a single person could fly it... Honestly, it'll probably be single-button flight... Take me to Earth., take me to .... and it'll map the most efficient course, plot fuel stops, etc... And you just do whatever it is you do onboard... Although, if money ends up still existing then there may be different tiers with that what I just said as being top of the line, and fully manual control being bottom )... Who knows... It's fun to think about though.
 
Last edited:
I really forgot to reply here telling I found what was causing all that trouble to me: typing error.

The command to issue a key press was "press key, hold for 0.008seconds then release". It was too short a time. All the other commands I have use "0.08s". So, of course the other commands were OK, just the ones for the panels were misbehaving *LOL*
 
i had that issue with the panels not lining up before i uninstalled the voice packs ( got tired of it and wanted peace and quiet), there is a reset panels/buttons command that you can say that will fix it However for the life of me i cannot remember it, all i remember was that it was a pain the backside to have to say it every other day after asking for it to dock for me and it'd open nav tab.
 
I really forgot to reply here telling I found what was causing all that trouble to me: typing error.

The command to issue a key press was "press key, hold for 0.008seconds then release". It was too short a time. All the other commands I have use "0.08s". So, of course the other commands were OK, just the ones for the panels were misbehaving *LOL*
Maybe consider editing your OP with this info then?
 
Basically, when you load my profile, say Load System which executes everything needed, resets the data and assigns all of the bind mapping ( If you edit your binds in Elite Dangerous, simply say Load System again and the script will have the latest binds ). You never need to change teh binds in the script.

If you want, you can change any of the voice commands, and you can add hotkeys too... If you want to change power management, take a look at how it is done. The first section resets it ( power reset code should be the same for everything if I recall correctly ) --- Strike that... Just remembered I did a major overhaul on this... I try to prevent repetition in all of my code as a general rule / coding standard... So, there are presets to reset the power to 2 2 2, then you simply adjust from there...
I am really interested on such feature. It would be VERY NICE if my profile could read players keybinds and ajust itself acordinlgy.

Which plugin should I use for that? Thanks for your attention
 
Top Bottom