Keeper isn't feeding animals

The keeper isn't doing anything, he has his own Keeper room already and his habitat, but he just let the animals die instead of feeding them.. In every single new zoo that in building, there is every time the same bug.. Great game!
Is there any fix for this? This is extremely gamebreaking and isn't worth 45€!!
 
I was watching a YouTuber earlier that had this problem. He eventually solved the issue by leveling up his zookeeper to level 2. Maybe try that, see if it works?
 
I can't imagine that this bug is following you from park to park.

A few standardquestions: Is your keeper room powered, opened and connected to your paths? Have you placed an door to your habitat?

Sidenote: At the beginning it's absolutely normal, that keepers don't feed instantly. This is because your animals arrive well fed and there's no reason for your keeper to feed them right at the beginning. But when you say your animals are starving... mmmh.
 
I can't imagine that this bug is following you from park to park.

A few standardquestions: Is your keeper room powered and connected to your paths? Have you placed an door to your habitat?

Sidenote: At the beginning it's absolutely normal, that keepers don't feed instantly. This is because your animals arrive well fed and there's no reason for your keeper to feed them right at the beginning. But when you say your animals are starving... mmmh.
Yeah I've never had an issue with keepers not feeding animals, neither in the beta nor full release... And it feels like it would be a persistent bug, not one that only affects select players.

I've noticed through streams and videos that when keepers don't feed the animals immediately, they get confused and start to spam the "call keeper" button, or moving the keeper around, etc. Each time would end up cancelling whatever the keeper was planning to do, and I wonder if constant interference is what's causing the keepers to "not work" 🤔

I never watch/micromanage my keepers, I just let them do their own thing and they're fine.
 
So when the points I've asked for are met and you say that it worked fine yesterday... I think then it's worth to check your local game files;

Close Planet Zoo > Rightclick Planet Zoo in your steam library > settings > local files > verify integrity of game files.
 
Top Bottom