Lighting weirdness

GUIDE FOR FIXING THIS ISSUE IS BELOW

I am currently trying my hand at creating simple objects to learn the ropes. I have some experience with Blender but this is baffling me.

Currently, this hexagon only has BC and F1 textures, and It's a very simple object. Whenever I rotate it along the Z axis, and sometimes in other orientations, the lighting drastically changes to be darker.
I've checked that the normals are correct, and the texture seems to be applying correctly (The crude L you see is simply something I added to make sure the texture was applied correctly, and to visualize the rotation). I seem to recall maybe having this issue with another official object in the game before, but not able to remember what it was.

Anyone else get this issue or have a solution?

lighting oddness.jpg

GUIDE ON HOW TO FIX

Option #1: Binary Method (NEW & EASIER)
MAGICAL BINARY SETTINGS.PNG
-Build your model as if Y= Forward and Z = UP!
-Can use Meter Scale (Centimeter scale should also work as long as your dimensions are correct)
-APPLY ROTATIONS AND SCALE. Rotations must be set to 0
-Remember to also check the "Animation" tab and turn off animations if exporting a static object.
-No need for any strange rotations.



Option #2: ASCII Method
ALSO SEE MY VIDEO TUTORIAL HERE

1) Change Unit Preset to "Centimeters" (Or else is Equivalent to setting Length to Metric and Unit Scale to 0.01)
Scene settings will look like this : https://i.imgur.com/hvgMlZC.png
correctsettings1.png

2) if you've already built a model it will need to be scaled up 100 times larger to be the correct scale. APPLY the scale to your objects.
If you change the scale before you start building, it will be built in the correct scale and wont need to be scaled up.

3) If your object is facing so that Y=Forwards and Z=Up (which is usually the default way people model), ROTATE Your object around the world origin -90° in X axis and 180° in Y axis. You are aiming to rotate your object so that Y=Up and Z=Forwards.

4) APPLY ROTATION AND SCALE TO ALL OF YOUR OBJECTS.

5) Export your model using these settings: https://i.imgur.com/1W5JkQx.png
correctsettings2.png

Thanks to mineraljunction, oli414, OlaHaldor and others for helping find this solution.
 
Last edited:
Having the same issue with a wall piece. One side is normal, the other is darker and more reflective. Tried to flip the normals, recalculate them, invert the uv map, etc... without any luck for now. Since it's taking almost an hour each time I upload an item, it's hard to find a solution quickly...
 
Do you happen to have Marmoset Toolbag? Could you check the mesh+textures there?
(I have it, if you like I could have a check)

It looks like a normal issue to me, but it's weird it only happens when you rotate the mesh.. [weird]
 
Do you happen to have Marmoset Toolbag? Could you check the mesh+textures there?
(I have it, if you like I could have a check)

It looks like a normal issue to me, but it's weird it only happens when you rotate the mesh.. [weird]
I don't have Marmoset Toolbag but the weird thing is that it's working fine in the blender render engine. I even tried in Element 3D in After Effects and every thing is working in the two different engine.
 
same for me. Top of some models are darker and the underside is lighter (also flipped the green channel on the normals) but it stays the same.
 
Well I tried everything I could think of, even changed my Uv map so that no faces overlap with each others...
I give up, I'll wait that someone finds the solution.

20181122152212_1.jpg
 
Well I'm glad I'm not the only one! Here's a gif showing how little I have to rotate to have the issue!
Lighting Issue.gif

I'm sharing all my files in the name of learning and helping solve the issue. Included is everything from the .blend to the final .pcugc, including the entire package .zip structure and contents (.fbx and textures)
View attachment Hex files.zip
 
Same exact issue here, loads of objects on the workshop have it too.

I wish it was just because my normals are incorrect but it loads perfectly fine in anything else (Unreal, Unity etc)

You folks are all using Blender too I figure?
That's the pattern that I'm seeing, haven't found anyone who got a blender export working without the weird lighting yet, made a post about it on the steam discussion today as well:
https://steamcommunity.com/app/493340/discussions/0/1741100729952769999/
 
Yes it seems to be a Blender problem...

Here is every thing I tried that didn't work so far, so that others don't loose time doing the same :
-Recalculate Normals
-Flipping normals
-Flipping only one side on normals
-Changing UV map so that no faces are overlaping with each other. the opposite sides of my walls were overlapping since it's the same textures so I changed that and didn't work.
-Exporting Fbx with smoothing to faces instead of normal. didn't work.
-Exporting Fbx in ASCII instead of Binary. Didn't pass the upload test, saying object is too small.
-FBX export that has the "Tangent Space" box checked. didn't work
-standard FBX that has been converted with "FbxConverter" from autodesk. didn't work
 
Last edited:
@OldHaldor I'll try your FBX in a bit. EDIT: Confirmed that your FBX fixes the issues!
but that sounds like a problem with Blenders FBX exporter? The scale is set to 1.0 everywhere in the blend file and during export. Gotta figure out if theres anything we can be changing to fix this. I'm gonna try changing the "Apply scalings" option in the exporter, which defaults to "All Local". EDIT 2: Changing to "All FBX" does not fix the issue. I might want to try the other options, but at this point I'm gonna wait for more information from others.
 
Last edited:
Just downloaded 3ds max (yes, legally, already got a PM within a minute asking for a illegal dl link), works perfectly. Just imported that FBX into Blender and exported it to an FBX again and gonna try to see what that is going to do. After that I'll try it the other way around. That should give a pretty good idea of whether or not it is Blender's FBX exporter.

Edit1: The 3ds max FBX, imported into Blender and exported again messes up again. Gonna try a Blender FBX imported into 3ds max now.
Edit2: The blender FBX imported into 3ds max and exported again works perfectly again.

Conclusion: Something is up with Blender's FBX export, and I wonder if Frontier has a solution to this seeing as they say to have it all tested with blender as well...
 
Last edited:
Just downloaded 3ds max (yes, legally, already got a PM within a minute asking for a illegal dl link), works perfectly. Just imported that FBX into Blender and exported it to an FBX again and gonna try to see what that is going to do. After that I'll try it the other way around. That should give a pretty good idea of whether or not it is Blender's FBX exporter.

Edit1: The 3ds max FBX, imported into Blender and exported again messes up again. Gonna try a Blender FBX imported into 3ds max now.
Edit2: The blender FBX imported into 3ds max and exported again works perfectly again.

Conclusion: Something is up with Blender's FBX export, and I wonder if Frontier has a solution to this seeing as they say to have it all tested with blender as well...
Thanks for the info ! Hope this can be fixed because it make Blender kind of useless right now... I'll try to download maya to export my fbx.
 
Found this on the net!
Can someone please try this settings and tell the result?

0duezB7.jpg

Someone said it's good to check "tangent space" under geometry, but others said it messed up the rotation!

It's worth a try!
 
Just tried the following settings. It still produced the weird lighting effects, but it didn't have any weird transformations either. In other words, it made no difference.
lucasexportsettings-1.jpg
I'm going to try alternating some of these options and see if a certain combination makes any difference.

EDIT: I also tried exactly the settings BeckysFootSlave showed in their picture, INCLUDING -Z forward and Y up, turning Apply Transform ON, and Tangent Space OFF. Only change was to disabled animations. It really made no difference!
 
Last edited:
@Lucasup
What happens using "my" settings in this way:

Select just the objects for export
Open fbx export and then check "selected objects"
Then export

Or maybe it is better to download the original fbx converter from autodesk?

I don't use blender just tried to help using Google with "blender fbx export settings" as search!
 
@Lucasup
Select just the objects for export
Open fbx export and then check "selected objects"
Then export
Sorry I should have said that I did this (pretty sure). I've tried doing and not doing the "selected objects" only method in many of my upload attempts, and haven't seen any differences by doing it this way or not.

And yeah I might try messing around with the autodesk converter.
 
Some people are saying they found the solution.

In Blender set your unit scale to 1 unit = 1 cm. Then scale your models by 100. This is what Max does as well. Too bad that they don't actually explain this properly in the guide. Took way too much time to figure out.
 
Top Bottom