Major performance problems

Hi

I've been playing ED on a PS4 Pro without any problems at all, and having just got a gaming rig for sim racing I thought I'd try ED on the PC with a Rift S - I'd bought it years ago for the Mac, but never really got into it and then Frontier killed Mac support, so I was able to re-download it from steam and also get a redemption code for the Oculus store.

My problem is that I get a relatively stable 60FPS on the PS4 pro, but on the PC it starts out OK but within 2 minutes it's a slide show - honestly no more that 5FPS, and this is just doing the new training introduction, and this is at 1080p flat screen resolution - I haven't tried VR yet.

When I check the resource use on my PC I can see that when ED is running both the processor and the GPU are only around 5 - 10% usage. Basically ED isn't actually using any compute resources.

Any ideas what's going on here. Everything else I'm running is absolutely fine.

Specs
Core i9 9900K @5GHz with custom loop cooling.
Nvidia RTX 2080 Ti
32GB RAM
512GB NVMe SSD (Samsung)
 
With that rig your should be hitting over 100FPS and more in space at 4k

I do with mine, only difference is I have i9 7940X cpu

Check in display options in game, check you dont have a frame limit set. I have seen this be enabled before after a crash or switch from VR
 
Sounds like a scheduling or memory management problem. I'd check power profiles, game mode, and make sure Windows is updated and that you have the newest drivers.

Also see if anything unusually demanding is running in the background.
 
I have a similar problem but since Im out in the black its only happening on / near planets. As soon as the glide starts there is stuttering. On the surface its getting unplayable to the point where the game freezes every other moment.

The strange thing is that its not tied to any graphic settings that I changed. It doesnt matter if I play on low settings or high, its basically the same. The only real difference is vsync. Its a bit less bad when vsync is on.

I have a xeon 1230v3, rx 590, hdd 7200rpm, 16gb ram (and win7). I should get buttersmooth 60fps on medium or even high settings but thats not the case. What I also notice, just lke you, is the somehow lack of gc usage. Its as if the gc is idle. I dont hear the fans, the temperature barely goes over 45°. Where the hell is the work load?!

I run ed in borderless with medium settings at 1080 but with now low settings for terrain. Furthermore I tweaked the graphics a bit:



XML:
<GalaxyBackground>
    <Low>
      <LocalisationName>$QUALITY_LOW;</LocalisationName>
      <TextureSize>1024</TextureSize>
    </Low>
    <Medium>
      <LocalisationName>$QUALITY_MEDIUM;</LocalisationName>
      <TextureSize>1024</TextureSize>
    </Medium>
    <High>
      <LocalisationName>$QUALITY_HIGH;</LocalisationName>
      <TextureSize>2048</TextureSize>
    </High>
  </GalaxyBackground>

<GalaxyMap>
    <Low>
        <LocalisationName>$QUALITY_LOW;</LocalisationName>
        <NebulasCount>10</NebulasCount>
        <NebulasInBackgroundCount>40</NebulasInBackgroundCount>
        <LowResNebulasCount>16</LowResNebulasCount>
        <HighResNebulasCount>1</HighResNebulasCount>
        <LowResNebulaDimensions>64</LowResNebulaDimensions>
        <HighResNebulaDimensions>256</HighResNebulaDimensions>
        <LowResSamplesCount>25</LowResSamplesCount>
        <HighResSamplesCount>128</HighResSamplesCount>
        <MilkyWayInstancesCount>6000</MilkyWayInstancesCount>
        <LocalDustBrightness>0.13</LocalDustBrightness>
        <MilkywayInstancesBrightness>3.0</MilkywayInstancesBrightness>
        <MilkywayInstancesSize>1.3</MilkywayInstancesSize>
        <MilkyWayInstancesOffscreenRTEnabled>true</MilkyWayInstancesOffscreenRTEnabled>
        <StarInstanceCount>2000</StarInstanceCount>
    </Low>
    <Medium>
        <LocalisationName>$QUALITY_MEDIUM;</LocalisationName>
        <NebulasCount>20</NebulasCount>
        <NebulasInBackgroundCount>40</NebulasInBackgroundCount>
        <LowResNebulasCount>16</LowResNebulasCount>
        <HighResNebulasCount>1</HighResNebulasCount>
        <LowResNebulaDimensions>64</LowResNebulaDimensions>
        <HighResNebulaDimensions>256</HighResNebulaDimensions>
        <LowResSamplesCount>30</LowResSamplesCount>
        <HighResSamplesCount>110</HighResSamplesCount>
        <MilkyWayInstancesCount>10000</MilkyWayInstancesCount>
        <LocalDustBrightness>0.13</LocalDustBrightness>
        <MilkywayInstancesBrightness>3.0</MilkywayInstancesBrightness>
        <MilkywayInstancesSize>1.3</MilkywayInstancesSize>
        <MilkyWayInstancesOffscreenRTEnabled>false</MilkyWayInstancesOffscreenRTEnabled>
        <StarInstanceCount>2000</StarInstanceCount>
    </Medium>
    <High>
        <LocalisationName>$QUALITY_HIGH;</LocalisationName>
        <NebulasCount>30</NebulasCount>
        <NebulasInBackgroundCount>40</NebulasInBackgroundCount>
        <LowResNebulasCount>16</LowResNebulasCount>
        <HighResNebulasCount>1</HighResNebulasCount>
        <LowResNebulaDimensions>64</LowResNebulaDimensions>
        <HighResNebulaDimensions>256</HighResNebulaDimensions>
        <LowResSamplesCount>35</LowResSamplesCount>
        <HighResSamplesCount>138</HighResSamplesCount>
        <MilkyWayInstancesCount>12000</MilkyWayInstancesCount>
        <LocalDustBrightness>0.13</LocalDustBrightness>
        <MilkywayInstancesBrightness>3.0</MilkywayInstancesBrightness>
        <MilkywayInstancesSize>1.3</MilkywayInstancesSize>
        <MilkyWayInstancesOffscreenRTEnabled>false</MilkyWayInstancesOffscreenRTEnabled>
        <StarInstanceCount>4000</StarInstanceCount>
    </High>
  </GalaxyMap>
</GraphicsConfig>


These settings lower the amount of stars in the galaxy map - which now takes up to 5 seconds to open. And it greatly changes the brightness, which is how I imagine space would be. Full of bright stars blinding you (actually the setting is still tame, I experimented with settings above 6)

I will now test things I have not yet tested, maybe its gone when I deactivate the fx.

Oh I forgot to mention Im using reshade but that does nothing.

First text fx off, terrain medium, material as well, fullscreen: reduced amounts of freezes. As soon as I am near my ship the freezes start to happen more frequently. For me there is no real work going on in the gc. Temperature dropped 1° as soon as I played.
Second test fx off, borderless, terrain medium, materials low: still happening, more often around my ship. Gpu temp 51°
Third test fx off, borderless, terrain med, materials low, draw distance reduced to minimum: like the second test.
Foruth test: like above and changed the fx trail feature in the GraphicsConfiguration.xml to 0 for all settings: no change.
Fifth test: no reshade: no change.

Installed msi afterburner. Gpu usage is below 50%, Cpu below 40%. Freezes happen even if I dont do anything. I just sit in my ship on a planet surface. No moving things. Freeeeeze.
 
Last edited:
does it still freez after a 50hz msi slider downclock?
as I could swear this game works on the goldilocks zone principle hz too fast it don't like to slow either in the mid mmmmm just right
 
Last edited:
I'm willing to bet the OP &/or akibiades) has supersampling turned way up on both the in game settings and the HMD. Works just fine on my laptop 50-60fps steady at 1080p medium to high, though I do get a better experience at 1600x900.

Could, of course be very wrong though.
 
Last edited:
Hello!

Both ideas didnt do the trick. Downclocking had no effect, turning off aa had no impact at all. I did have supersampling on 1x. Never had any other setting. 0.5 or anything between this lowest setting and 1x resulted in extreme eye cancer.

My next idea was the pp. 650w is more than enough according to various website where you can enter your setup to figure out what you need.



Should I activate other settings in msi afterburner?

Next step: downgrading to my old r9 270x for proof of concept.

To do: playing another game. I dont have any installed, that will take time. After that.. flashing the gpu bios?

r9 270x:



No change in graphic settings. Random freezes just like before. So its either some serious hw issue on my side, the drivers or the game.
 
Last edited:
I'm willing to bet the OP &/or akibiades) has supersampling turned way up on both the in game settings and the HMD. Works just fine on my laptop 50-60fps steady at 1080p medium to high, though I do get a better experience at 1600x900.

Could, of course be very wrong though.
I haven't even tried it in VR at the moment. I'm running everything at low graphics, no frame limit, no v-sync and at 1080p. For the first 2 to 3 minutes everything is buttery smooth, then it starts glitching slightly and then gradually over the course of a couple of minutes I'm down to 5FPS or less - You can count the frames as they literally slide past.

Checking the resource use I can see that there are no other processes, either app or service, taking up processor cycles, in fact when ED is running and this happens I see a max processor use of 5% and GPU use is at around 3 - 5%.

All Nvidia drivers are up to date. My Windows 10 pro is however still at 1809.

Maybe I should give a test run on my iMac, which has the home version 1903 bootcamped onto it, to see if it improves the situation. The Mac should be able to handle it as it's got a Radeon Pro 580 (a slightly underclocked RX580) and an i5 3.8GHz (7600K).

Anyway thanks for all the suggestions. It's not critical that I get ED up and running, but it would be a "nice to have".
 
Updated to the new optional driver. Same thing. Now even the galmap is freezing and the gpu usage is dipping.

The september update happened on the 18th. My first planetary landing was on november 1st. It didnt happen before. So I guess its the game?!

Besides that the lower my settings are the more stuttering is happening. With low jet cones and volume effects every entry to a new system is accompanied by stuttering. Its just rediciolous at this point. Im gonna crank up the settings and bite the bullet. End of story.
 
So I guess its the game?!
Quite a few other people are not having these issues. Without a frame rate limit, the game fully loads my 1080 Ti at essentially all times and shows significant utilization of 7-8 threads total, two of them heavy, on my 4.2GHz 5820k. And I'm not seeing any appreciable stuttering; even those who are don't see to experience it as badly as you are.

I'm sure the game is a contributor, but something else is definitely wrong.
 
Dear OP
I run a very similar setup to yours, only that I have a GFX1080ti 11GB.
No problems at all. Smooth 60 fps (the maximum of my 2k screen) with all settings at ultra.
Unless I don't plug anyting in this USB 3.0 PCIe expansion card. Then the whole game is stuttering betwen 10 and 20fps, with massive micro freezes every few seconds. As long as anything is in there (even a memory stick), everything is fine.
 
Quite a few other people are not having these issues. Without a frame rate limit, the game fully loads my 1080 Ti at essentially all times and shows significant utilization of 7-8 threads total, two of them heavy, on my 4.2GHz 5820k. And I'm not seeing any appreciable stuttering; even those who are don't see to experience it as badly as you are.

I'm sure the game is a contributor, but something else is definitely wrong.
As I said I cranked up the settings. High, 90fps, etc.

Never even 60% gpu load. Never even 50% cpu load but stable 90 fps. Every game start is now pretty fast, on the other hand the first 20 seconds in game are 5 frames. Yes.. 5 frames in 20 seconds. After that buttersmooth. Unless I jump or come near a landable planet.

You are right, something is wrong. I did change my hardware in the last weeks. Last year I brought the pc to an expert shop, they put the ram in different slots, I never noticed this. It was running single channel until last week. The other thing is that my rx590 is brand new. I had the stuttering with the old r9 270x as well. So I bought the 590. Deleted the old drivers, as recommended. Now with the new gpu the stuttering and freezing became worse.

Could it be the psu?

3dmark fire strike score is 12 263. The pc didnt turn itself off.

Wait a minute. 3dmark says I cant run a directx12 test.
 
Last edited:
Good old trusty stable system with good enough Radion, and today my frame rate just halved itself for no reason. Gotta be something changed in the patches. (Or Microsoft has seized more resources and buggered things up).
 
I think I've got to the root of my particular problem.

Yesterday I tried to run ED in VR (Oculus store version) and it flatly refused to start indicating a fatal error. Steam version was the same as well.

So I did a bit of googling and it appears that I mistakenly installed some crapware from ASUS, namely SonicStudio which apparently causes problems with Oculus VR in many games. I forgive myself for this transgression as this is my first Windows PC ever and I've only had it about a week (I'm a UNIX, Linux, and Mac guy)

So I removed this and SonicRadar (also from ASUS), and also drivers for a Steinberg UR22 audio interface which was only installed as temporary measure.

The end result is that I've just had 30 minutes in VR with ED and no slow down whatsoever. I'm hopeful that this has also resolved the issue when playing in flatty mode as well.

Hopefully this might help some others who may have similar problems.

With regards to ED in VR - consider my mind totally blown - totally. I nearly crapped myself coming out of my first hyperspace jump even though I knew what to expect.

So thanks for your help.
 
Top Bottom