Need help on scaling...

I've created a few small simple items in Blender successfully (finally...). Now I have an object I'm trying to create using a SketchUp model of mine. Because of it's height, the object is broken into multiple parts so that each is under the 8m limit, then they can be stacked. Exported from SU as a .dae and imported into Blender just fine. UV unwrapped, texture applied, rotation and scaling applied, but I keep getting a message that the ,fbx is rejected as being too small. I've tried exporting using metric set to 1m as with it set to .01m, chnaged the scale by an increase of 100 as the tutorials said, applied rotaion and scale after I was done. While I'm used to SketchUp, Blender is new to me...anyone see any obvious settings I missed? Thanks for any help or suggestions!
 

Attachments

  • BlenderSettings.jpg
    BlenderSettings.jpg
    462.4 KB · Views: 21
  • TMTKerror.jpg
    TMTKerror.jpg
    190.8 KB · Views: 20
Hi,

as i have never tried TMTK with older Blender versions (that is < 2.8), i personally can only give you a suboptimal answer. Still, maybe this is helpful to you:

You say that you already managed to create a few small items in Blender directly. Could you successfully export those to TMTK? Are there any obvious differences in the settings/displayed dimensions? What happens if you reimport your .fbx file into Blender? Have you tried applying the location as well?

Some further notes:
Your Blender screenshot looks as if you were using an "old" version of Blender (that is, a version before 2.8). While 2.8 overhauled the UI almost completely (which could make you hesitant to switch), the .fbx exporter was also changed. With the current one, you will not need to do any scale-tinkering for static (that is, non-animated) objects. I slightly recall there being some trouble with the older exporters. Unfortunately, i cannot remember what the relevant workaround was. I think the old version required 0.01 unit scale (with this setting, the displayed dimensions would be the actual ones).

If it isn't too much trouble for you, i'd suggest trying to export it with a newer version of Blender (the current being 2.91). As you are using Windows, you can just download the portable version from the official website, so you don't have to commit to upgrading just yet if you don't want to.

If you want, you can also PM me and i can have a look at your .blend file directly (if you are willing to provide it to me).
 
Thanks for your help Gohax!

Yes, I was able to successfully create some rectangular signs in Blender and exported them to TMTK and they worked fine in-game. Yes, I'm using 2.79b, mostly because that's the version many of the tutorials used, so I purposefully went with it. Most of the tutorials for earlier versions required you to manually change the scale settings from 1.0 to 100. and then apply rotation and scale. One difference I noted was that on several tutorials when setting up Blender to start your project, they used metric and set it to centimeters (0.01), while several other one's used metric set to meter (1.0) I've tried both settings and got the same TMTK message.

I'll give a try to some of the things you suggested, and I'll download the new version of Blender.
 
Actually it was an error on my part setting up Blender and saving the template, I missed a step which was messing up the scale when importing a file from SU.

Thanks for the help Gohax, I appreciate it a lot!
 
Top Bottom