New Client broken - no Horizons?

I spent the last 3 days trying to get this to go.

Finally I tied to do install hitting the non-horizons button and it finally finished.

What a PITA
 

Viajero

Volunteer Moderator
If it helps, in my case whenever I run the game from my Steam pinned games list (which in my case has always been my go to way to play the game, Horizons included) or by clicking play (then vanilla) in my Steam library I still get the same error:



But when I select to run a specific sub game option (i.e. Horizons version, or VR version, not vanilla though) in the steam library I can get into the game:

 
Last edited:
try to start "\steamapps\common\Elite Dangerous\Products\elite-dangerous-64\EliteDangerous64.exe"

and after the program closed, try "\steamapps\common\Elite Dangerous\EDLaunch.exe" .. it worked for me.
Steam user, but not a LEP. I'd been having the issue where the shortcut that I've used for years suddenly started popping the launcher with the "Update Required" screen (even though there was no update pending). The above set of steps seems to have resolved this (at least when directly launching the executable. I've not yet tried placing the shortcut to the launcher on the desktop).

The other issue I'm having now, which I never used to have, is that executing the launcher is automatically starting SteamVR and Oculus Home. I've stopped Oculus Home from launching by having it require admin permissions to run, but SteamVR is still starting. I don't even have my Oculus headset or sensors plugged into the computer these days. :-/
 
Last edited:
Possible issue for Steam users getting the launcher to work but with them being auto-logged in:

Same individual also suggested taking Steam into OFF-LINE mode - that'll also kill the auto-log-in situation.
 
The http 404 error can be solved by changing "Options -> Select language..." from "Use System Defaults" to "English". Options menu can be accessed by left clicking your email address in right upper corner of the Launcher.

A big thank you to Frontier User #e337c94ade283f7 (unfortunately we can't see forum name or CMDR name in the issue tracker).
 
The http 404 error can be solved by changing "Options -> Select language..." from "Use System Defaults" to "English". Options menu can be accessed by left clicking your email address in right upper corner of the Launcher.

A big thank you to Frontier User #e337c94ade283f7 (unfortunately we can't see forum name or CMDR name in the issue tracker).
Aand HEY PRESTO! Give that man a hug from me! :)
 
Top Bottom