• Good news Guest, we've updated our reporting system to make it easier for you to report issues to us!

    Head over to https://issues.frontierstore.net/ to report, vote, and give feedback on the issues that matter most to you!

No improvement to menu load times with update 1.10.2 (sorry can't change prefix to 1.10.2)

Klötenkieker, that is my biggest frustration - everything was fine the night before the Toolkit update came out...then that next morning the menu load times increased tenfold. [wacky] [cry]
 
I can confirm I still have performance issues with the latest release, including incredibly slow menus. My problem is not as bad as Fisherman's, but it is enough to make the game less enjoyable. In fact I think FPS has gone down with the latest release, I used to get around 25 FPS in the scenario park I'm building, now it's around 19.
 
I've just been told that they cannot reproduce the problem and that menus open fast for them when testing my giant park on their computer. They're telling me it must be background processes running on my machine... But the game takes nearly all of my memory the whole time. I just don't get it.
 
Last edited:
Fisherman. Would you like to send your ppark to me. Let me see if I also encounter the same problem... If at least two people have the problem with the same park on two computers they can't ignore it.... Right?
 

Chante Goodman

Community Manager
Staff member
Fisherman, we are still dedicated to helping, we just cannot reproduce the same issue you have. The team will test your park with the TMT items - did you also send over the billboard images? TMT items can massively slow down a park if they are not made following the tutorial we created.
 
I'm putting all of that together now. I have about 70 toolkit items. And yeah. I'm seriously considering just deleting all the toolkit stuff from my park. That's a real shame though.

EDIT: Okay, I just sent him the link to my billboard files and links to the 67 toolkit items I used.
 
Last edited:
I think they know it's a problem, but on whatever machines they are testing it on, it seems to work fine. I wish I knew exactly what they're stats are for comparison. [blah]
 
Hang on... is 15 seconds supposed to be acceptable to load the menu? Because it did not used to be that slow.

I have posted videos of an empty sandbox park in other threads where the menus take 10 or more seconds to load on every single open. That shouldn't happen, and didn't used to happen on older versions. We know it can be better because it used to be better.

I could understand 5-10 seconds on the first load, but after that all of the items should be cached and it should open instantly. I'm testing on a computer with 32GB of ram, why isn't it used?
 

Chante Goodman

Community Manager
Staff member
That sucks man.. It seems like they aren't willing to acknowledge this as a problem.
Hang on... is 15 seconds supposed to be acceptable to load the menu? Because it did not used to be that slow.

I have posted videos of an empty sandbox park in other threads where the menus take 10 or more seconds to load on every single open. That shouldn't happen, and didn't used to happen on older versions. We know it can be better because it used to be better.

I could understand 5-10 seconds on the first load, but after that all of the items should be cached and it should open instantly. I'm testing on a computer with 32GB of ram, why isn't it used?
If you haven't already, please file bug reports so we can look into these issues for you!
 

heatherg23

Volunteer Moderator
This is the bug report.. Is it not.
If each person opens a bug report then they can help each of them directly as opposed to having to help 10 people within the thread. They would have a difficult time tracking your responses down within this thread.
 
If each person opens a bug report then they can help each of them directly as opposed to having to help 10 people within the thread. They would have a difficult time tracking your responses down within this thread.
Then why do they merge threads.. why if you post a bug will someone come and say.. this has already been reported... lots on inconsistencies. I feel like if i post a bug report they are just going to merge it with another. So why do a new one. I figured this woild be a response from someone... this is why i say what i have to say on my video channel instead cause i dont feel like its heard here or just swept under a rug or this forum only cares when they hear someone say how awesome they are. Lots of issues with the game that are considered.. working as intended... and lots of people who want to say "its your computer" they can say its not an issue all they want but the day the patch launched. They literally said they were awqre and still working on it. Again inconsistencies.
 

heatherg23

Volunteer Moderator
Chante gave instructions several posts above just follow those if you want YOUR issue looked into. She gave the instruction and it's up to you to follow it.
 
I think they are done looking into this issue. It could not be resolved. Just gotta accept it and move on...and make only small parks from now on.
 
Top Bottom