Oculus 1.13 Update - anyone having tracking problems?

Oculus Home 1.11 kinda publicly botched up tracking, I guess with multiple sensors. 1.12 apparently fixed a lot of that.
(I never had issues with either.)

But now with 1.13 I'm having some major tracking issues in ED. Here's what I see... Anyone else?
- Stations & supercruise & jumping all seem fine. No issues.
- Then, I went to a busy compromised nav, and started getting tracking issues
- The colors will fade out for a second, the image will jump, and then tracking will resume and colors go back to normal
- Happens every 5 seconds or so, randomly, so really annoying
- Problem went away immediately after jumping to supercruise

Observation: My CPU utilization is noticeably higher in the compromised nav. So... I'm thinking maybe the bad tracking is linked to high(er) CPU usage. CPU was not at 100%. But perhaps one of the cores is getting overloaded. I'm running a 6700k @ 4.4, so I think I should have plenty of horsepower.

I found an early thread on Oculus that might be related:
https://forums.oculus.com/community/discussion/51168/poor-tracking-tracking-problem-with-1-13-single-sensor-setup

Anyone else? Thanks!
 
Hmm. AI and geometry is significantly simpler in supercruise, with less models present (just your ship and the planets etc).

There might be some situations where you're not getting tracking data in time for the frame render - these frames will be the greyed-out ones you see when you 'lose tracking'. Chances are good the tracking is fine, especially if you're not moving much or simple obstruction i.e. by ducking under a desk etc where the sensor simply can't see you.
But you might be pushing detail too hard, even for a GTX1080.

My rig is pretty much identical to yours; i7 6700K, GTX1080 (same Gigabyte G1 Gamers card too), 16GB DDR4 3200 RAM, Rift CV1 and I'm not seeing the jumping in tracking at all. I have Touch, so am using a second sensor though.

What sort of detail settings are you using? Supersampling/HMD Quality settings?

Overall frame rate? If its really low can interfere with the tracking sometimes. If you're running HMD Quality at 2.0x for instance and med-high detail in ED, the GTX1080 will drop down to ASW 45fps mode and render the ASW synthetic frames in between the real rendered frames. But at high loads, sometimes even running in ASW mode at 45fps isn't enough. It might be that the tracking data breaks down at some points, and you see horrible judder, with loss of good tracking?

I always run with ASW turned OFF (ensure NumLock is on, then hit Ctrl-Numpad 1), and I press Ctrl-F to see the frame rate in the monitor window. If I see judder, I can peep out the Rift nose and see what the ED frame rate looks like. ED's displayed frame rate is correct for VR, even if your monitor is only showing 60fps.

If you turn ASW off, you might see a tracking improvement whilst seeing the true rendering performance your 1080GTX is capable of with your current ED detail settings.
Or, you might see that under normal "try for 90fps" without ASW, your tracking gets worse.

With 1080GTX, I run all Ultra, maxed detail settings with the following changes;
Motion Blur Off (minor performance gain)
Depth of Field Off (minor gain)
Ambient Occlusion Low (big gain here)
Shadows Medium (bit more here too)
Bloom Medium (I simply prefer less bloom)
Monitor window size really doesn't matter, the resize is virtually free.
ED Supersampling 1.0x
HMD Quality 1.25x (if I use the Oculus Debug Tool, I push Pixel Density a bit higher to 1.3)

If higher cpu usage is your issue, remember that has a knock-on effect in that it gives the GPU less time to render, forcing a drop to ASW.
 
Auto correct on phone!

Looking at the oculus forum there seems to be a glitch for those with only one sensor in the newest runtime.

Presumably the OP only has the one?

Red you must have two?
 
Last edited:
Yep. One sensor for me.

I think I found a temporary solution: process affinity.

I restricted "EliteDangerous64.exe" to cores 1-6, and "OVRServer_x64.exe" to cores 7-8. That seems to have done 2 things: tracking is fixed, AND it generally seems to have improved the smoothness overall. I'd get a single jitter rarely - nothing big, but noticeable. That seems to have gone now too. Interesting!
 
Last edited:
I use 1 sensor and I get similar grey outs at times. I also get the white flashes on a regular 10secs or so which I put down to Win 10 Update has reset much of my devices and not rid the cache to allow just what I need. I tried Disable USB Power Management but no result. Others have had these flashes in the past. I can only hope that it gets sorted and from now on I will not use Auto-Update for Oculus and Nvidia except Win10 which it should require regardless. So...how can we revert to v1.11 or 1.12?

Is this to do with any previous settings for Debug Tool I wonder as I can not get that to start. It tells me HMD is not connected but it's running!
 
Last edited:
Looking at the oculus forum there seems to be a glitch for those with only one sensor in the newest runtime.

Presumably the OP only has the one?

Red you must have two?
Yeah, I have Touch so I'm on two sensors like dogbite.

I wonder if the new Creator's update for Win10 withits game mode will help with the processor load balancing/affinities for CPU managmeent of reasources while using game software.

We certainly won't want it to put ED up on a maximum performance footing and then put the Rift sensor USB tracking on a low-priority back-burner so to speak!
 
Last edited:
I just tried System Properties>Advanced>Performance Settings>Advanced>Adjust for best performance of=Background Services
As this is the setting for music programs to allow recording and midi timing to sync. No difference but I select this anyways.
 
haven't noticed any tracking issues on my setup. i5 6600k, CV1 1.13
not tested much though, just departing a planet in System A to land on a planet in System B

Edit: Using 1 sensor
 
Last edited:
I restricted "EliteDangerous64.exe" to cores 1-6, and "OVRServer_x64.exe" to cores 7-8.
After several more tests, I can confirm the process affinity seems to have fixed the tracking problem for me.
And 1 confirmed fix for someone else too: https://forums.oculus.com/community/discussion/comment/509598/#Comment_509598

In fact, in my subjective view, I think the tracking is now significantly better than I've ever seen! I may lock process affinity permanently going forward! I have an AutoHotkey script that automatically assigns the process affinity on each launch.

Code:
#NoEnv
#SingleInstance force

SetTitleMatchMode RegEx
DetectHiddenWindows On

If 1 = exit                                   ; Allow command-line to close the script.  Run, %A_AhkPath% "Elite Watchdog.ahk" exit
  ExitApp


SetAffinity( name, mask ) { ; CPU is a bitmask
  Process, Exist, %name%
  hPr := DllCall( "OpenProcess", Int, 1536, Int, 0, Int, ErrorLevel )  
  DllCall( "GetProcessAffinityMask", Int, hPr, IntP, PAM, IntP, SAM )
  DllCall( "SetProcessAffinityMask", Int, hPr, Int, mask )
  DllCall( "CloseHandle", Int, hPr )
}


Loop {
  WinWait ahk_exe EliteDangerous64.exe
  SetAffinity( "OVRServer_x64.exe", 192 )
  SetAffinity( "EliteDangerous64.exe", 63 )
  WinWaitClose
}
 
Last edited:
Since 1.13 everything works fine(dk2/1 sensor) for a few minutes but then hmd disconnects. This happens everytime now so cant play for more than 10-15 minutes at a time!!!
I have heard that oculus beta opt fixes this issue so I will try that tonight .
I wish there was a way to disable oculus auto-updates!

edit: oculus beta did not help my case.
 
Last edited:
Any update on this problem ? Running on GTX1080 here, 1 sensor (no touch), i get the grey flashes / loss of tracking every few seconds, makes the game unplayable. I understand i can fiddle with something (process affinity) but it used to run fine without touching anything ? (edit) tried fiddling with affinity settings, it's not helping any.
 
Last edited:
Some have said that it must be a Windows Update USB issue as a complete re-install of OS has fixed it for them. I can get around it with setting Affinity and it actually stays after any reboot for Oculus programs so only needs ED64 to get setup each time.
 
Issue happens in Elite Dangerous *only*. I just completed Chronos and that went perfectly. Played Pinball FX for a few hours in VR without any issue either.

Affinity doesnt fix the issue. And last thing i want is a complete Windows reinstall, first it's stupid, then i'm ready to bet money it wont fix anything... I'll wait for next patch.
BTW it appeard on latest patch. 2.3.0 was fine, played quite a few hours without any glitch.
 
Last edited:
I decided to go ahead and put a little GUI around the AutoHotkey script I use to automatically detect and manage the process affinity setup. The affinity does seem to fix problems for multiple people, and for me just makes VR smoother in general.

No laughing at my (lack of) GUI skills :). I keep the app in my tray all the time, and it just watches for ED and adjusts accordingly.
I may try to add in process priority settings as well, as that seems to have helped others.

So... Give it a try - maybe it will help.
Suggestions welcome.

https://github.com/rkodey/ED-Affinity

There's a compiled stand-alone version that requires no install of anything:
https://github.com/rkodey/ED-Affinity/releases/download/0.1/ED.Affinity.exe

IMPORTANT: You probably need to launch the app with "Run as Administrator", or else it may not be able to adjust the process settings. It may depend on how you launch ED.
 
Last edited:
Top Bottom