Ok is it just me or are the servers the worst they've ever been today?

I don't know if this is Easter Sunday, or some change they have made related to the new "Network" options in the options menu but the game has never been as unplayable for me as it is right now.

12 minutes hyper jump followed by a 16 minute hyper jump, followed by a disconnect (the servers remained greyed out until i reopned the game 5 mins later).

Went back in, 6 minute hyper jump followed by disconnect rinse repeat.

My internet is fine, and this is the first time its ever been this unplayable.

Anyone else having issues here?
 
Last edited:
Yesterday, I was unable to select any game mode for a solid five minutes (It was ghosted out). Then I realized I was downloading Steam game updates. I reduced the Steam max download speed to a third of what I had set and was able to log on instantly and played for four hours without issue.

Windows updates, AV definitions, and BitTorrent will do the same thing.
 
I've been having issues on and off since the update. Haven't logged on today, though. Yesterday I got disconnected a couple of times, then lost the mission server completely so gave up at that point.
 
I don't know if this is Easter Sunday, or some change they have made related to the new "Network" options in the options menu but the game has never been as unplayable for me as it is right now.
No, it's you!

It's more stable than it has been recently for me.
 
Interesting.

I have nothing in the background going or updating, only affected thing is the game. I almost needed fuel rats, disconnected on the same jump 6 times and had no fuel left!

- - - Updated - - -

Been kicked out 3 times today, and experienced some >30s hyperjumps too.
Just to see if we can narrow it down..

I live in England and am using Virgin Media 100mbs Fibre.

If anyone else is having difficulties and have a similar ISP/situation to above let me know.
 
I had matchmaking errors earlier today. I'm on a fiber connection in America. Seems to have lasted for about half an hour, but things seem fine now.
 
The servers have been rubbish since 2.3

Today takes the cake, though. This is the first time I've ever felt that a patch made the game unplayable.
 
I've been getting it all weekend here in the US as well. So don't think it's the local media at all, but the servers in general. Fri wasn't nearly as bad at Sat. I had to reset my router thinking that was the issue and then realizing it wasn't...
 
Top Bottom