Over Four years since release and Frontier still hasn't fixed the Vive scaling issue...

Every time I load up this game I am disappointed that the world scale issue still persists. With the Vive, and now my Vive Pro, I have the body of a small child and everything feels much too small.

Compare this to my wife's Rift, where the character body is appropriately sized, the world is appropriately sized, and cockpits are large and cavernous. It is a completely inferior experience on Vive/Vive Pro. I see this mentioned from time to time here on the forums but many people seem oblivious to this. I've wined about it for years now but FDEV have yet to even comment on the issue, and no third party fix exists.

For a game where immersion is so central to the experience, having the world scale completely off pretty much ruins the experience.
 
Every time I load up this game I am disappointed that the world scale issue still persists. With the Vive, and now my Vive Pro, I have the body of a small child and everything feels much too small.

Compare this to my wife's Rift, where the character body is appropriately sized, the world is appropriately sized, and cockpits are large and cavernous. It is a completely inferior experience on Vive/Vive Pro. I see this mentioned from time to time here on the forums but many people seem oblivious to this. I've wined about it for years now but FDEV have yet to even comment on the issue, and no third party fix exists.

For a game where immersion is so central to the experience, having the world scale completely off pretty much ruins the experience.
Have you tried the below?

If you use SteamVR you can easily adjust your IPD
  • Start SteamVR.
  • Go to your internet browser and enter:
  • In the "Type a command" input box (bottom of the page) enter:
    • settings steamvr.ipdOffset -0.00XX
  • Note: The offset value is in meters, if you want to reduce IPD by 3mm, enter 30 there - i.e
    • settings steamvr.ipdOffset -0.0030
  • Restart SteamVR.
I set an offset of -0.0030 in mine and now with my Vive Pros physical IPD set to my actual IPD the games scale actually looks correct. Without using the above offset things look a little on the small / thin side.
PS - The consumer version of the HTC Vive was released on 7 June 2016, so just a touch over 3 years ago ;)
 
Last edited:
Every time I load up this game I am disappointed that the world scale issue still persists. With the Vive, and now my Vive Pro, I have the body of a small child and everything feels much too small.

Compare this to my wife's Rift, where the character body is appropriately sized, the world is appropriately sized, and cockpits are large and cavernous. It is a completely inferior experience on Vive/Vive Pro. I see this mentioned from time to time here on the forums but many people seem oblivious to this. I've wined about it for years now but FDEV have yet to even comment on the issue, and no third party fix exists.

For a game where immersion is so central to the experience, having the world scale completely off pretty much ruins the experience.
They don't care about VR as much. They consider it a low priority.
 
Have you tried the below?
Well what do you know, this actually worked. Flipping up my headset and looking down at my arms and then my ingame arms, they are pretty much exactly the same size. I adjusted this value to extremes to make sure I wasn't making it up and positive values shrink the world and negative values increase the size of the world. I can't believe I haven't known about this all this time... I don't yet know what the downsides to this are or if I will develop some sort of eye strain but the initial results are promising.

To you, I wish you all the good things in life
 
Last edited:
Well what do you know, this actually worked. Flipping up my headset and looking down at my arms and then my ingame arms, they are pretty much exactly the same size. I adjusted this value to extremes to make sure I wasn't making it up and positive values shrink the world and negative values increase the size of the world. I can't believe I haven't known about this all this time... I don't yet know what the downsides to this are or if I will develop some sort of eye strain but the initial results are promising.

To you, I wish you all the good things in life
No worries mate, I only stumbled across this a couple of weeks ago myself, I did post it in another thread but useful information tends to get burried quite quickly. The workaround seems to work well for me and I've not noticed any adverse effects myself - hopefully the same will be true for you also.

As well as this works it is obviously no real substitute for an actual 'world scale' slider in game which would resolve the problem without forcing people to look for obscure settings in SteamVR.
 
You can also edit the config files manually before starting SteamVR. The file you need is:
{Steam Install Directory}\config\steamvr.vrsettings

The setting you want to edit is steamver:ipdOffset

Mine looks like the following:
JSON:
   "steamvr" : {
      "activateMultipleDrivers" : true,
      "allowAsyncReprojection" : true,
      "allowInterleavedReprojection" : false,
      "background" : "C:\\Program Files (x86)\\Steam\\steamapps\\common\\SteamVR\\resources\\backgrounds\\night_mountains.png",
      "basestationPowerManagement" : true,
      "doNotFadeToGrid" : true,
      "enableHomeApp" : false,
      "forceFadeOnBadTracking" : false,
      "installID" : "17613157252782615991",
      "ipdOffset" : -0.0040000000260770321,
      "lastVersionNotice" : "1.5.7",
      "lastVersionNoticeDate" : "1560301760",
      "mirrorView" : 1,
      "mirrorViewGeometry" : "-1713 183 1604 908",
      "mirrorViewGeometryMaximized" : true,
      "playAreaColor" : "#FFFFFF00",
      "showStage" : true,
      "supersampleManualOverride" : true,
      "supersampleScale" : 1.5
   },
 
Top Bottom