Performance much worse?

Is anyone else seeing a massive performance decrease with the Odyssey Alpha compared to Horizons? I normally get around 100 to 120 fps in Horizons, I'm trying Odyssey and I am getting 15-35 fps with the same resolution/settings? Mostly about 15 fps. It's totally unplayable for me.

I have an i5 overclocked to 4.6 Ghz and an EVGA GTX 1060 6GB GPU, 16 GB ram, M.2 drive and play at 1080p on a 165hz monitor. According to FDEV Odyssey should run exactly the same as Horizons does but it's definitely nowhere near for me, unless something is wrong?
 
Same here, even for an Alpha, something is definitely not right with the performance, getting about 35~fps on some planets without atmosphere.
About 100-90 in stations where i was getting about 220+ before (Not talking about station interiors, where i'm getting between 60 and 110+)
Running on ultra no SS+SMAA at 1080p on a 9900K at 5.1Ghz and a RTX 2080 OC'd.
 
O_O''
worse than i thought, guess i will have to wait better times to try it on my i7-6xxxhq 2.6GHz with a 980M
 

Paul_Crowther

Community Manager
Frontier
Hi there,

As mentioned in the announcement last week:

"Please note that as this is an Alpha phase, a large amount of optimisation work for the final release is yet to be completed. As with all pre-released content, please be aware that you may encounter bugs and inconsistent performance as part of your experience."

This means what you are experiencing is not the final version of the game and as such you may encounter performance drops and issues. Our developers will be constantly working to improve the experience as the Alpha continues and beyond.
 
I understand it's Alpha! Alpha doesn't normally mean that the game won't play beyond 15 fps! Especially when your PC normally runs the Horizons version of the game almost 10 times better than that.

I'm not even on a planet. I can't get out of the first station. I'm in the same room where you start. Almost everywhere it's around 15 fps, there is one spot where it jumps up to 35.

I am watching D2EA and he is playing the game at much more normal FPS (around 100 fps). If the performance was down to the Alpha then it would be around the same for everyone.
 
Hi there,

As mentioned in the announcement last week:

"Please note that as this is an Alpha phase, a large amount of optimisation work for the final release is yet to be completed. As with all pre-released content, please be aware that you may encounter bugs and inconsistent performance as part of your experience."

This means what you are experiencing is not the final version of the game and as such you may encounter performance drops and issues. Our developers will be constantly working to improve the experience as the Alpha continues and beyond.
So you are saying that some people, i.e. - me, could get 15 fps when others, i.e. D2EA, with a similar PC can get 100 fps?
 
Yes, try to disable things like shadow and effects. On linux just enabling shadows of menus cut offs half of FPS in any game.
I know that changing graphics settings can improve the FPS. It just seems like something isn't right when the FPS is sooo much worse with this Alpha compared to Horizons.

I know it's Alpha and yes it's not fully optimised so we can expect a slightly worse performance on the same hardware but I can play Star Citizen at 4k miles better than this! There's something wrong for me.
 
I know that changing graphics settings can improve the FPS. It just seems like something isn't right when the FPS is sooo much worse with this Alpha compared to Horizons.

I know it's Alpha and yes it's not fully optimised so we can expect a slightly worse performance on the same hardware but I can play Star Citizen at 4k miles better than this! There's something wrong for me.
Raise a ticket on the issue tracker.
 

Slopey

Volunteer Moderator
Try resetting the quality down to Low then up to High again. If you were flying around in the base game on Ultra with 2x supersamplling, you're going to have issues in the station. I had 15fps on Ultra initially, but setting it to Low then High defaults gets me 60+ in the station, 40 in the hangar and 40-60 on the surface (3060Ti with 5600x proc)
 
That other spacelegs game alpha is stuck with similar frame rates. Fidelity!
Star Citizen = 4k resolution runs at about 25 fps for me. 1080p resolution runs at about 50-60fps.

Horizons = 1080p runs between 100-140 fps (100 is about the absolute lowest)

Odyssey Alpha = 1080p resolution runs at about 15 fps for me.

hmmm.... not so similar for me.
 
Try resetting the quality down to Low then up to High again. If you were flying around in the base game on Ultra with 2x supersamplling, you're going to have issues in the station. I had 15fps on Ultra initially, but setting it to Low then High defaults gets me 60+ in the station, 40 in the hangar and 40-60 on the surface (3060Ti with 5600x proc)
I have it on custom settings, mostly ultra with the odd setting like shadows turned down. I'm on 1.5x supersampling at the minute. Like I said though the PC runs Horizons with the same settings at the same resolution almost 10 times better. We were told that the system requirements for Odyssey would be the same as they were for Horizons so I was not expecting such a massive drop in performance, despite it being an Alpha.
 
I have a pretty beefy system so I am brute forcing to a very stable 90 to 120 fps most of the time but the fps drops harshly when you book a flight with apex. Something happens there.

The game is not optimized yet though that's for sure. I do see dips and pop-ins. Textures loading in too late. It's normal stuff I expevcted. I wouldn't worry too much to be fair. They will iron this out.
 
Top Bottom