Hardware & Technical Saitek X52 Pro on USB3.0 (Intel Z97 chipset)

After I installed Windows 10, the MDF started being unstable. It would turn off sometimes and fail to display all text. I ended up getting a Thrustmaster Warthog HOTAS. Never going back to Saitek :)
To be fair, Saitek have said this is expected behavior in W10 and are working on a fix for their fix.

http://madcatz.kayako.com/Knowledgebase/Article/View/604/46/windows-10--saitek-hotas-beta-drivers-and-software-release

The only fault I experience on my setup is that it's stopped showing Mode X text on the MFD when in No Profile, and the MFD brightness flickers after PC power-off until set again. It only does this on one machine, not a big deal for me really - never notice it in the DK2 :d

Now if you really want to see an example of driver failure on W10, try Fujitsu and their ADF flatbed scanners. Completely inoperable, and it's a $5k scanner.
 
Last edited:
I tried to contact support for Saitek and never got a reply. I tried to submit a ticket and even posted a rather civil comment on a MadCatz facebook page for Saitek products. A few days later that facebook page was deleted.

I could probably make the product work and be patient and wait for a fix for the MFD. But when MadCatz are blackballing Saitek products I figured it was best to abandon it altogether. Going to try to sell it.
 
I found this website, and thread, after days and days of Googling, and I might have found what I was looking for, so I have just registered to reply to this thread...

I have had a new PC put together recently (Win7 x64) to run MS Flight Simulator. I use a Saitek X52 as my 'flight controller'. I have spent a lot more time over the past few weeks trying to troubleshoot problems with the X52 freezing up than enjoying the flightsim however; this also causes the N52 keypad also to stop working at the same moment, and even lead to BSODs (today 'System_Service_Exception', but I have had quite a selection) over the past few weeks,

The first thing I learned here (supported elsewhere) is that the X52 does not like the Intel controllers for USB3.0. I found I had my Nostromo N52 keypad and the Saitek X52 plugged into a USB3.0 port, so have moved it to a USB2.0 port now. It seems though, from what I read, that this won't make any difference. Norcus, you suggested using a different USB controller altogether, but I have no idea how to ascertain whether a different one is available or not on my M/B. Would you, or anyone, have any idea? My M/B is an Asus H971 Plus (mini form). In the interim, I have gone for your 'emergency' suggestion, and disabled xHCI in the BIOS. I then did a clean reinstall of the Saitek driver and SST software, and so far (though it is early days yet, I have only tested for a couple of hours) I have had no problems.

Clearly I would like to get my USB3.0 back if possible, so any help would be very welcome. If I still get problems with the X52, I'll post back. I hardly dare think that it will be OK after all these weeks of frustration!!

Thanks,

Martin
 
I've used both USB 2 and 3 and have had numerous issues where my X52 pro just stops functioning. Tonight I even reinstalled Windows 10 x64 and the only thing i installed was the latest nvidia drivers, elite, and the x52 software so i could load my custom profile and use all of the buttons n dials. It failed after my first interdiction not 15 minutes into the game. My ship has been destroyed too many times because this hardware has failed me.

Mind you... it seemed to be working fine before Horizons...? Elite update? Windows update? What is the culprit?

[EDIT]

Mad Catz Support had this to say:

"After the major Windows 10 update (build 1511) there have been a few reported issues with Microsoft."
 
Last edited:
Until I can find a way of replacing the Intel USB3.0 controller, I have disabled xHCI (i.e. USB3.0) in the BIOS. I have had no crashes or problems since then. As I only use this PC for Flight Simulator, losing USB3.0 is not a huge annoyance, but I am going to email Saitek again (they did reply to my previous email at least).
 
I am using a Z97 motherboard with the X52 before and X52 pro now connected to a USB 3.0 port without any issues.
I was running Windows 8.1 Pro and now Windows 10 Pro.

If I am not mistaken Windows 7 is not recognizing USB 3 devices
 
Hi everyone,

the problem still isn't fixed!
I got my rift cv1 and it requires.... USB3.0! So i reactived xHCI in UEFI und rebooted, installed all the latest drivers from intel and saitek, plugged in my x52 pro and got a completely frozen system in reward. So i can play elite with my rift OR with my x52 pro hotas... well done saitek, never again!

*EPIC SLOW CLAP*
 
I have a faulty X52 that used to work ok(ish) on my Z97 boards USB3 ports. But due to the bad quality found internally after 3 electrical faults, went looking for replacement. There was of course the mechanical failure of the throttle detent as well.
First tried a CH throttle and stick that refused to be recognised or work with ED, the stick would work, sort of, with the plain joystick choice, but no luck with the throttle.
Luckily the trader would it back when I said I would get a Warthog. This also had problems with USB3, even on a high powered USB3 hub. A bit of googling and I discovered others had USB3 problems with all sorts of equipment, and the main solution offered was USB2. Tried it and not seeing any problems, even though it has to be plugged into the USB2 Hub on the monitor, (power output unknown) as only one USB2 port is accessible without changing case front panel connections to usb2 mobo port instead of the usb3 port.

As I had not sent the CH equipment back at that stage I unpacked it again and tried that on USB2, it worked.

So until a maker supplies one that is specifically USB3 compatible, my advise is always plug joysticks et al into USB2.
 
Last edited:
Top Bottom